Any users happily running a Firewire interface on Win 10?

Configure and optimize you computer for Audio.
KVRAF
2227 posts since 9 Jun, 2002 from East of Santa Monica

Post Thu Jan 14, 2021 8:24 am

I love all three of my FW interfaces (Steinberg MR816X, TC Electronic Konnekt 24D and Konnekt 6): Rock solid drivers, great sound... basically they just work.

Things is, I'm still on Win 8.1. I've heard too many stories about how temperamental Win 10 is, especially as it relates to Firewire support.

For example, Focusrite's support page confirms that my Firewire PCIe add-on card - an older TI chipset rock-solid under Win7/8 - started causing problems under Win 10, so they don't recommend it anymore. While they did suggest a different card-chipset for Win10, the fact they discontinued their own FW line of interfaces doesn't exactly instill me with confidence.

Obviously I know I could ditch the FW units and go with USB 2/3 -- but like I said, my setup ain't broke, and If I can upgrade the O.S. without breaking anything else, I'm good for a few more years!

I know there are a quite a few FW interface owners out there on Win 10. I'd love to hear from those of you running a solid setup: What's your interface, and the FW chipset you're using? Current or legacy drivers? Do you keep Win 10 fully updated, or not?

TIA :) :ud:

User avatar
KVRAF
6778 posts since 8 Feb, 2003 from London, UK

Post Thu Jan 14, 2021 11:15 am

My Audiofire4 is still holding on. Last driver update was... a while back! (Just after Windows 8 came out.) Doesn't work with everything... but Reaper is fine. For my new computer I got a Zoom UAC-2... Which is nice and new.

User avatar
KVRAF
2275 posts since 13 Jun, 2008 from Napier,New Zealand

Post Thu Jan 14, 2021 11:42 am

My Presonus Firestudio started to have issues. It worked fine with older versions of Windows 10, but with newer versions I was getting a lot of audio drop-outs, on play-back and recording. I'd love to just use an older/stable version of Windows 10, but I use that computer on the net, and haven't been able to work out any way of successfully stopping the updates. Anyway, the hardware hadn't actually been supported since Windows 7, so I bit the bullet and got a Tascam USB one... And it sucks. :dog: :hihi:

User avatar
KVRAF
10848 posts since 26 Jun, 2006 from San Francisco Bay Area

Post Thu Jan 14, 2021 11:46 am

I’m using a UAD FireWire 8 on the latest version of Windows with no problems.
Zerocrossing Media

4th Law of Robotics: When turning evil, display a red indicator light. ~[ ●_● ]~

User avatar
KVRist
225 posts since 2 Sep, 2012

Post Thu Jan 14, 2021 2:41 pm

Allen & Heath zed r16 using firewire with no problems.

KVRer
7 posts since 21 Dec, 2020

Post Thu Jan 21, 2021 12:38 pm

I still struggle with my Fireface 800 glitching out of stand by under Windows 7, with awful spitting white noise.

User avatar
KVRist
75 posts since 3 Jan, 2021

Post Thu Jan 21, 2021 12:42 pm

"started causing problems under Win10" - makes me curious about the specific nature of such problems.

KVRian
1096 posts since 20 Nov, 2004 from Seinäjoki, Finland

Post Thu Feb 04, 2021 9:07 am

Focusrite Saffire DSP 24 here on Windows 10. No FW issues whatsoever.
***************************
Truly mind-boggling music! - New album out! - And a blog!

User avatar
KVRAF
10848 posts since 26 Jun, 2006 from San Francisco Bay Area

Post Thu Feb 04, 2021 9:45 am

Deleted
Zerocrossing Media

4th Law of Robotics: When turning evil, display a red indicator light. ~[ ●_● ]~

User avatar
KVRAF
5709 posts since 9 Dec, 2008 from Berlin

Post Thu Feb 04, 2021 10:05 am

My GF also runs her Focusrite Saffire DSP 24 on Windows 10 for years without issues.
I think it runs on the motherboard Firewire port, no idea what the chipset is though, IIRC it's an old Asus board with one of the early 4 core i7s.

Cheers,

Tom
"Out beyond the ideas of wrongdoing and rightdoing, there is a field. I’ll meet you there." - Rumi
ScreenDream|Thomas Helzle 8) Twitter

KVRist
276 posts since 13 May, 2003

Post Thu Feb 04, 2021 1:24 pm

I used an MR816 without problem (with a pci card) for several years (at some point the MR816 stopped functioning, but that wasn't WIn10 related)

KVRian
1344 posts since 25 Nov, 2008 from Seattle, WA

Post Sat Feb 13, 2021 5:16 pm

Anyone using a Profire 2626 on win10?

KVRAF
2797 posts since 4 Jan, 2005

Post Sat Feb 13, 2021 5:36 pm

I've moved on from my Echo Audiofire4 firewire to a Native Instruments komplete audio 6 mk2 usb2 device . Firewire worked best on Windows7 and XP. I'm very happy with the newer device .

Return to “Computer Setup and System Configuration”