Mac OS Monterey - Plugin Compatibility

Configure and optimize you computer for Audio.
sQeetz
KVRian
692 posts since 8 Jan, 2005

Post Sun Oct 31, 2021 10:38 am

aMUSEd wrote:
Sat Oct 30, 2021 7:57 am
I'm surprised Open GL is still supported on Monterey - weren't they going to phase it out on Mac?
All I know, is that enabling OpenGL on Softube plugins on Big Sur lead to massive graphic glitches, but since Monterey it is the opposite. OpenGL when off is slow and sluggish. Turning it on makes scrolling around on e.g. Modular smooth as butter.
MacBook Pro M1 . 16GB . 1TB . . Logic Pro……Renoise……Reason

Bombadil
KVRAF
7315 posts since 31 Aug, 2013 from Down the Withywindle

Post Sun Oct 31, 2021 11:48 am

sQeetz wrote:
Sat Oct 30, 2021 10:44 am
aMUSEd wrote:
Sat Oct 30, 2021 7:57 am
sQeetz wrote:
Tue Oct 26, 2021 12:35 am
That was my experience. yep.
I'll have to correct myself: not everything is working. Both XLN plugins I have don't work properly. Addictive Keys and Addictive Drums. They play allright, but the GUI is just black.
On the other hand: Softube plugins now work with OpenGL enabled, what leads them to run a lot smoother than before.
I'm surprised Open GL is still supported on Monterey - weren't they going to phase it out on Mac?
I cantacted them and they put me on a trial version of AK and AD. It's working now
ARM native?
“Always after a defeat and a respite," says Gandalf, "the Shadow takes another shape and grows again."
J.R.R. Tolkien

sQeetz
KVRian
692 posts since 8 Jan, 2005

Post Sun Oct 31, 2021 11:54 am

Bombadil wrote:
Sun Oct 31, 2021 11:48 am
sQeetz wrote:
Sat Oct 30, 2021 10:44 am
I cantacted them and they put me on a trial version of AK and AD. It's working now
ARM native?
Unfortunately no... :? not yet
MacBook Pro M1 . 16GB . 1TB . . Logic Pro……Renoise……Reason

Bombadil
KVRAF
7315 posts since 31 Aug, 2013 from Down the Withywindle

Post Sun Oct 31, 2021 11:55 am

Thx. I asked them about that for Big Sur and the reply I received was very vague.
“Always after a defeat and a respite," says Gandalf, "the Shadow takes another shape and grows again."
J.R.R. Tolkien

sQeetz
KVRian
692 posts since 8 Jan, 2005

Post Sun Oct 31, 2021 12:26 pm

Bombadil wrote:
Sun Oct 31, 2021 11:55 am
Thx. I asked them about that for Big Sur and the reply I received was very vague.
They will eventually get there. I can't wait to ditch Rosetta...
MacBook Pro M1 . 16GB . 1TB . . Logic Pro……Renoise……Reason

Bombadil
KVRAF
7315 posts since 31 Aug, 2013 from Down the Withywindle

Post Sun Oct 31, 2021 1:30 pm

Then we'll see what these machines can do, though I ain't complaining too hard. I haven't made the switch to Monterey, so ADD2 and ADK still work fine here.
“Always after a defeat and a respite," says Gandalf, "the Shadow takes another shape and grows again."
J.R.R. Tolkien

collider
KVRist
270 posts since 14 Jun, 2018

Post Sun Oct 31, 2021 2:14 pm

sQeetz wrote:
Sun Oct 31, 2021 10:33 am
collider wrote:
Sat Oct 30, 2021 12:07 pm
sQeetz wrote:
Sat Oct 30, 2021 10:44 am
I cantacted them and they put me on a trial version of AK and AD. It's working now
How come that?
Contacted support telling that since the update to Monterey the plugin window is just black, then a guy named Gustaf from XLN wrote back telling that he flipped a switch for my account and that if I start the XLN Online Installer there will be new test release versions for AKeys and ADrums waiting to be installed.
So, they have working updates to be release soon. Thanks!

darkinners
KVRist
31 posts since 28 Aug, 2021

Post Mon Nov 01, 2021 1:57 am

All my Softube plugins look like this in my new 14" Macbook Pro M1 Max 64GB laptop under Monterey.
Anyone also experience this issue?
Image

alexekki
KVRer
1 posts since 6 Nov, 2014

Post Mon Nov 01, 2021 2:22 pm

I can confirm that neither Nimbus nor R4 are working in Monterey (but they did work in Big Sur). Not only do they crash the validation in Logic Pro (both in native and in Rosetta mode), they even instantly crash any project on which you have an instance of them.

XLN Audio RC-20, on the other hand, is weirdly working fine for me, i.e. the GUI is normal, not black.

Bombadil
KVRAF
7315 posts since 31 Aug, 2013 from Down the Withywindle

Post Mon Nov 01, 2021 6:07 pm

Anyone with IK stuff functioning on all cylinders?
“Always after a defeat and a respite," says Gandalf, "the Shadow takes another shape and grows again."
J.R.R. Tolkien

corneliusw
KVRer
12 posts since 13 Sep, 2007 from melbourne

Post Thu Nov 04, 2021 3:07 am

darkinners wrote:
Mon Nov 01, 2021 1:57 am
All my Softube plugins look like this in my new 14" Macbook Pro M1 Max 64GB laptop under Monterey.
Anyone also experience this issue?
Image
Same issue on my 16” M1 Max 64GB. Sadly it’s the only thing stopping me from using this computer as everything else essenital seems to work.

darkinners
KVRist
31 posts since 28 Aug, 2021

Post Thu Nov 04, 2021 6:30 am

corneliusw wrote:
Thu Nov 04, 2021 3:07 am
darkinners wrote:
Mon Nov 01, 2021 1:57 am
All my Softube plugins look like this in my new 14" Macbook Pro M1 Max 64GB laptop under Monterey.
Anyone also experience this issue?
Image
Same issue on my 16” M1 Max 64GB. Sadly it’s the only thing stopping me from using this computer as everything else essenital seems to work.
Hey I found the fix, if you haven't already, please install Saturation Knob. This one will display correctly.
In your DAW, open saturation knob and click the "cog" icon at the upper right corner, scroll down and disable OpenGL (this option is global to all softube plugins).
After you disable OpenGL , close the DAW, reopen the DAW and now all your Softube plugins will display correctly.

dayjob
KVRAF
1894 posts since 6 Nov, 2006

Post Fri Nov 05, 2021 9:01 pm

alexekki wrote:
Mon Nov 01, 2021 2:22 pm
I can confirm that neither Nimbus nor R4 are working in Monterey (but they did work in Big Sur). Not only do they crash the validation in Logic Pro (both in native and in Rosetta mode), they even instantly crash any project on which you have an instance of them.
same here. tried multiple DAWs and no luck. they instantly crash everything.

and as of now there is no update planned per Izotope's list of apple silicon pending update schedule.

https://support.izotope.com/hc/en-us/ar ... ty+updates

Image

will add that UVI Relayer won't work for me on apple silicon/monterey

corneliusw
KVRer
12 posts since 13 Sep, 2007 from melbourne

Post Sat Nov 06, 2021 3:53 pm

darkinners wrote:
Thu Nov 04, 2021 6:30 am
Hey I found the fix, if you haven't already, please install Saturation Knob. This one will display correctly.
In your DAW, open saturation knob and click the "cog" icon at the upper right corner, scroll down and disable OpenGL (this option is global to all softube plugins).
After you disable OpenGL , close the DAW, reopen the DAW and now all your Softube plugins will display correctly.
Amazing! That totally works and all Softube plugins run perfectly. Thank you

User avatar
waltercruz
KVRAF
2143 posts since 4 Dec, 2011 from Brasília, Brazil

Post Sat Nov 06, 2021 4:20 pm

alexekki wrote:
Mon Nov 01, 2021 2:22 pm
I can confirm that neither Nimbus nor R4 are working in Monterey (but they did work in Big Sur). Not only do they crash the validation in Logic Pro (both in native and in Rosetta mode), they even instantly crash any project on which you have an instance of them.
Nimbus, R4, Trash and some others won't be supported on M1.

https://support.izotope.com/hc/en-us/ar ... le-silicon

Return to “Computer Setup and System Configuration”