Ableton Live 9 Suite Tonespace VST Help

Official support for: mucoder.net
acemitch2k420
KVRer
3 posts since 16 Jun, 2016

Post Thu Jun 16, 2016 3:35 pm

Hello

First of all this app is awesome! Great work mucoder. I'm having difficulties getting Ableton to recognize the renamed .component file to .vst though. It shows up fine as a audio unit but I can't get those midi notes generated in tonespace to feed into my other midi vst since I can't get the vst version to show up. I read about a way to run it as a standalone and then feed those notes back into Ableton, but if there is a way to get the vst version to show up and run that'd be great since it appears to work so easy with vst synths that way. Any help would be great thanks so much!

I'm running OS X El Capitan 10.11.4 and I have a legit licensed copy of Ableton

Thanks again

UncleAge
KVRAF
1502 posts since 11 Jun, 2005 from Phoenix, Arizona

Re: Ableton Live 9 Suite Tonespace VST Help

Post Thu Jun 16, 2016 4:19 pm

acemitch2k420 wrote:I'm having difficulties getting Ableton to recognize the renamed .component file to .vst though.
You tried to change the au extension to vst?

acemitch2k420
KVRer
3 posts since 16 Jun, 2016

Re: Ableton Live 9 Suite Tonespace VST Help

Post Thu Jun 16, 2016 6:55 pm

Hey UncleAge

Yes I put the .component file into the components folder and made a copy then renamed the extension to .vst and put that one into the vst folder. Still no luck :(

UncleAge
KVRAF
1502 posts since 11 Jun, 2005 from Phoenix, Arizona

Re: Ableton Live 9 Suite Tonespace VST Help

Post Thu Jun 16, 2016 7:48 pm

Firstly I am on 10.9.5 not El Capitan. Secondly I run Live 8-32bit and Reaper 4-32&64bit.

Ok, I downloaded the latest version of Tonespace.
I copied the Tonespace.component file into my "MacintoshHD/Library/Audio/Plugins/VST" folder.
I changed the extension form "component" to "vst" and it worked. It loaded up in each daw.

Please check that you are putting the file in the same directory that Live is scanning for VST plugins (check your preferences). Like for instance I never put plugins into my user audio folder. I only put them into the main audio folder and when some installer decides to put them in the user audio folder they never show up in my daws because I don't have that folder selected as a available VST folder (personal preference).

In Live I put the Tonespace on Track 2, set midi out to VST Host and then opened up Track 3 and routed the midi from Track 2/Tonespace into it. It worked.

Also, please accept that there may be a difference between Mavericks and El Capitan that is causing the issue. If that is the case I hope someone else can resolve your issue. Good luck.

acemitch2k420
KVRer
3 posts since 16 Jun, 2016

Re: Ableton Live 9 Suite Tonespace VST Help

Post Sun Jun 19, 2016 10:35 pm

Thanks so much for the thorough reply! So after reading everything and messing around a little while more I was able to solve the issue. I'm not sure why this fix worked but it did and was very easy.

In my VST Plug-In options in Lives preferences I had my custom VST folder set to an empty folder in my documents (I never had the need to have a custom spot to put my VST). I tried turning the custom folder off still no luck. But then I set the custom VST folder to the same default folder in my Library/Audio/Plug-Ins/VST and immediately it showed up!

Strange that it wouldn't show up unless both Plug-In paths were designated to that same default folder but I'm not complaining ha. It works now and I'm having lots of fun feeding this midi into my synths. :)

Thank you again UncleAge for the help and mucoder for a great Plug-In!

Low Fye
KVRer
1 posts since 8 Jun, 2017

Re: Ableton Live 9 Suite Tonespace VST Help

Post Wed Jun 07, 2017 4:12 pm

Hi.
I'm having the same issue however I cant figure out how to resolve the problem. And yes, I have followed the above mentioned steps. I am running a 64 bit version of Ableton suite 9. I wonder, is the vst application of tonespace 2.5 only the 32 bit version and that's why I don't see it in my vst plugin folder? I do see the AU version. I've followed all the steps, renamed the component file to .vst, copied it into the Audio>Plugin>VST folder. I've gone into the ableton preferences and ensured the custom folder pathway is correct. I've tried different things, even renamed the component file to .vst.64..... but nothing works.
Any help on this would be greatly appreciated.

Thanks

Return to “mucoder”