How to get hypercyclic to work as an Ardour plugin (error: missing descriptor function)

Official support for: mucoder.net
alemangui
KVRer
1 posts since 19 Dec, 2019

Post Thu Dec 19, 2019 12:12 am

AUTO-ADMIN: Non-MP3, WAV, OGG, SoundCloud, YouTube, Vimeo, Twitter and Facebook links in this post have been protected automatically. Once the member reaches 5 posts the links will function as normal.
Hello all :)

I have been trying all afternoon to install Hypercyclic as an Ardour plugin without success. I keep getting there errors:

Code: Select all (#)

[ERROR]: LADSPA: module "/usr/lib/ladspa/hypercyclic.so" has no descriptor function.
[ERROR]: 'ladspa_descriptor': /usr/lib/ladspa/hypercyclic.so: undefined symbol: 
I downloaded the files and placed the .so file under /usr/lib/ladspa along with the other ones (I am on Ubuntu 18,04) but every time I make Ardour scan for plugins I get the error above.

Weirdly, I am able to launch Hypercyclic with their executable, just not with Ardour.

I'm going crazy here, does anyone have an idea of what could be going wrong?

Kott
KVRist
129 posts since 12 Mar, 2013 from Russia, Vladivostok

Re: How to get hypercyclic to work as an Ardour plugin (error: missing descriptor function)

Post Mon Dec 23, 2019 5:38 pm

Hi,

This is VST plugin not LADSPA. Put it in some VST dir then point to in Ardour's settings.

Return to “mucoder”