Bug reports

Official support for: musicdevelopments.com
lulukom
KVRian
722 posts since 30 Nov, 2013

Post Fri Sep 29, 2017 7:15 am

Can you make sure that when I drag the midi file consisting of chords to the master track, then the length of these new chords in the master track becomes the same as the length of those chords that were already in the master track?
Yes, you reminded me of what it's called ...
"Keep harmonic rhythm" ( For drag in master track)
I would even say - do not keep the rhythm of harmony, but make a new rhythm of harmony in the master track according to the midi file, which is dragged to the master track. Thank you.

nexussynth
KVRian
530 posts since 1 Jan, 2004

Re: Bug reports

Post Fri Sep 29, 2017 6:30 pm

+1
"..What is simple, is simply seen.."

lulukom
KVRian
722 posts since 30 Nov, 2013

Re: Bug reports

Post Sat Sep 30, 2017 12:42 am

Hello !
Thanks for the support...
In general, wherever there is saving or dragging or import, there should be an option to "keep rhythm". Perhaps this can be a global option in the program settings. Thank you.

musicdevelopments
KVRAF
2795 posts since 9 Jan, 2010

Re: Bug reports

Post Sat Sep 30, 2017 8:44 am

OK. How about this?
With the new "major/minor rings" option you can see all major and minor chords AND the diatonic chords are there too:

Image

Please let me know if you need some fancy shading on the circle. I did not find that important but some people (among myself ;) ) may not like that flat design.

Thanks,
Attila
http://www.musicdevelopments.com
Music Prototyping And Automated Composition Solutions

PeteInNeedOfABeat
KVRer
29 posts since 28 Jun, 2016 from Germany

Re: Bug reports

Post Mon Oct 02, 2017 5:41 am

That's great Attila!

Flat design is ok for me.

But a "tension-colour-scheme" would be helpful.

For example: Green for diatonic chords, in C Major: C,F,G and their relative minor chords and Yellow for D,A, Eb, Bb and Red for the rest of the chords.

Not sure if that's harmonically 100% correct, but I'm sure you get the idea.

Sunny greetings,
Pete

musicdevelopments
KVRAF
2795 posts since 9 Jan, 2010

Re: Bug reports

Post Mon Oct 02, 2017 5:51 am

Good idea, Pete! I'll do that later today.
Thanks!
Attila
http://www.musicdevelopments.com
Music Prototyping And Automated Composition Solutions

User avatar
Boone777
KVRian
629 posts since 8 Aug, 2011

Re: Bug reports

Post Tue Oct 03, 2017 4:45 am

Still having the loop bug in reaper. First notes or chords are note played.
You do not have the required permissions to view the files attached to this post.
Last edited by Boone777 on Tue Oct 03, 2017 8:40 am, edited 1 time in total.
Win 7, 64Bit, 16 Gig RAM, Intel i7 Quad 3.9, Reaper 5.62, Steinberg MR816x

User avatar
Boone777
KVRian
629 posts since 8 Aug, 2011

Re: Bug reports

Post Tue Oct 03, 2017 8:39 am

Notes of the last chord in the loop are held. No problem if I stop and play. All first chords are ok it's just the last one that stays on while in loop it overlaps over the first chord. I thought it would have something to do with midi parameters or something but there seems to be none of those present in RC. Those are chord generated or draged from the phrase window.

Reaper project in GoogleDrive: https://drive.google.com/file/d/0B7EoWU ... sp=sharing
You do not have the required permissions to view the files attached to this post.
Win 7, 64Bit, 16 Gig RAM, Intel i7 Quad 3.9, Reaper 5.62, Steinberg MR816x

musicdevelopments
KVRAF
2795 posts since 9 Jan, 2010

Re: Bug reports

Post Tue Oct 03, 2017 9:50 am

At the end of the loop, before jumping back to the beginning 'All Notes Off' is sent. I have tested this many times. Are you sure your virtual instrument handles 'All Notes Off' properly? Can you try another VSTi?
Is this with RC version 3.3?

Thanks!
Attila

PS: I have downloaded your Reaper projects and will try them soon. Thanks for making them available, it is big help.
http://www.musicdevelopments.com
Music Prototyping And Automated Composition Solutions

User avatar
Boone777
KVRian
629 posts since 8 Aug, 2011

Re: Bug reports

Post Tue Oct 03, 2017 6:23 pm

musicdevelopments wrote:At the end of the loop, before jumping back to the beginning 'All Notes Off' is sent. I have tested this many times. Are you sure your virtual instrument handles 'All Notes Off' properly? Can you try another VSTi?
Is this with RC version 3.3?

Thanks!
Attila

PS: I have downloaded your Reaper projects and will try them soon. Thanks for making them available, it is big help.
Yes V3.3. And I tried on a couple different VSTi. The first time I changed the synth I thought it was Dexed creating the problem. It seemed to work at first. But I tried more mainstream synths like Absynth, Reaktor or a Kontakt bank and the problem was still occuring
Win 7, 64Bit, 16 Gig RAM, Intel i7 Quad 3.9, Reaper 5.62, Steinberg MR816x

musicdevelopments
KVRAF
2795 posts since 9 Jan, 2010

Re: Bug reports

Post Wed Oct 04, 2017 11:43 am

I have found an issue introduced in v3.3. I did not remember well, earlier 'All Notes Off' was sent, but not anymore from v3.3 because it caused side effects, quiet notes in some instruments. Now separate 'Note Off' messages should be at the end of the loop, but there is a bug that will be fixed tomorrow.

Another observation: Reaper incorrectly sends the first PPQ position as 4.000011 (for 96kHz) and 4.000028 (for 48kHz) although the loop starts at exactly 4. This causes the first chord to be silent. I hate to insert workarounds but rounding the PPQ position worked well.

I'll update you on the progress but I expect this will be fixed tomorrow.

Thanks, Boone777 for reporting this bug!
Attila
http://www.musicdevelopments.com
Music Prototyping And Automated Composition Solutions

musicdevelopments
KVRAF
2795 posts since 9 Jan, 2010

Re: Bug reports

Post Fri Oct 06, 2017 1:19 am

FYI the hanging notes problem in the VST plug-in at the end of the loop is fixed in v3.4b2 (available now).
http://www.musicdevelopments.com
Music Prototyping And Automated Composition Solutions

PeteInNeedOfABeat
KVRer
29 posts since 28 Jun, 2016 from Germany

Re: Bug reports

Post Tue Oct 10, 2017 1:44 am

Hi Attlila!

Last night I found a bug in the phrase editor. If I create a phrase, then hit "copy to clipboard" and try to insert it in composition view via "control + v", it crashes RC 3.3.

A "long crash" with RC staying in Taskhost Window for a couple of minutes. Happened twice last night (Win7, 64-bit).

And I read about the changes you made to the CoF-View. Sounds great, thank you.

Do you plan to release a version 3.31 with these updates (for the people like me that don't like betas)?

Sunny greetings,
Pete

musicdevelopments
KVRAF
2795 posts since 9 Jan, 2010

Re: Bug reports

Post Thu Oct 12, 2017 6:49 am

Hi Pete,
I tried to crash the program with "copy to clipboard" and pressing Ctrl-V but so far I could not. Did you find a pattern for the crash occurring? I am sorry for the inconveniences!

Yes, lots of things were fixed in the last 1-2 weeks so v3.31 will be available on Monday.
Thanks,
Attila
http://www.musicdevelopments.com
Music Prototyping And Automated Composition Solutions

musicdevelopments
KVRAF
2795 posts since 9 Jan, 2010

Re: Bug reports

Post Fri Oct 13, 2017 1:18 am

PeteInNeedOfABeat wrote:And I read about the changes you made to the CoF-View. Sounds great, thank you.

Do you plan to release a version 3.31 with these updates (for the people like me that don't like betas)?
Hi Pete,

There will be a v3.31 update but new features won't be included, only bug fixes.
I realized you wanted to use the CoF improvements, which I am afraid won't be in this update. I am sorry! :oops:

Attila
http://www.musicdevelopments.com
Music Prototyping And Automated Composition Solutions

Return to “MusicDevelopments”