Bug reports

Official support for: musicdevelopments.com
musicdevelopments
KVRAF
2889 posts since 9 Jan, 2010

Post Sun Jan 07, 2018 8:35 am

The chord suggestions correctly shows the possible chords after C...

You have set the chord preview to use a phrase, probably the currently selected phrase in the browser, that is why it sounds so long. You should do that only when you want to listen to a phrase with different chords in the chord selector. It is not a good idea to use this all the time. The default chord preview is shorter.
To change this open the Chord Selector, and click on the Options menu:

Image

Select Chord+Bass in this menu and all will be fine.
http://www.musicdevelopments.com
Music Prototyping And Automated Composition Solutions

BluGenes
KVRist
346 posts since 15 May, 2017

Re: Bug reports

Post Sun Jan 07, 2018 9:25 am

OK, got that .. I never have changed that before.. now it works like it should..

Didn't the chord suggestions used to be able to change the chord on the master track? It doesn't for me, but, if I choose the selector it works fine.. ( I could be having a minor brain fart here.. lol)

edit: still not changing the chord based on what I click in the suggestions.. new video coming..;)

BluGenes
KVRist
346 posts since 15 May, 2017

Re: Bug reports

Post Sun Jan 07, 2018 10:20 am

Ok, let's try this again.. I found the cause of the bug. I changed the default setting for a new composition. It is the setting for starting with an empty master track that causes the bug.. new video, ...

https://www.youtube.com/watch?v=YjP0SrR ... e=youtu.be

nexussynth
KVRian
529 posts since 1 Jan, 2004

Re: Bug reports

Post Sun Jan 07, 2018 7:34 pm

i have the same bug. would be nice if it worked whether it was an empty master track or not.
"..What is simple, is simply seen.."

musicdevelopments
KVRAF
2889 posts since 9 Jan, 2010

Re: Bug reports

Post Sun Jan 07, 2018 10:38 pm

OMG! This avoided my attention from the previous video! I'll fix this today.
Sorry,
Attila
http://www.musicdevelopments.com
Music Prototyping And Automated Composition Solutions

BluGenes
KVRist
346 posts since 15 May, 2017

Re: Bug reports

Post Mon Jan 08, 2018 2:46 am

lol ok, well, for me, brain fart avoided.. whew.. thanks.. :tu:

nexussynth
KVRian
529 posts since 1 Jan, 2004

Re: Bug reports

Post Thu Jan 25, 2018 6:23 pm

Having a bug with notes hanging in Kontakt 5.6.8 and lower when sounds with slightly long release times are sounding with more than one note. this did not occur until 3.5b3. I can't go back to 3.5b2 now (don't have a copy of it). Could you look into this Attila?
"..What is simple, is simply seen.."

nexussynth
KVRian
529 posts since 1 Jan, 2004

Re: Bug reports

Post Thu Jan 25, 2018 6:51 pm

I also forgot to mention that load times in Kontakt are now somewhat longer. More investigation shows some libraries are more susceptible than others to note hangs.
"..What is simple, is simply seen.."

nexussynth
KVRian
529 posts since 1 Jan, 2004

Re: Bug reports

Post Fri Jan 26, 2018 2:25 pm

not trying to bump here :) , i just found that a re-install has improved kontakt loading but a few libraries still hang on long notes/releases though they are fine in other programs/DAWs. also have tried kontakt 5.6 and 5.3 and same problem. RC 3.3 does not have the problem. :roll:
"..What is simple, is simply seen.."

User avatar
tonedef71
KVRian
914 posts since 21 Sep, 2007 from USA

Re: Bug reports

Post Fri Jan 26, 2018 2:41 pm

nexussynth wrote:not trying to bump here :) , i just found that a re-install has improved kontakt loading but a few libraries still hang on long notes/releases though they are fine in other programs/DAWs. also have tried kontakt 5.6 and 5.3 and same problem. RC 3.3 does not have the problem. :roll:
Just curious... have you tried Kontakt 5.7.3?
Image
[Intel Core i7 8700 | 32GB DDR4 | Waveform 9; Studio One 4 Pro; FL Studio 20; RapidComposer; Sundog Song Studio; Orb Composer; Pizzicato | FL Studio ASIO (WASAPI) | Win10 x64]

nexussynth
KVRian
529 posts since 1 Jan, 2004

Re: Bug reports

Post Fri Jan 26, 2018 9:44 pm

no not yet but not having any problems in other DAWs or programs. i'll have to live with it. orchestral libraries give problems sometimes.
"..What is simple, is simply seen.."

musicdevelopments
KVRAF
2889 posts since 9 Jan, 2010

Re: Bug reports

Post Sat Jan 27, 2018 2:55 am

Very strange :( Do the notes hang during normal playback? Or when you stop playback? Or for chords or phrase preview?
It would be a big help if you could find out which version introduced this bug. I am going to upload v3.31, v3.4, v3.41 and v3.42 for you to try and will send you the download links in PM.

I am sorry for the inconveniences.
Attila
http://www.musicdevelopments.com
Music Prototyping And Automated Composition Solutions

nexussynth
KVRian
529 posts since 1 Jan, 2004

Re: Bug reports

Post Sat Jan 27, 2018 4:55 pm

Well it seems to be okay with the 3.3. the RC problem is note offs are not recognized in kontakt libraries with large instruments but some smaller ones in Project SAM also hang. same with NI's own libraries.

the chords begin to play fine but when the next chord plays the notes from the previous chord are still sounding even if stop is pressed and i must use kontakt's panic button to stop them.

i hope this helps. :)
"..What is simple, is simply seen.."

musicdevelopments
KVRAF
2889 posts since 9 Jan, 2010

Re: Bug reports

Post Mon Jan 29, 2018 1:08 am

Sorry to bother you, but can you try if it does NOT work with v3.31?
It would be a big help if I knew where to look for this bug.
For some time I have been thinking about fully reworking note rendering and using a method that guarantees no hanging notes.
This will be necessary sooner or later.

Thanks,
Attila
http://www.musicdevelopments.com
Music Prototyping And Automated Composition Solutions

nexussynth
KVRian
529 posts since 1 Jan, 2004

Re: Bug reports

Post Mon Jan 29, 2018 4:29 pm

libraries load faster with 3.31 but still hang though not as frequently for some reason. even my old energyXT 1.41 does not hang. somebody on another forum told me i should turn off multiprocessors in kontakt and try that, but i don't want to run it that way as i would have to turn it back on for my other softwares.

hope that helps. it could be the libraries i am using. Spitfire libs sometimes hang very occasionally on other DAWs (maybe libs with a lot of release samples?).
"..What is simple, is simply seen.."

Return to “MusicDevelopments”