Bug reports

Official support for: musicdevelopments.com
NTO
KVRist
136 posts since 8 Feb, 2011

Post Thu Jun 07, 2018 7:22 am

NO!
Still missing something.
Current hassle:
2018-06-07_RC_MorePhraseImport.png
EDIT:
Tried reboot, problem remains.
Tried using the previously retained name, problem remains.
Tried using 'Edited', problem remains.
Tried resetting Custom Phrases in Settings, select the previously retained name, problem remains.

DOES save the file where I set it, but didn't have to set it every time, before sub-dirs created...
Problem for library addition/organization.

EDIT2:
It goes on. If I try to type in the desired location, It acts as though it saved it there (inc's next file name), and doesn't retain the string I typed in. Turns out it actually saves the phrase in the top level of Custom Phrases, as though the location was blank.
So typing input ignored... :o Could not have been originally - created branch on first save!
Problem remains.
You do not have the required permissions to view the files attached to this post.

NTO
KVRist
136 posts since 8 Feb, 2011

Re: Bug reports

Post Sat Jun 09, 2018 7:40 am

FWIW
Since UI mod where Phrase inspector is (new?) button, I've noticed if I have used the inspector/have phrase selected, the inspector's 'X' doesn't close it - need to use the UI button. Elsewise, the 'X' will close it...
Video here:
https://www.screencast.com/t/R3YHEmoEWBi

Seems there's more. Becomes non-responsive and won't redraw in some cases, not captured.
(setting = on top for these experiences)

NTO
KVRist
136 posts since 8 Feb, 2011

Re: Bug reports

Post Sat Jun 09, 2018 8:21 am

Doesn't seem reasonable that I can drag a selection to before the start of composition :?:
Video here:
https://www.screencast.com/t/PQ8qbk0320CD
EDIT to try vid alt
RC_DragFar_Scroll.gif
You do not have the required permissions to view the files attached to this post.
Last edited by NTO on Sat Jun 09, 2018 2:03 pm, edited 1 time in total.

NTO
KVRist
136 posts since 8 Feb, 2011

Re: Bug reports

Post Sat Jun 09, 2018 8:44 am

Clicking in the horizontal scrollbar to jump right one screen width
does not seem to allow for track headers
Video here:
https://www.screencast.com/t/uY7yGQszwq3e

BluGenes
KVRist
347 posts since 15 May, 2017

Re: Bug reports

Post Sat Jun 09, 2018 9:32 am

NTO wrote:Clicking in the horizontal scrollbar to jump right one screen width
does not seem to allow for track headers
Video here:
https://www.screencast.com/t/uY7yGQszwq3e

can you use something else to screen cap with ? Flash has been deprecated and is no longer supported.

NTO
KVRist
136 posts since 8 Feb, 2011

Re: Bug reports

Post Sat Jun 09, 2018 11:06 am

dunno, is this a Mac thing?
using Jing in many forums - no prob/complaints except here :?:
EDIT:
Found it - premature - 2020
https://techcrunch.com/2017/07/25/get-r ... h-in-2020/

Not opposed if I can find something as easy and widely accepted - probably more coming
Guess the animated gif is postable (not as easy)

Scrollbar issue cancelled - don't remember where I was - cannot repeat

NTO
KVRist
136 posts since 8 Feb, 2011

Re: Bug reports

Post Sun Jun 10, 2018 7:49 am

It seems, when I'm going through a midi import, slicing to phrases
if I make mistake and slice inside the desired phrase range
Ctrl+Z will not undo the slice
Have been making the remainder another phrase then gluing the two to correct...

I believe this is reported in error. Failures seem likely due to incorrect user entry.
(Several dozen tests convince me :clown: :dog: )
Last edited by NTO on Fri Jun 15, 2018 5:33 pm, edited 1 time in total.

NTO
KVRist
136 posts since 8 Feb, 2011

Re: Bug reports

Post Sun Jun 10, 2018 8:40 am

Clicking to set the playback position while cutting for phrases
Position jump! (Only happens near edge of track view [~near?])
RC_ClickJump_Scroll.gif
You do not have the required permissions to view the files attached to this post.

NTO
KVRist
136 posts since 8 Feb, 2011

Re: Bug reports

Post Sun Jun 10, 2018 8:57 am

This is mostly FYI
The length entry field in the midi import dialog is three positions, 999 max, but does not constrain the track content.
EDITED: In interest of accurate, field allows entry of many digits, but upon enter will replace w/'999'.
2018-06-10_RC_ImportLimitExceeded.png
You do not have the required permissions to view the files attached to this post.
Last edited by NTO on Fri Jun 15, 2018 11:47 am, edited 1 time in total.

musicdevelopments
KVRAF
2896 posts since 9 Jan, 2010

Re: Bug reports

Post Mon Jun 11, 2018 5:34 am

Thank you for reporting these! :tu:
Attila
http://www.musicdevelopments.com
Music Prototyping And Automated Composition Solutions

NTO
KVRist
136 posts since 8 Feb, 2011

Re: Bug reports

Post Mon Jun 11, 2018 8:58 am

"Ctrl+Z will not undo the slice"

Perhaps related to undo event capture length :?: :idea:
Next day, early in new file (<200 bars), Ctrl+Z has worked twice...
(Backup dir in project where issue noted has 593 files, current - where working indicates 60 - worked to last use at 231 history file count)
If this suspicion is ever confirmed I will post a new reply in this thread.


I believe this is reported in error. Failures seem likely due to incorrect user entry.
(Several dozen tests convince me :clown: :dog: )
Last edited by NTO on Fri Jun 15, 2018 5:34 pm, edited 1 time in total.

joule
KVRist
54 posts since 7 Apr, 2015

Re: Bug reports

Post Tue Jun 12, 2018 6:53 am

I'm pretty sure this is a bug, otherwise I'll learn something new:

The slash chord notation is wrong. If you enter a C/E chord under the C major scale, the roman notation will be I/V. It should be I/III, since E is the third degree of the scale, no? (I think you're looking up a chromatic array rather than the scale array.)

Something strange like C/Gb would probably be I/bV, I assume.

EDIT: Fixed a 'typo'. I'm too used thinking in Eb major.

musicdevelopments
KVRAF
2896 posts since 9 Jan, 2010

Re: Bug reports

Post Wed Jun 13, 2018 5:56 am

Yes, you are right, the slash chords were wrongly converted from/to roman notation!
Sorry about that, I fixed this bug now. I expect there will be a v3.51 update this weekend.
Thanks!
Attila
http://www.musicdevelopments.com
Music Prototyping And Automated Composition Solutions

NTO
KVRist
136 posts since 8 Feb, 2011

Re: Bug reports

Post Thu Jun 21, 2018 8:30 am

I have Settings > Miscellaneous > Editing > Move Playback Position For Click On The Workspace = off; but right click to open browser still moves the Playback Position.
RC_PhraseBrowserMovesPlayhead.gif
You do not have the required permissions to view the files attached to this post.

musicdevelopments
KVRAF
2896 posts since 9 Jan, 2010

Re: Bug reports

Post Thu Jun 21, 2018 8:40 am

This setting is meant to work for a single click with the left mouse button.
When you right-click, the position always moves.
http://www.musicdevelopments.com
Music Prototyping And Automated Composition Solutions

Return to “MusicDevelopments”