Bug reports

Official support for: musicdevelopments.com
lasvideo
KVRist
80 posts since 26 Feb, 2016

Post Sat May 02, 2020 10:19 am

Hi Attila:

As much as I enjoy RC (MAC CATALINA-BETA), I am experiencing a frustrating bug with it that is a game stopper for me.

Ive been creating a simple Baroque tune based on classic progressions for piano, flute and cello.

I create a Melody phrase generated part for the flute , copy it and move it to the next chord in the progression. Simple stuff. No magnets or anything fancy.

Sometimes I regenerate the copy of the phrase generator for the flute and use that. I play the piece back several times and save it several times . Just to be safe.

Then when I recall the song several of the flute phrases have changed from how I saved it. I then corrected them and played the piece to confirm the changes, then saved the piece again.

When reopening several of the flute phrases had changed again. I wont be using RC until this behavior is somehow corrected.

Tom Daigon
Last edited by lasvideo on Sun May 03, 2020 8:35 am, edited 2 times in total.

lasvideo
KVRist
80 posts since 26 Feb, 2016

Re: Bug reports

Post Sat May 02, 2020 11:57 am

Attila, I sent you an email with BEFORE and AFTER screen shots and MP3s attached, so you can see and hear what the file was originally and how the flute phrases were changed when I reopened the RC song file.

BluGenes
KVRian
727 posts since 15 May, 2017

Re: Bug reports

Post Sat May 02, 2020 5:32 pm

I'm interested in this.. I have never had this happen.. I'd like to try an reproduce this to confirm it..

I'm on Windows though...

Is this the production version 3.84 or beta ?

lasvideo
KVRist
80 posts since 26 Feb, 2016

Re: Bug reports

Post Sat May 02, 2020 6:14 pm

Im on the most recent beta for Mac (Catalina)
Attached is the file with piano , flute and cello instruments.
Also attached is the RC file which has the problematic flute phrases (cause the correct ones always get changed when saved).
Also Before and After screen shots of how the flute phrases should look and how they end up looking when I reopen the project.
You do not have the required permissions to view the files attached to this post.

lasvideo
KVRist
80 posts since 26 Feb, 2016

Re: Bug reports

Post Sat May 02, 2020 6:16 pm

Here are Before and After MP3s . How it SHOULD sound and how it is CHANGED.
You do not have the required permissions to view the files attached to this post.

BluGenes
KVRian
727 posts since 15 May, 2017

Re: Bug reports

Post Sun May 03, 2020 2:53 am

ok, got the zips..


edit: the second flute phrase has the magnet on.. in both screen shots..

lasvideo
KVRist
80 posts since 26 Feb, 2016

Re: Bug reports

Post Sun May 03, 2020 3:33 am

Yes, I tried many tests varying magnets on and off to see if it could correct the problem of the notes that were changed in the phrase generator. It didnt help.

I just went thru the whole testing process again with that magnet off. The problem still remains . After saving and re-opening, that phrase and one other phrase is changed in several places.

lasvideo
KVRist
80 posts since 26 Feb, 2016

Re: Bug reports

Post Sun May 03, 2020 4:50 am

I even tried replacing the phrases that get altered by deleting them and trying a new melody generator (to replace the one I deleted). After saving, closing RC and reopening that same file, the phrases still get altered.
Last edited by lasvideo on Sun May 03, 2020 8:37 am, edited 2 times in total.

User avatar
musicdevelopments
KVRAF
3756 posts since 9 Jan, 2010

Re: Bug reports

Post Sun May 03, 2020 6:35 am

Interesting, I am looking into this problem.
http://www.musicdevelopments.com
Innovative music software for creative musicians - home of RapidComposer, Melodya and Syne

lasvideo
KVRist
80 posts since 26 Feb, 2016

Re: Bug reports

Post Sun May 03, 2020 7:07 am

Thanks Attila!

lasvideo
KVRist
80 posts since 26 Feb, 2016

Re: Bug reports

Post Sun May 03, 2020 10:30 am

Out of curiosity I thought I would load the problematic RC file (created in Mac Beta) into the most current non-beta release for the Mac to see if the problem I had (stated above) was present in that version.

As it turns out it seems the beta file is not backward compatible because when I loaded the file into the regular Mac release all the track data and midi data was not there. Oh well, it was worth a shot.

lasvideo
KVRist
80 posts since 26 Feb, 2016

Re: Bug reports

Post Sun May 03, 2020 3:02 pm

After going thru all the tutorials and explorations...I felt like I was getting my "RC Legs" back when I bumped into this unfortunate issue.

So, in a last ditch effort, I completely removed RC from my system and reinstalled the beta, in hopes I could continue having fun with it.

Alas, as I fixed the altered phrases, then saved, closed and reopened the file...the same things happened as stated above. DAMN!

BluGenes
KVRian
727 posts since 15 May, 2017

Re: Bug reports

Post Sun May 03, 2020 4:03 pm

Are there any variations on the track ? (right click the track header and click the yellow arrow) I can't reproduce this at all..

lasvideo
KVRist
80 posts since 26 Feb, 2016

Re: Bug reports

Post Sun May 03, 2020 4:15 pm

On the flute track (the only place this seems to be happening), the default Expression is the only variation. This behavior also seems unique to the Melody Generator since Im using that exclusively on the flute track.

It doesn't surprise me that you cant reproduce this problem on Windows. Ive noticed over the development curve that Windows and Mac have different issues that need correcting.

BluGenes
KVRian
727 posts since 15 May, 2017

Re: Bug reports

Post Sun May 03, 2020 5:04 pm

OK, this should fix it... Since you had a magnet on, right click the track header and click the "deactivate Magnets". When you enabled the magnet, you enabled the phrase envelope. That is what is making it jump back...
Last edited by BluGenes on Sun May 03, 2020 5:19 pm, edited 1 time in total.

Return to “MusicDevelopments”