Bug reports

Official support for: musicdevelopments.com
lasvideo
KVRist
80 posts since 26 Feb, 2016

Post Sun May 03, 2020 5:09 pm

Thanks for your interest in solving this thing, but as I stated above...

"I just went thru the whole testing process again with that magnet off. The problem still remains . After saving and re-opening, that phrase and one other phrase is changed in several places."

Magnets were only used when I started trouble shooting. I've done extensive test with NO magnets whatsoever and still got the same results unfortunately.
I just tried substituting the Random Melody Generator for the Melody Generator and it had the same issues (no magnets involved) ;)

BTW, I did try your suggestion, but got the same results as before. Thanks for trying!

At this point I give up. Hopefully Attila will find the problem so I can start using RC again.

BluGenes
KVRian
727 posts since 15 May, 2017

Re: Bug reports

Post Mon May 04, 2020 12:00 am

ok, before I give up, did you do this in the screen shot... Because, I am %100 confident this is the problem...

Image

lasvideo
KVRist
80 posts since 26 Feb, 2016

Re: Bug reports

Post Mon May 04, 2020 3:47 am

Yup, thats exactly what I did. Same problems.

I spent a year using RC in 2016 composing this kind of music and never experience this kind of issue.

Thanks for your interest in helping me solve things.

BluGenes
KVRian
727 posts since 15 May, 2017

Re: Bug reports

Post Mon May 04, 2020 4:56 am

Welp, it's up to the master now.. lol head scratcher for sure.. What puzzles me, is, it's the same code. Meaning, the only difference between the Apple part and the Windows part is the OS stuff that draws the screen or does file system stuff. Other than that, it's the exact same source code..

Just remember, you working with a beta version, it will have issues.. I wouldn't use the beta version for any production work, use the release version for that.. In fact, I would try doing the same thing on the release version. Also, try again in the beta, but, start from scratch.. don't re-use anything at all from the composition that is having problems..

It's just a process of elimination to figure this out...

cheers..
Gene

lasvideo
KVRist
80 posts since 26 Feb, 2016

Re: Bug reports

Post Mon May 04, 2020 5:14 am

LOL! Great minds think alike.
I just did a clean install of the most current regular version of RC (after removing ALL the beta files). I also did a fresh build of the baroque progression for the same instruments.
Got it the way I liked it. Saved it. Opened it. And yet again RC altered several phrases to sound like garbage.
Last edited by lasvideo on Tue May 05, 2020 8:13 pm, edited 1 time in total.

lasvideo
KVRist
80 posts since 26 Feb, 2016

Re: Bug reports

Post Mon May 04, 2020 7:12 am

I dont expect to see this problem fixed anytime soon since I see Attila has his hands full with the release of Melodya 1.0 right now.

lasvideo
KVRist
80 posts since 26 Feb, 2016

Re: Bug reports

Post Mon May 04, 2020 7:50 pm

Out of curiosity I loaded up the PC regular version of RC on another machine I have. Based on my experience with it, I would say that the Melody Phrase Generator has serious issues. It displayed similar idiosyncrasies as stated at length above in my posts about the Mac version.

Return to “MusicDevelopments”