Rapid Composer + Ableton

Official support for: musicdevelopments.com
--SYNTH--
KVRist
92 posts since 11 Jul, 2002

Post Mon Jan 18, 2016 2:04 pm

Hi!
How can I address each track of rapid composer to play a different instrument plug-in inside Ableton Live??

Thanks!

Nextom
KVRist
94 posts since 26 Sep, 2015

Re: Rapid Composer + Ableton

Post Mon Jan 18, 2016 2:07 pm

Hi Chris,

I'm a beginner myself in this. But from what I understood in reading on several forums, this is not possible. It' seems to be a much lamented shortcoming of Ableton, that all incoming external signals arrive on the same midi-channel. But don't take my word for it, do a search on your own. And let me know if you find out otherwise.

--SYNTH--
KVRist
92 posts since 11 Jul, 2002

Re: Rapid Composer + Ableton

Post Tue Jan 19, 2016 9:53 am

Thanks!! Thats a sad thing (how come that cant do this simple thing????).....but lets wait for an update!!

dsan@mail.com
KVRAF
3069 posts since 29 Sep, 2005

Re: Rapid Composer + Ableton

Post Tue Jan 19, 2016 12:58 pm

Actually, if I understand correctly, this is very easy to solve. I don't know if the solution works when using Rapid Composer as a VST; however, in stand alone mode I know this works as I use it daily.

You need "Virtual MIDI Cables".

This: http://www.tobias-erichsen.de/software/loopmidi.html

Or this: http://www.copperlan.org/

There are other virtual MIDI cables but I recommend these since both are free and I am familiar with them ;)

CopperLAN also works over LAN as does rtpMIDI, another software developed by Tobias Erichsen. These are what I use to route Rapid Composer from machine 1 to Live on machine 2.

Here are the steps (assuming you are using Windows machines):
1.) Install the software of your choice (or both if you wish. Keep in mind Windows imposes a 10 MIDI device limit, but you can set up as many ports as you want. I have 2 loopMIDI ports and 4 CopperLAN ports (because this is the default set up by CopperLAN).
2.) Be sure to restart your machine after installation - an important step!
3.) Open Live and set up your MIDI ports in preferences. See the manual for how this is done. It's simple and straight forward; HOWEVER!!! Be sure you do not route an out to in on the same port. Else you will create a loop and this is disastrous!!
4.) Open RC standalone and go to the settings tab. Set up the defaults as you wish.
5.) On the Composition tab, right click a track to open the Track Dialog. RC recognizes all the virtual MIDI devices you have created and permits you to select which device you want a particular track to use.
So let's say you select Track 1, and set the MIDI out device to "loopMIDI 1". Then set the output channel to 1. For each MIDI port you have 16 channels to choose from :clap: So if you have created 4 ports, you now have 64 MIDI output channels you can assign as MIDI inputs inside Live.
6.) Go back to Live and select a track. Set "MIDI In" to "loopMIDI 1". Now select the input channel on this port, in this case channel 1.
7.) Set your MIDI out, in Live, to the VST you want to use and select the channel. If, for example, it is a multi channel instrument, like Kontakt, you can use up to 64 MIDI channels (over 4 ports). :clap:
8.) I use group tracks in Live to control a multi channel instrument like Kontakt. If I'm using 16 instruments inside an instance of Kontakt, I create 17 tracks in Live - a Master Track that Kontakt is on and then 16 tracks routed to Kontakt.

I hope this was easy enough to understand but if not feel free to ask questions :tu:

Before departing I'll say again DO NOT ROUTE A MIDI OUT TO A MIDI IN ON THE SAME PORT

@nextom - I think what you refer to is for external hardware instruments. I'm not an expert on this though and know just enough to be dangerous :hihi:

If what you need though is to route your RC tracks to a corresponding track inside Live, what I have described above does work ;)

Cheers!
My DAW System:
W7, i5, x64, 8Gb Ram, Edirol FA-101

Nextom
KVRist
94 posts since 26 Sep, 2015

Re: Rapid Composer + Ableton

Post Thu Feb 18, 2016 1:40 pm

Hi Dsan,

trying hard to earn my membership to the stupidity-club here:
I'm trying to recreate your setup, but I'm not receiving a signal in Ableton. Can you figure out, what I'm doing wrong?
I did install Copperlan, and I set it up in Ableton as follows:
Image
I also set up a channel in Ableton to receive VMidi1, as you can see here:
Image

and here:
Image
Now, the last step, as you write, should be to open in RC's composition tab the track's dialogue and set the channel. But this is where I get lost. Where exactly do I do that? You mean this dialogue here?
Image
The channel here is set to 1, but there are no further specifications, so I assume this must be it?
But I'm still getting no signal in Ableton. What am I missing?

pottering
KVRian
649 posts since 14 Dec, 2014

Re: Rapid Composer + Ableton

Post Thu Feb 18, 2016 3:20 pm

My guesses, based on the screenshots:

I think the receiving track in Ableton has to be set to (Monitor) "In" instead of "Auto".

Seems the "Softer Acid" track is sending to a instrument called "MonoPoly" (a loaded Korg plugin I guess), shouldn't that be selected to the "VMidi 1" virtual MIDI cable?
[edit: actually, gotta select "MIDI:GeneralMIDI", then another option named "Device" appears, where you can select the virtual MIDI cable]

The "Fernst." option (that I assume is the "remote" option in English) is only for MIDI controllers that have the correct Remote Script selected (like the "Code 49" in your screenshot), should be disabled for simple MIDI connections.

[edit2: Also, I'm pretty sure Live can receive from separate MIDI channels in each track.]
Last edited by pottering on Thu Feb 18, 2016 3:41 pm, edited 1 time in total.

Nextom
KVRist
94 posts since 26 Sep, 2015

Re: Rapid Composer + Ableton

Post Thu Feb 18, 2016 3:36 pm

I think the receiving track in Ableton has to be set to (Monitor) "In" instead of "Auto".
Nope, sir. I tried all three options: In, Auto and off.
Seems the "Softer Acid" track is sending to a instrument called "MonoPoly" (a loaded Korg plugin I guess), shouldn't that be selected to the "VMidi 1" virtual MIDI cable?
I agree. But there, I can only select several VSTi's and RC's soundfonts. Nothing else in that list.
The "Fernst." option (that I assume is the "remote" option in English) is only for MIDI controllers that have the correct Remote Script selected (like the "Code 49" in your screenshot), should be disabled for simple MIDI connections.
Yeah, but I want my Keyboard, too. (And I don't imagine this to be the cause, or would you?)

musicdevelopments
KVRAF
2888 posts since 9 Jan, 2010

Re: Rapid Composer + Ableton

Post Thu Feb 18, 2016 10:51 pm

Hello Thomas,

pottering made a good point. When you send the output of a track to external MIDI devices, you don't use VSTi or soundfont as the instrument in RapidComposer. Instead you should choose "MIDI: General MIDI". Don't worry about 'General MIDI' because you don't have to use any program changes, there is a "No Patch Change" preset which does not send any program changes for your track.
I think I should add "MIDI: External Port" or something like that. Sorry about this being a bit confusing.

Thanks,
Attila
http://www.musicdevelopments.com
Music Prototyping And Automated Composition Solutions

dsan@mail.com
KVRAF
3069 posts since 29 Sep, 2005

Re: Rapid Composer + Ableton

Post Fri Feb 19, 2016 10:10 am

I'm sorry to be late getting back.

The correct setting is as Attila explains - set the track "Instrument" to "MIDI: General MIDI"

This was my meaning in step 5 but I wasn't as clear as I could have been. Sorry for being so obtuse.
I think the receiving track in Ableton has to be set to (Monitor) "In" instead of "Auto".

Nope, sir. I tried all three options: In, Auto and off.
I use "AUTO" but because it works for me I have not tried the others.

The problem may be you will need to arm the track for recording(this happens sometimes, sometimes not). Once armed you should hear the sound of the VST as it plays what RC feeds it.
Seems the "Softer Acid" track is sending to a instrument called "MonoPoly" (a loaded Korg plugin I guess), shouldn't that be selected to the "VMidi 1" virtual MIDI cable?
I agree. But there, I can only select several VSTi's and RC's soundfonts. Nothing else in that list.
See Attila's explanation. You should find "MIDI:General MIDI" in that drop down.

You first select "MIDI:General MIDI" in the "Instrument" setting, then select "VMIDI" in the "Device" setting, then select the channel. It's easy routing once you get used to it.
The "Fernst." option (that I assume is the "remote" option in English) is only for MIDI controllers that have the correct Remote Script selected (like the "Code 49" in your screenshot), should be disabled for simple MIDI connections.
Yeah, but I want my Keyboard, too. (And I don't imagine this to be the cause, or would you?)
You set the keyboard up in Live as normal. Don't confuse the keyboard with VMIDI. You send the RC MIDI data to Live via VMIDI, you send what you are playing on the keyboard to Live via its own MIDI settings.

VMIDI is not a controller so the "Remote" should be off in Live.

You will not be able to play the track in Live, with the keyboard, that you have set up to receive MIDI data from RC. Live only permits one "Input", per track, at a time.

But, you can set up RC to receive from the keyboard, play it in RC and send the data to Live via VMIDI.

HTH....Let me know if I can help further.

Cheers!
My DAW System:
W7, i5, x64, 8Gb Ram, Edirol FA-101

dsan@mail.com
KVRAF
3069 posts since 29 Sep, 2005

Re: Rapid Composer + Ableton

Post Fri Feb 19, 2016 10:33 am

Nextom wrote:Image
I also set up a channel in Ableton to receive VMidi1, as you can see here:
Image

and here:
Image
Tom,
A couple of things I notice from your pics:
1.) VMIDI is not a control surface, so it should not appear in the top dialog. It should only show up in the "Ports" dialog (bottom part).
2.) Each VMIDI "INPUT" port should be set "On". Otherwise they can't get used.
3.) I see a "RapidComposer Virtual MIDI Output" under the "Input" section of the settings - What is this?
4.) On Live's routing dialogue, set the channel you want Live to receive. If you use "All Channels" you will get a mess of data coming at you.
5.) I see you have the tracked armed, so this is not the reason you do not hear sound. I am sure it is because you are not sending "MIDI:General MIDI" from RC as discussed in the previous post.
6.) I suggest (back in RC's settings) uncheck "Send MIDI Reset All Controllers", "Send MIDI Reset Pan" and "Send MIDI Reset Volume", especially if you use an instrument such as Kontakt. Otherwise you will have to adjust again, each time you send data, what you had those settings at before RC reset them.

The other settings you have made are useful.
Nextom wrote:Now, the last step, as you write, should be to open in RC's composition tab the track's dialogue and set the channel. But this is where I get lost. Where exactly do I do that? You mean this dialogue here?
Image
The channel here is set to 1, but there are no further specifications, so I assume this must be it?
But I'm still getting no signal in Ableton. What am I missing?
I hope the other post answered this for you. But if not, let me know!

Cheers!
My DAW System:
W7, i5, x64, 8Gb Ram, Edirol FA-101

Nextom
KVRist
94 posts since 26 Sep, 2015

Re: Rapid Composer + Ableton

Post Sat Feb 27, 2016 12:56 pm

Hi guys, thanks much for all your tipps. I think I have a pretty good grasp now of how it should work – only problem being, that it still doesn't :cry:
Here's my new setup:
In RC's Settings, I chose VMidi2 as the output. (But I tried with all other available outputs too, as: Rapid Composer Virtual midi out or IAC Driver IAC Bus 2).
Image
In the track inspector, I chose "General Midi" as the instrument and channel 1.
Image

In Ableton, I opened three tracks, each with one of RC's midi-out options.
Image
I tried arming each track, I tried "All channels" or channel 1 – nothing.

I'm quite sure this must be a bug outside of these settings - either in Ableton, in RC or in my iMac.

dsan@mail.com
KVRAF
3069 posts since 29 Sep, 2005

Re: Rapid Composer + Ableton

Post Sun Feb 28, 2016 5:11 am

Nextom wrote:Hi guys, thanks much for all your tipps. I think I have a pretty good grasp now of how it should work – only problem being, that it still doesn't :cry:
Here's my new setup:
In RC's Settings, I chose VMidi2 as the output. (But I tried with all other available outputs too, as: Rapid Composer Virtual midi out or IAC Driver IAC Bus 2).
https://www.evernote.com/l/ACQ2vHGs6I5H ... /image.png
In the track inspector, I chose "General Midi" as the instrument and channel 1.
https://www.evernote.com/l/ACTKdNIYhtND ... /image.png

In Ableton, I opened three tracks, each with one of RC's midi-out options.
Image
I tried arming each track, I tried "All channels" or channel 1 – nothing.

I'm quite sure this must be a bug outside of these settings - either in Ableton, in RC or in my iMac.
You need to set track 2 and 3 MIDI Out to a vst. As it is now the data RC is sending is going no where once it arrives to Live. Do you see in your picture where it says "MIDI To"? and you have it set to "NO Output"?

Do not use "All Channels" as a source. Use a separate channel for each track. You can of course send all data to one track but that will make a mess of the sound.

You need to make absolute sure you have the routings how they should be or Live will not make a sound.

This is not a bug. It works when you have things correct. Been doing it many years now ;)
My DAW System:
W7, i5, x64, 8Gb Ram, Edirol FA-101

PeteInNeedOfABeat
KVRer
29 posts since 28 Jun, 2016 from Germany

Re: Rapid Composer + Ableton

Post Tue Jun 28, 2016 8:58 am

Hi all!

Just signed up here so I can join the threads about Rapid Composer.

A big "thank you" to everybody (especially dsan and Attila)!

Your struggle has helped me to finally work it out.

RC (3.02) runs smooth here in Ableton Live (9.6.1) via loopMIDI. Win7, 64-bit.

The "General Midi"-Setting in RC was the one thing I did wrong before I saw this thread.

And if you use the standalone-version of RC for this (which I did), you have to remember that recording the Midi into Ableton won't work. You just control "play" and "stop" in RC and then drag&drop the Midi into Ableton if you like what you've heard.

I only played around for half an hour, but so far everything was funky (in a good way).

Best wishes,
Pete

musicdevelopments
KVRAF
2888 posts since 9 Jan, 2010

Re: Rapid Composer + Ableton

Post Tue Jun 28, 2016 9:05 am

Welcome to the RapidComposer forum, Pete! :hug:
Thanks for sharing your experiences. It is not easy to set up RC with certain DAWs. Help from the community is invaluable...

Thanks,
Attila
http://www.musicdevelopments.com
Music Prototyping And Automated Composition Solutions

musicdevelopments
KVRAF
2888 posts since 9 Jan, 2010

Re: Rapid Composer + Ableton

Post Thu Apr 19, 2018 11:54 pm

I posted this also on the Tips&Tricks forum:

Mike O'Connor prepared a video to show how to set up RapidComposer and Ableton Live:

https://www.youtube.com/watch?v=0rNvuQjujBU

Thanks, Mike! :tu:
Attila
http://www.musicdevelopments.com
Music Prototyping And Automated Composition Solutions

Return to “MusicDevelopments”