Melodya topic (was Melodya v1.0 announced...)

Official support for: musicdevelopments.com
KVRist
153 posts since 31 Dec, 2005

Post Sat May 09, 2020 4:28 am

BluGenes wrote:
Fri May 08, 2020 9:37 pm
Hey Megawatt.. Just to be clear, you understand how notes are being displayed? If you are NOT hovering over the motive, you see all the notes based on the variations, but, when you hover over the motive, notes disappear.. Those are the original notes, before the variations are applied.. So, deleting a note may give the impression you are deleting more notes than you actually are..
Thank you BluGenes for your help :)
musicdevelopments wrote:
Sat May 09, 2020 2:59 am
Hi Megawattt,

I downloaded NanoHost, and now I understand what you meant to ask! If you delete a note in a motive, the same note will be deleted in other sections which use the same motive. What you can do is clicking on the 'clone' icon (4th icon in ACTIONS line) to make a copy of the motive to break any connection with the others, and you can delete a single note.

EDIT: which DAW do you use? I tried loading projects in several DAWs and there was no crash...

Thanks,
Attila
And thank you Attila for explaining in more detail :) i have tried your suggestion and it works! to be honest i use Synapse Audio Orion as my main DAW, support ended on it about 7 years ago, i have Melodya midi configured and wrapped in Mutools MUX Modular, it all works except for the crashes (so maybe Orion is the problem there) and when i drag and drop midi files into Melodya it plays back some wrong notes (It also does the wrong notes thing in NanoHost) so the midi wrong notes playback is a problem for me, as i have mentioned before please is it possible to add a feature to Melodya to manually load midi files into it (Or squash this bug?)
Strictly drum and bass

User avatar
KVRAF

Topic Starter

4377 posts since 9 Jan, 2010

Post Sat May 09, 2020 5:11 am

Hi Megawattt,
do you have a MIDI file that is always imported with wrong notes? Would it be possible to send it to me in e-mail, so that I can check it?
Thanks,
Attila
https://www.musicdevelopments.com
Innovative music software for creative musicians - home of RapidComposer, Melodya and Syne

User avatar
KVRAF

Topic Starter

4377 posts since 9 Jan, 2010

Post Sat May 09, 2020 5:15 am

I installed Mixcraft Studio, and I confirm playback starts at the first quarter note instead of from the beginning. However this is a bug in Mixcraft, not in Melodya, because the host sends the wrong starting position to Melodya. I am not a fan of adding workarounds so I will report this to Acoustica.

EDIT: I have reported this to Acoustica today.
https://www.musicdevelopments.com
Innovative music software for creative musicians - home of RapidComposer, Melodya and Syne

KVRist
153 posts since 31 Dec, 2005

Post Sat May 09, 2020 6:17 am

musicdevelopments wrote:
Sat May 09, 2020 5:11 am
Hi Megawattt,
do you have a MIDI file that is always imported with wrong notes? Would it be possible to send it to me in e-mail, so that I can check it?
Thanks,
Attila
No problem Attila, please send your email address.
Strictly drum and bass

User avatar
KVRAF

Topic Starter

4377 posts since 9 Jan, 2010

Post Sat May 09, 2020 7:22 am

Melodya v1.05 is available with the following fixes:
  • Hanging notes fixed
  • Note preview works (new setting added to enable/disable note preview)
  • [macOS] Pop-up menu works well
  • Stability improvements
https://www.musicdevelopments.com
Innovative music software for creative musicians - home of RapidComposer, Melodya and Syne

KVRist
153 posts since 31 Dec, 2005

Post Sat May 09, 2020 7:24 am

Hi Attila.

Did you receive the midi file sir?
Strictly drum and bass

User avatar
KVRAF

Topic Starter

4377 posts since 9 Jan, 2010

Post Sat May 09, 2020 7:36 am

Hi Megawattt,
Yes, thank you, I am checking the MIDI file. I think I can fix this quickly.
Thanks!
Attila
https://www.musicdevelopments.com
Innovative music software for creative musicians - home of RapidComposer, Melodya and Syne

KVRist
153 posts since 31 Dec, 2005

Post Sat May 09, 2020 7:38 am

musicdevelopments wrote:
Sat May 09, 2020 7:36 am
Hi Megawattt,
Yes, thank you, I am checking the MIDI file. I think I can fix this quickly.
Thanks!
Attila
Excellent! :)
Strictly drum and bass

KVRist
384 posts since 26 Feb, 2007

Post Sat May 09, 2020 4:25 pm

v 1.0.5 in Studio One 4 ("S1"), Mac OS X 10.13.6 High Sierra:

> Fixes the stuck notes problem when stopping a melody by hitting the Play arrow button. Yay!
> Fixes the problem that selecting items in the right-click pop up menu did nothing. Yay!

BUT big show stopper BUG: Removing Melodya plugin freezes or crashes S1 consistently. Really hoping you can fix that in the next (1.0.6) version. That's the last bug remaining for me (that I can see now from quick testing of major things without exhaustively testing every single function)

KVRist
31 posts since 16 Dec, 2018

Post Sun May 10, 2020 1:00 am

dbender wrote:
Sat May 09, 2020 4:25 pm
v 1.0.5 in Studio One 4 ("S1"), Mac OS X 10.13.6 High Sierra:

> Fixes the stuck notes problem when stopping a melody by hitting the Play arrow button. Yay!
> Fixes the problem that selecting items in the right-click pop up menu did nothing. Yay!

BUT big show stopper BUG: Removing Melodya plugin freezes or crashes S1 consistently. Really hoping you can fix that in the next (1.0.6) version. That's the last bug remaining for me (that I can see now from quick testing of major things without exhaustively testing every single function)
Melodya 1.05 still crashes S1 on Windows too.

KVRist
31 posts since 16 Dec, 2018

Post Sun May 10, 2020 5:39 am

Dear Attila,

Unfortunately the newest 1.05 version is almost unusable for on Win and MacOS.

1. It crashes S1
2. Sound doesn't stop after I stop playback. It is very annoying.

User avatar
KVRAF

Topic Starter

4377 posts since 9 Jan, 2010

Post Sun May 10, 2020 9:45 am

Hi charliezerotwo,

which virtual instrument did you use? Does it support receiving "All Notes Off"?
I tested v1.05 with S1 using several VSTis (SynthMaster2, EZKeys), there were no hanging notes!
On the other hand I found some others (Mojito, Cakewalk SI-String Section) that produced hanging notes...
I am investigating this and will have a fix shortly. Is it common for a virtual instrument to ignore "All Notes Off"? :?

I did not experience any crashes with S1 on Windows. If you have a crash dump on macOS, it would be a big help if you could send it to me in e-mail (info@musicdev....com).

Thanks,
Attila
https://www.musicdevelopments.com
Innovative music software for creative musicians - home of RapidComposer, Melodya and Syne

KVRist
31 posts since 16 Dec, 2018

Post Sun May 10, 2020 1:39 pm

musicdevelopments wrote:
Sun May 10, 2020 9:45 am
Hi charliezerotwo,

which virtual instrument did you use? Does it support receiving "All Notes Off"?
I tested v1.05 with S1 using several VSTis (SynthMaster2, EZKeys), there were no hanging notes!
On the other hand I found some others (Mojito, Cakewalk SI-String Section) that produced hanging notes...
I am investigating this and will have a fix shortly. Is it common for a virtual instrument to ignore "All Notes Off"? :?

I did not experience any crashes with S1 on Windows. If you have a crash dump on macOS, it would be a big help if you could send it to me in e-mail (info@musicdev....com).

Thanks,
Attila
Dear Attila,

I used Serum, Sylenth1, Spire and Hive 2 with Melodya and all they produced hanging notes all the time. It was really frustrating. And you are right, there is no such issue, when I use EZKeys. (On windows).

I would report you about the crashes a bit later if you dont mind!

Thank you!

KVRist
384 posts since 26 Feb, 2007

Post Sun May 10, 2020 1:58 pm

That's because: In midi land, notes off problems generally don't affect plucked short note type instruments like piano, and do affect sustained type sounds like violin and pads.

KVRist
153 posts since 31 Dec, 2005

Post Sun May 10, 2020 6:43 pm

Good morning Attila.

I am still experimenting with Melodya and i have noticed that i am unable to get it to run in loop mode even if it is using the host tempo and signature, when i press "play" on my DAW the melody will play once then stop, the DAW "play" button will stay on playing in a loop but Melodya will not play in a loop with the DAW, i have tried this with the Melodya loop button enabled and disabled, am i doing something wrong ? :? :)
Strictly drum and bass

Return to “MusicDevelopments”