Notes Color

Official support for: musicdevelopments.com
KVRer
14 posts since 27 Mar, 2021

Post Sat Mar 27, 2021 2:04 am

Hi everyone! I was wondering why my notes have all the same color.

I've tried to set both options:
  • Color Notes By Track Color
  • Color Notes By Track Color + Velocity
Unfortunately, my notes are always white! :O

I'm using the latest version of RC on MacOS Catalina, with the color space of my display set to Generic RGB Profile (RC is simply unusable with the standard Color LCD profile.)

Thanks!

Screen Shot 2021-03-27 at 03.00.07.png
You do not have the required permissions to view the files attached to this post.

User avatar
KVRAF
4362 posts since 9 Jan, 2010

Post Sat Mar 27, 2021 2:54 am

Hi Mark,

This is very strange! White would be a valid note color (for velocity=64, as set under Settings / User Interface / Note Shading) but when using the track color only, the notes should never be white.
Will you send me your settings and the above composition file in e-mail for analysis? The settings file is ~/Documents/RapidComposerV4/Settings/settings. I cannot find an explanation for this, even after checking the source code, and so far no other users complained about it. Did you use the 'composite track' before this screenshot?

Using Generic RGB Profile is a good idea, because in recent macOS versions macOS does constant color space conversion, which makes the UI very slow. Hardware accelerated UI is what I am working on, so this will be fixed fairly soon.

Thanks!
Attila
https://www.musicdevelopments.com - Anniversary Sale -40% until April 20!
Innovative music software for creative musicians - home of RapidComposer, Melodya and Syne

KVRer

Topic Starter

14 posts since 27 Mar, 2021

Post Sat Mar 27, 2021 1:53 pm

Hi, Attila! I was about to grab my preferences file, but then I realized I forgot to try one last setting: the velocity color presets.

I applied one of the presets and now all the notes’ colors are showing up correctly! At this point, I wouldn’t even know how to replicate the issue as all the velocity presets are working correctly.

If this helps, the odd behavior was affecting also the preview of the generators panel and the phrase editor. It’s something I’ve experienced when starting with a fresh copy of RC, and default settings.

User avatar
KVRAF
4362 posts since 9 Jan, 2010

Post Sun Mar 28, 2021 7:20 am

I have checked this on a new installation, but no avail. As far as I saw when using the track color only, the color does not depend on the velocity. So this remains a mystery. Which is good, because this world would be boring without mysteries :)
I am happy that you found the solution.
Thanks!
Attila
https://www.musicdevelopments.com - Anniversary Sale -40% until April 20!
Innovative music software for creative musicians - home of RapidComposer, Melodya and Syne

Return to “MusicDevelopments”