Product wanting re-activated

Official support for: bestservice.de
KVRer
1 posts since 22 Feb, 2021

Post Sun Feb 21, 2021 5:31 pm

Hi there,

I purchased the ERA II pack on BestService in 2018. When I tried to use the software tonight, I was met with the licence manager. It stated: "Era 2 has not yet been activated on this computer."

I've been using the software on a near weekly basis for the past two years, any reason why It's suddenly asking me to re-activate as if It's new?

I've made no hardware changes to the PC and I have not moved the location of the files since original installation.

Thanks,

KM

KVRAF
2151 posts since 28 Jul, 2003

Post Mon Feb 22, 2021 1:48 am

Windows update? This can break activations.
My main tools: Kontakt, Omnisphere, Samplemodeling + Audio Modeling. Akai VIP = godsend. Tari's libraries also rock.

KVRAF
28052 posts since 11 Apr, 2010 from Germany

Post Mon Feb 22, 2021 2:24 am

First Windows update for 2 years?

Apart from that, in my experience, most license activation systems don't get confused with that anymore. I wouldn't know about Best Service though, because I don't own any products from them.
Plugins and a DAW. On an operating system. Which runs on a computer.

KVRAF
2151 posts since 28 Jul, 2003

Post Mon Feb 22, 2021 6:26 am

chk071 wrote:
Mon Feb 22, 2021 2:24 am
First Windows update for 2 years?
I didn't say EVERY Windows update breaks the Best Service authorization.
SOMETIMES they do... MOST of the time, they don't.

This is coming from someone who owns many Best Service products, and is also evidenced in SEVERAL Best Service threads, if you do a search.
chk071 wrote:
Mon Feb 22, 2021 2:24 am
I wouldn't know about Best Service though, because I don't own any products from them.
Then why disagree with my comments, if you have no experience with the product in the question?
My main tools: Kontakt, Omnisphere, Samplemodeling + Audio Modeling. Akai VIP = godsend. Tari's libraries also rock.

KVRAF
2151 posts since 28 Jul, 2003

Post Mon Feb 22, 2021 6:39 am

Windows 10 update de-authorized stuff?

Win10 updates remove all Magix e-licenses?

Another windows update - another activation situation for best service Engine...

These are just 3 threads on the topic supporting my response. There are more, but I got sick of copy-pasting links.
chk071 wrote:
Mon Feb 22, 2021 2:24 am
in my experience, most license activation systems don't get confused with that anymore.
chk071 wrote:
Mon Feb 22, 2021 6:44 am
I have a lot of experience with copy protections of different plugins, also with the ones using machine/hardware ID. And, in my experience [snip]
chk071 wrote:
Mon Feb 22, 2021 6:44 am
I can only repeat again though that that is not an issue anymore[snip]
Can I humbly suggest that maybe you are not as experienced as you might think you are.
Last edited by Ben H on Mon Feb 22, 2021 7:08 am, edited 6 times in total.
My main tools: Kontakt, Omnisphere, Samplemodeling + Audio Modeling. Akai VIP = godsend. Tari's libraries also rock.

KVRAF
28052 posts since 11 Apr, 2010 from Germany

Post Mon Feb 22, 2021 6:44 am

Ben H wrote:
Mon Feb 22, 2021 6:26 am
chk071 wrote:
Mon Feb 22, 2021 2:24 am
I wouldn't know about Best Service though, because I don't own any products from them.
Then why disagree with my comments, if you have no experience with the product in the question?
Because I have a lot of experience with copy protections of different plugins, also with the ones using machine/hardware ID. And, in my experience, they usually had issues with the half yearly big updates, because those act like a new OS install. I can only repeat again though that that is not an issue anymore with the plugins/copy protections I use.

Anyway, the OP should contact Best Service. That's better than fishing in troubled waters here.

P.S.: No idea why you're acting so defensively.
Plugins and a DAW. On an operating system. Which runs on a computer.

KVRAF
2151 posts since 28 Jul, 2003

Post Mon Feb 22, 2021 7:15 am

chk071 wrote:
Mon Feb 22, 2021 6:44 am
P.S.: No idea why you're acting so defensively.
I have no idea why you're acting so dismissively?

It can't possibly be because of Windows update, because you said so... despite multiple other people CONFIRMING that this is the case.
My main tools: Kontakt, Omnisphere, Samplemodeling + Audio Modeling. Akai VIP = godsend. Tari's libraries also rock.

KVRAF
28052 posts since 11 Apr, 2010 from Germany

Post Mon Feb 22, 2021 7:20 am

Where have I been acting dismissively? I've merely pointed out that it may not be very effective to do guess work, and that the OP should rather contact Best Service, the company responsible for delivering a functioning product.
Plugins and a DAW. On an operating system. Which runs on a computer.

KVRAF
2151 posts since 28 Jul, 2003

Post Mon Feb 22, 2021 7:52 am

chk071 wrote:
Mon Feb 22, 2021 7:20 am
it may not be very effective to do guess work
And yet EVERY SINGLE reply of yours has been guesswork, based on a product that you DO NOT OWN and have NO EXPERIENCE WITH. :roll:
chk071 wrote:
Mon Feb 22, 2021 2:24 am
I wouldn't know about Best Service though, because I don't own any products from them.
EDIT: nvm. I'm just going to ignore you.

@KingMel
Your problem is not uncommon.

I actually own ERA II (as well as half a dozen other Best Service products) and have had this happen to me.
Other people in the threads that I linked have also confirmed this happened to them, BUT

1. You get 5 activations for your product.
2. If you run out of activations, you can send an email to Best Service and they will reset the count. I have done this myself, as have others in the threads that I have linked (and others that I have not).

You should also update to the latest version of the ENGINE player if you haven't already, because this has been fixed for a lot of people. Although sometimes it still fails because Windows has a knack for changing/breaking things.
Last edited by Ben H on Mon Feb 22, 2021 3:15 pm, edited 1 time in total.
My main tools: Kontakt, Omnisphere, Samplemodeling + Audio Modeling. Akai VIP = godsend. Tari's libraries also rock.

KVRAF
28052 posts since 11 Apr, 2010 from Germany

Post Mon Feb 22, 2021 9:33 am

Again, I have no idea why you're freaking out here. But, suit yourself. ;)

Hope the OP gets a solution from Best Service. That's what matters first and foremost here.
Plugins and a DAW. On an operating system. Which runs on a computer.

User avatar
KVRer
26 posts since 5 Dec, 2011

Post Thu Apr 29, 2021 2:26 pm

:x
I came to this forum for an answer to the OP's question as well and it is disheartening to see the instant bickering. Act professionally and courteously people, c'mon! I have only one in my life been able to load a Best Service library more than one without it breaking and this goes back to Yellow Tools days. I purchased a DAW Suite upgrade based in part on that library being included but it just was never worth the hassle, so a let-down that I never use.
The Best Service license system is broken, period. It's great that they are generous with the extra activations but lets face it- they have to be. If they were stingy they would go out of business due to people with lost activations. I activated Galaxy-X on my computer around the holiday season and the activation has already broken. I don't let Windows install auto-updates partly for this reason if it even is the reason. If it only happened every 5 years it would be one thing but it happens ALL THE TIME! So instead of making music I'm here trying to find answers on forums. And B-S charges a premium compared to most competing products even on a half-price sale which makes it even more outrageous. Their customer service is excellent but again, it has to be. This just makes me never want an Engine-based product again like I said after the Independence Pro library but hope sprang eternal so here I am. :cry:
Edited to add that the Ethno World 5 instruments I bought from Best Service six years ago that run in Kontakt have never once had a problem.

Return to “Best Service”