Plugins affected by sample rate

Official support for: acondigital.com
KVRer
26 posts since 19 Jun, 2019

Post Thu Jun 24, 2021 5:10 am

I was testing some reverbs in Reaper and I noticed that Convolve and Verberate 2 are both affected by the audio device sample rate. With Verberate 2 it's subtle, but with Convolve the difference is quite noticeable, even between 44.1 and 48 kHz.

This is not ideal, projects should have a consistent sound regardless of SR settings. (I supposed some tiny differences might be inevitable.)

User avatar
KVRian
1159 posts since 1 Jan, 2005 from Norway

Post Fri Jun 25, 2021 3:55 am

Thanks for reporting. Verberate should adjust to the sample rate, but some internal parameters use discrete steps (for better CPU utilization), so slight differences are possible. Convolve should resample the impulse response when you load it from file. Which host application were you using when testing? Did you reload the IR file after changing the sample rate?

Best,
Stian

KVRer

Topic Starter

26 posts since 19 Jun, 2019

Post Sat Jun 26, 2021 6:46 am

I'm using Reaper and the VST3 versions of plugins.

You're right (regarding Convolve), reloading the IR file or preset (or the song/project) after the SR change fixes it. Or, in other words, it only happens if you change the SR mid-project, after the plugin is already running.
So it shouldn't affect many people.

When using Convolve in Acoustica, the problem is a bit different. While Reaper resamples the audio on the tracks when you change the audio device SR (before this audio reaches the plugins), it seems that Acoustica keeps the SR of the original sample regardless of the audio device SR settings (SR change is applied after the effect chain).
So changing the SR of the audio device in Acoustica has no effect on Convolve. However, if you load two samples with a different SR, Convolve will sound differently. And just like in Reaper, reloading the IR file or preset fixes it.

User avatar
KVRian
1159 posts since 1 Jan, 2005 from Norway

Post Tue Jun 29, 2021 4:43 am

Thanks for elaborating. I think Convolve should reload (and thus resample) the IR files when the sample rate is changed. That should solve both issues. I've added it to our task tracking system and we will get it fixed as soon as possible.

Best,
Stian

Return to “Acon Digital”