Equalize 2 bug? My fault?

Official support for: acondigital.com
KVRian
588 posts since 4 Jan, 2007

Post Thu Nov 25, 2021 11:11 am

Hello.

Using Win10, VST3, Reaper 6.34.

1.) I select a highpass and set it to the highest frequency. Blocks all signal, as expected I get no sound.
2.) I set the channel mode to L or R.
3.) Now I hear both channels.

I would expect to only hear one channel.

Now I hard pan a sound with no high frequency to the left and apply the same highpass. If i select the mid channel the sound gets completely muted. If I select the side channel there is no gain change.

A hardpaned sound when converted to M/S should have the same energy on both channels (M and S) I think.

What am I doing wrong?

KVRian

Topic Starter

588 posts since 4 Jan, 2007

Post Tue Nov 30, 2021 10:21 am

Can anyone confirm?

KVRer
27 posts since 6 Dec, 2004

Post Tue Nov 30, 2021 1:18 pm

This is the normal behavior since when you select L or R the filter is applied only to one channel not both has in the stereo position! Right ? ;)

KVRian

Topic Starter

588 posts since 4 Jan, 2007

Post Thu Dec 02, 2021 6:42 am

From the manual
Channel Mode Buttons
You can choose any of the following channel modes for each equalizer band
individually:
L : Apply to left channel only
M : Apply to mid channel only. The mid channel is the sum of the input channels
multiplied by a scaling factor.
: Apply to both channels
S : Apply to side channel only. The side channel is the difference of the input
channels multiplied by a scaling factor.
R : Apply to right channel only
If I select R or L I expect the hipass that blocks all the signal to just block all the signal in one channel. I'm reporting this as a bug...

User avatar
KVRian
1237 posts since 1 Jan, 2005 from Norway

Post Thu Dec 02, 2021 6:45 am

Hi Rafa,
rafa1981 wrote:
Thu Nov 25, 2021 11:11 am
Hello.

Using Win10, VST3, Reaper 6.34.

1.) I select a highpass and set it to the highest frequency. Blocks all signal, as expected I get no sound.
2.) I set the channel mode to L or R.
3.) Now I hear both channels.

I would expect to only hear one channel.
Do you have anything else in your chain? I cannot reproduce this in REAPER. Selecting either L or R mutes one channel here (running REAPER 6.29 under Windows).

Best,
Stian

KVRian

Topic Starter

588 posts since 4 Jan, 2007

Post Thu Dec 02, 2021 6:54 am

Will try again when back at home. Let's hope I'm misreporting (apologies in that case)...

KVRian

Topic Starter

588 posts since 4 Jan, 2007

Post Thu Dec 02, 2021 12:30 pm

stian wrote:
Thu Dec 02, 2021 6:45 am
Hi Rafa,
It seems actually a bug, but it requires more than two channels. To reproduce:

-Set some audio or synth.
-Set equalize afterwards.
-Set the hipass to the highest frequency.
-Set the right or left channel (L or R) button on Equalize.

At this point only one channel sounds. Everything working OK.

-Press the "2in 2out" button on the top right of Reaper's area.
-Set the track channels dropdown to 4.

Now the EQ settings are completely ignored (same for L,R,M and S). But there is more. Now this requires another audio source on channels 3/4.

If I set the EQ to normal (linked L and R) the expected behavior would be to apply the EQ to channel 1 and 2 and let 3 and 4 pass through, but the EQ is applied to all 4 channels.

I say expected behavior because, for an EQ it seldomly makes sense to apply the same EQ settings to two channels with different audio content. In this case it can be workarounded by just not connecting pings 3 and 4 on both in an out.

Notice that with pins 3 and 4 disconnected, 1 and 2 still behave weirdly with regards to L, R, M and S.

Return to “Acon Digital”