A Small Collection Of Bugs

Discussion about: tracktion.com
ForrestH
KVRer
8 posts since 24 Jan, 2019

Post Sat Jun 08, 2019 11:22 am

[W10.1.5/Linux]

• Merge MIDI Clips discards notes in the rightward (timeward?) clip; sometimes just ones at the seam, sometimes all the notes in the clip.
• Render-and-replace MIDI-as-MIDI goes through motions but leaves the selected clips untouched (and there's nothing in the Rendered folder).
• There seems to be precision beyond the third zero in chord clip length: the overlap indicator lights up even though the length and placement fields in the properties pane say it shouldn't. Select-all and shrink by the smallest amount zoom allows will work around the problem. (Quantize Clip Lengths would be nice....) Also, selecting a Chord Track clip doesn't provide a Select function in the Properties pane.
• The tooltips say that << and >> are doable with cursor-left and cursor-right, but nothing happens when I press the arrow keys. (I don't have left or right assigned as shortcuts, but [test pause] they do work as shortcuts.)
• The |<< button's tooltip says "rewind to the start of the edit". Its actual behavior varies. During playback, it sends the transport to the start of the earliest selected clip, at least if the cursor is to the right of said clip. Ditto if playback is stopped, except that clicking it again will do as advertised. Moving the cursor by clip edge is quite handy, and there ought to be a >>| button too with this in mind, or maybe control-clicking the << and >>...
• The Properties bar has a Key setting; click that and a popup box appears containing Key and Scale that can be clicked on in turn. The Key submenu seems to be stable, but the Scale menu tends to disappear while I'm moving the mouse pointer toward it.
• Once you've brought up the Actions popup, there seems to be no way to get rid of it via keyboard.
• Fonts in the font selector aren't alphabetized.

• [Linux?] File dialogs still use black text regardless of background color.

• [Linux] Apparently the Waveform window should now display the Waveform icon instead of the generic X, but it doesn't under Trinity (KDE3++). I used the "xseticon" workaround.
• [Linux] Restart-on-crash doesn't work. I see "/bin/sh -c /usr/bin/Waveform10 --recovery" and "/usr/bin/Waveform10 --recovery" in htop, but Waveform itself remains invisible.

• [Notabug?] I can stretch individual main tracks to arbitrary heights, but not the T/M/C tracks, which impedes making label text visible.
• [Notabug?] Is there a reason for the limit in the number of notes in an Arpeggio? I haven't hit a limit on Bassline.
• [Notabug?] The separate Track window supports only horizontal wheel zoom when displaying MIDI, but I gather MIDI editing isn't actually supported in that window yet, so...

mikoatkvr
KVRist
437 posts since 25 Jul, 2010 from Northern Ireland

Re: A Small Collection Of Bugs

Post Sat Jun 08, 2019 11:36 am

• [Linux] Restart-on-crash doesn't work. I see "/bin/sh -c /usr/bin/Waveform10 --recovery" and "/usr/bin/Waveform10 --recovery" in htop, but Waveform itself remains invisible.

I reported this some time ago, seems to be Jack/Juce related. It will work with pulseaudio and I believe alsa too.

ForrestH
KVRer
8 posts since 24 Jan, 2019

Re: A Small Collection Of Bugs

Post Wed Jun 12, 2019 7:02 pm

mikoatkvr wrote:
Sat Jun 08, 2019 11:36 am
It will work with pulseaudio and I believe alsa too.
I get unusably broken-up audio with ALSA with Tracktion/Waveform/JUCE devkit, though I haven't experimented with it.

ForrestH
KVRer
8 posts since 24 Jan, 2019

Re: A Small Collection Of Bugs

Post Wed Jun 12, 2019 7:06 pm

One more bug: adding FX to audio clips causes their waveforms to disappear in favor of a "(Can't read this file)" message. Do Remove-all-FX and back comes the waveform.

Return to “Tracktion”