Upgraded from T9 to T10 and now there's a weird Copy/Paste setting

Discussion about: tracktion.com
Protocall
KVRer
8 posts since 17 Mar, 2018

Post Sun Apr 21, 2019 9:12 am

So, wanted to upgrade to support Tracktion, but now there's a weird Copy/Paste setting that's for some reason set by default (aka, I didn't want this to happen, but now I'm stuck trying to figure out how to undo it). Can you help?

Scenario: Select a MIDI clip that's been quantized... copy/paste (normally this creates a new instance right after the selected clip (which is awesome). Now, it pastes the selected clip right after the first clip, but unquantized. Same length, but notes aren't quantized.

Seems like this shouldn't be the default (as it wasn't in all versions I've been running going back to T1. Google results in nothing, haven't found this in forums. Any help is appreciated. Thanks!
You do not have the required permissions to view the files attached to this post.

spoontechnique
KVRist
150 posts since 7 May, 2018

Re: Upgraded from T9 to T10 and now there's a weird Copy/Paste setting

Post Sun Apr 21, 2019 5:58 pm

I've noticed this often myself. You can get around it by clicking on a clip and CTRL + Dragging to create a copy. Not sure why it's the case, though.

Protocall
KVRer
8 posts since 17 Mar, 2018

Re: Upgraded from T9 to T10 and now there's a weird Copy/Paste setting

Post Sat Aug 31, 2019 1:57 pm

Yeah. Still have the issue. Here's the scoop. Don't upgrade Tracktion. They messed up Copy and Paste. Hey... at least they have a bunch of other stuff. Who need's Copy and Paste? Been with them since T1. Now looking elsewhere. =\

dRowAudio
KVRian
1493 posts since 30 Dec, 2012

Re: Upgraded from T9 to T10 and now there's a weird Copy/Paste setting

Post Tue Sep 03, 2019 1:11 am

I think that's a bit harsh. It's not like we've completely broken all copy/paste functionality, this seems to be an edge case as I can't easily reproduce it and we haven't been inundated with reports of the problem. This is obviously a bug that we'll try and fix.

I'm trying to replicate the bug with a minimal test case:
1) Create a new Edit and add a single, 1 bar MIDI clip starting at time 0:0
2) Add a new 1 beat long MIDI note starting at 1, 2, 240
3) Select the clip and from the "Actions" side panel choose "Quantise" -> "1 beat"
[See the note snap to start of the clip]
4) Copy then paste the clip
[See the new clip starting at bar 2 and it contains only a single MIDI note of 1 beat long starting at the start of the MIDI clip]
[Also note that when the new clip is selected, the "Quantise" property is still set to "1 beat"]

Can you try to repeat these steps and see if you notice any different behaviour?
Could it be that you have configure the clip in a different way? Do you have offset or loop start/length properties set at all?

Also, what version of Waveform are you using? It could be this is something we have already fixed?

Return to “Tracktion”