Two feature questions

Discussion about: tracktion.com
UnionS8
KVRist
78 posts since 10 Dec, 2002

Post Mon Jul 22, 2019 4:14 am

Hi. Please, I couldn't find the answer to these two questions (been searching the manual, forums, youtube...) Can someone help me?
1. How can I select a certain range of the automation curve and move it or copy/paste it somewhere else (on the same track)?
2. Is it possible to set a loop range from the selection? I

Thanx in advance, Stepaan
Or is it all just an illusion...
...and I would say to you: "Perhaps".

tovokas
KVRist
277 posts since 9 Sep, 2005 from Washington State. USA

Re: Two feature questions

Post Mon Jul 22, 2019 7:43 pm

1: Shift click the automation points you want to copy. (Can you mouse drag select? Haven't been able to figure out how). Inside the full-sized control panel at the bottom, click on "copy points to clipboard". If you want to paste them to the same track, just move your cursor to the correct spot and click on the "paste from clipboard" button in the control panel. On another track, just go to it and click on the automation line and do the same thing.

2: If you have a clip selected, typing 'a' will set in/out loop points around the clip. I couldn't find a way to do the same with the new range selection feature.
iMac (Retina 5K, 27-inch, 2017), 4.2 GHz Intel Core i7
Radeon Pro 580 8 GB
Focusrite Scarlett 4i4 3rd Gen
Waveform 10/Studio One Pro 3.5

UnionS8
KVRist
78 posts since 10 Dec, 2002

Re: Two feature questions

Post Tue Jul 23, 2019 2:04 am

Thank you. I am actually aware of these two routines.
ad 1. The point is I can't drag select a region which I need to copy/move. And shift+click is simply pain, because I need to copy a part of an altered automation pattern with some 50+ points.
ad 2. I know the 'a' shortcut. But sometimes I simply need to set loop of a different lenght than the clip is.
I immediately fell in love with Waveform 10. Mainly because it's straightforward approach and clever interface. I wonder why these basic functions (present in 99,9 % of all DAWs) don't work in W10?!
Or is it all just an illusion...
...and I would say to you: "Perhaps".

tovokas
KVRist
277 posts since 9 Sep, 2005 from Washington State. USA

Re: Two feature questions

Post Tue Jul 23, 2019 9:40 pm

Agreed, I don’t understand why the regular lasso, or alt/option lasso doesn’t work on automation nodes. Range selection is new, but it would seem that having the ‘a’ shortcut assign the start/end points to the range if one is active would be a no-brainer. :)
iMac (Retina 5K, 27-inch, 2017), 4.2 GHz Intel Core i7
Radeon Pro 580 8 GB
Focusrite Scarlett 4i4 3rd Gen
Waveform 10/Studio One Pro 3.5

tovokas
KVRist
277 posts since 9 Sep, 2005 from Washington State. USA

Re: Two feature questions

Post Wed Jul 31, 2019 1:53 am

Experimenting tonight, I noticed that if you just click on the automation curve line, rather than multiple points, a "Copy Marked Region" button shows up in the automation curve box at the bottom of the page. You can then use the in and out points to select the region of the points you wish to copy.

When you then click on the automation curve you want to modify, a "Paste from Clipboard" button allows you to either paste the copied points between the in and out markers, or at the cursor. That's a bit better than shift-clicking all the points. :)
iMac (Retina 5K, 27-inch, 2017), 4.2 GHz Intel Core i7
Radeon Pro 580 8 GB
Focusrite Scarlett 4i4 3rd Gen
Waveform 10/Studio One Pro 3.5

UnionS8
KVRist
78 posts since 10 Dec, 2002

Re: Two feature questions

Post Thu Aug 01, 2019 1:19 am

Thanx. I'll check it out when I'm home. But still. The automation lane workflow is a way beyond nowadays standards.
Or is it all just an illusion...
...and I would say to you: "Perhaps".

Return to “Tracktion”