Error while deleting

Discussion about: tracktion.com
anbz
KVRist
100 posts since 23 Jan, 2014

Post Mon Sep 30, 2019 1:02 am

Hello.

I wanted to warn about this message I get really often when I try to delete regions in waveforms on PC version. It happens since long in my case, in older versions too... Since always in fact.
But never in Mac version !

It would be hard to see that I'm the only one to get it.

If I have 40 regions (files) to delete, I get 40 messages to click on...

Thanks for your help.

PierreG
KVRist
200 posts since 24 Sep, 2005

Re: Error while deleting

Post Wed Oct 02, 2019 11:15 am

anbz wrote:
Mon Sep 30, 2019 1:02 am
If I have 40 regions (files) to delete, I get 40 messages to click on...
Care to share the error messages?

anbz
KVRist
100 posts since 23 Jan, 2014

Re: Error while deleting

Post Thu Oct 03, 2019 7:01 am

Waouuhhh.. sorry !
Exactly this one !
IMG_4037.jpeg
You do not have the required permissions to view the files attached to this post.

PierreG
KVRist
200 posts since 24 Sep, 2005

Re: Error while deleting

Post Thu Oct 03, 2019 11:38 am

Thanks for sharing the error message.

Please say more about how you "delete regions". Are you selecting a group of clips and using the Delete (Also deleting source files) option? Or are you deleting tracks?

I don't typically delete large numbers of large files, so I've never seen this. Do the errors pop up when deleting lesser numbers of smaller files?

Possible Anti Virus or similar app having a grip on the files trying to be deleted? If you have Windows File Explorer open on the files you're trying to delete, this may be the conflict.

anbz
KVRist
100 posts since 23 Jan, 2014

Re: Error while deleting

Post Thu Oct 03, 2019 12:48 pm

Hello !

It happens when I delete one or group of regions, selecting "Also deleting source files".
The I'm not annoyed by this message, I'm always surprised of the time needed to delete, it's surprisly long.
I don't have any windows opened when this can happen. Kind of problem I've never experienced with other softwares. Weird !

PierreG
KVRist
200 posts since 24 Sep, 2005

Re: Error while deleting

Post Thu Oct 03, 2019 1:33 pm

I forgot to ask, do the files actually delete? It would seem that this message is saying that the delete operation failed.

Do you mean to say clips when you say "one or groups of regions"?

So if you select only 1 clip and choose to Delete (Also deleting source files), do you always get this message? Either way, do the source clip audio files actually delete?

anbz
KVRist
100 posts since 23 Jan, 2014

Re: Error while deleting

Post Thu Oct 03, 2019 11:17 pm

Hello.
This is totally aleatory.
I've just tried with 8 tracks, 2 minutes long.
I tried to delete and also deleting source files, on 8 tracks, I had 4 messages. And 4 files were effectively deleted in the Recorded Files folder. So, I tried to delete the 4 others. And then, only one message but 3 files were deleted. The last one worked with no message. Pretty hard to explain so ???
Sorry, when I say CLIPS, I mean groups of regions yes.

PierreG
KVRist
200 posts since 24 Sep, 2005

Re: Error while deleting

Post Fri Oct 04, 2019 9:20 am

That is super weird!
anbz wrote:
Thu Oct 03, 2019 11:17 pm
Sorry, when I say CLIPS, I mean groups of regions yes.
My turn for sorry... clips are the individual recorded objects that contain the audio wave graphics, which you see redrawing all of the time (as you've described in the other KVR thread). Groups of regions makes no sense to me. A region to me would be a group of selected clips.

I've mentioned this several times now and not seen a response regarding whether or not you have antivirus or any other apps that would be scanning your files. What you describe regarding both these delete errors AND the issue with redraws, could both be being caused by other apps messing with file access, and or file attributes.

Do you use Windows file compression in Windows 10? Or any type of file encryption? There's also the W10 Ransomware Protection feature that monitors apps for suspicious activity, which I've tried and had to turn off because it messed with Waveform. Then of course there's the possibility that you have some form of malware happening on your system. I think you've said that these issues have been there for many versions of Tracktion and Waveform, which again, may point to some other app(s) you've had installed all along. Just guessing here!

Being that others are not experiencing these issues, or at least not talking about it in these threads, says to me that these issues are likely based outside of Waveform.

anbz
KVRist
100 posts since 23 Jan, 2014

Re: Error while deleting

Post Sat Oct 05, 2019 5:13 am

Hello. Ok, I understand better some things.
SO, I think I've disabled all background apps I could to test these problems. Maybe I should de-install them to be sure.
I don't think I have malwares or things like that. Or my software to look after that doesn't do his job ?

And I don't use file compression in Windows 10 no.

Maybe I should try on a new partition with just Waveform installed and see what happens ?

PierreG
KVRist
200 posts since 24 Sep, 2005

Re: Error while deleting

Post Sat Oct 05, 2019 8:19 am

Cool. Wishing you luck in resolving these things!

:pray:

Return to “Tracktion”