Tracktion Universe 2020

Discussion about: tracktion.com
User avatar
exponent1
KVRist
358 posts since 10 Nov, 2018 from India

Post Sun Feb 02, 2020 12:50 am

jabe wrote:
Sun Feb 02, 2020 12:01 am
Wrong bit versions are rejected when scanned and don't appear in the menu. What you'll have is both VST (.dll) and VST3 (.vst3) versions installed, both 64-bit.

JBridge is software that allows 32-bit plug-ins to run under 64-bit versions of Waveform.
+1

I think people should not spread misinformation convincingly without knowing a bit more in depth. Gives new users the wrong impressions.

courtjestr
KVRist
164 posts since 25 Aug, 2018

Re: Tracktion Universe 2020

Post Sun Feb 02, 2020 8:30 am

jabe wrote:
Sat Feb 01, 2020 8:38 pm
courtjestr wrote:
Sat Feb 01, 2020 5:58 pm
When Tracktion became Waveform 8, 32 bit support was dropped. So it is not a glitch, it is expected behaviour.
Minor point - Waveform 9 was the first to be 64-bit only.
I stand corrected. Thanks!

GuitarPlayerinNYC
KVRist
63 posts since 23 Dec, 2019

Re: Tracktion Universe 2020

Post Sun Feb 02, 2020 12:44 pm

exponent1 wrote:
Sun Feb 02, 2020 12:50 am
jabe wrote:
Sun Feb 02, 2020 12:01 am
Wrong bit versions are rejected when scanned and don't appear in the menu. What you'll have is both VST (.dll) and VST3 (.vst3) versions installed, both 64-bit.

JBridge is software that allows 32-bit plug-ins to run under 64-bit versions of Waveform.
+1

I think people should not spread misinformation convincingly without knowing a bit more in depth. Gives new users the wrong impressions.
If it's me, you're referring to, then you'd be wrong in saying I'm spreading wrong information; if I have, please point it out. I never have a problem in standing corrected. I only reported what happened, and both the 32, and 64 bit versions of the effects appeared in my menu- the sub menu for effects doubled in size- e.g. "TAutoFilter & TAutoFilter (64 (bit)," plus the other 15 plugins, for a total of 32

I figured out how to remove the 32 bit plugins from the plugins tab, and that removed the entries from my menu. At no point did I say the 32 bit plugins worked. Or, are you saying that this is such an impossibility, that it never occurred? Then I must have made this whole thing up.

Your initial response to my saying WF can be glitchy, when I said half my plugins disappeared, was that it "probably" wasn't a glitch, because 64 bit, etc. Then, how did they appear in the first place, and work? I installed EZDrummer/Keys as 64 bit. Essentials & Collective was installed by the Tracktion Download manager (I later manually installed both- plus the Loops, that disappeared, as well). How do you explain that?

@jabe- wrong bit versions can be rejected, but still work. I just installed this guitar plugin. I got an error message, yet, the plugin works. Note that it says "Bass" on the UI, but it's the guitar plugin. And no, I didn't install their Bass plugin. In the YT vids I've seen, I didn't see "Guitar."

Bottom line is, because something should work a given way, doesn't mean it always does. But I really resent the suggestion that I'm spreading misinformation ( when I simply relayed a problem). Convincingly, yet.
You do not have the required permissions to view the files attached to this post.

fde101
KVRist
179 posts since 16 Mar, 2017

Re: Tracktion Universe 2020

Post Mon Feb 03, 2020 2:50 am

Where that screenshot shows "Bass" should be the name of the track the plugin was placed on.

User avatar
exponent1
KVRist
358 posts since 10 Nov, 2018 from India

Re: Tracktion Universe 2020

Post Mon Feb 03, 2020 2:52 am

fde101 wrote:
Mon Feb 03, 2020 2:50 am
Where that screenshot shows "Bass" should be the name of the track the plugin was placed on.
+1 :hihi:

GuitarPlayerinNYC
KVRist
63 posts since 23 Dec, 2019

Re: Tracktion Universe 2020

Post Tue Feb 04, 2020 12:32 pm

fde101 wrote:
Mon Feb 03, 2020 2:50 am
Where that screenshot shows "Bass" should be the name of the track the plugin was placed on.
You're 100% right. I have no problem in standing corrected. I dragged the plugin into an existing project.

However, this doesn't address how a 32 bit, rejected plugin works. Answer: Because WF10 can handle 32 bit VSTs. Source: Traction support, when I opened a ticket on my problem. It shouldn't load 32 bit VSTs, and I don't know if WF has a built-in bridge, but it can, and it does.

Seems the impossible, is possible. From Tracktion support:
waveform runs 32 bit.JPG
Guess Tracktion is convincingly spreading false information about their own product.

Some people should remain silent, and be thought a fool, than open their mouth, and remove all doubt (not directed at you, fde101). Me, I like to collect facts, before jumping to specious conclusions.
You do not have the required permissions to view the files attached to this post.

User avatar
aMUSEd
KVRAF
31152 posts since 14 Sep, 2002 from In teh net

Re: Tracktion Universe 2020

Post Tue Feb 04, 2020 1:56 pm

dupont wrote:
Fri Jan 17, 2020 10:20 am
Hope it will be less buggy than previous versions on OSX.
Much as I love Tracktion’s interface and workflow the DSP engine is still, after several years of version updates, impossibly glitchy on Mac. Until recently I thought it may be due to my 2 core MacMini but now I have a 6 core iMac and it’s still glitchy.

Kott
KVRist
145 posts since 12 Mar, 2013 from Russia, Vladivostok

Re: Tracktion Universe 2020

Post Tue Feb 04, 2020 2:57 pm

GuitarPlayerinNYC wrote:
Tue Feb 04, 2020 12:32 pm

However, this doesn't address how a 32 bit, rejected plugin works. Answer: Because WF10 can handle 32 bit VSTs. Source: Traction support, when I opened a ticket on my problem. It shouldn't load 32 bit VSTs, and I don't know if WF has a built-in bridge, but it can, and it does.

Seems the impossible, is possible. From Tracktion support: waveform runs 32 bit.JPG

Guess Tracktion is convincingly spreading false information about their own product.

Some people should remain silent, and be thought a fool, than open their mouth, and remove all doubt (not directed at you, fde101). Me, I like to collect facts, before jumping to specious conclusions.
Maybe Tracktion team means their 32-plugins, like Biotek2 or Collective?
Your statement that these plugins was in menu can be explained by messed T7/W10 configuration files.


I think this discussion has to be moved in separate thread.

GuitarPlayerinNYC
KVRist
63 posts since 23 Dec, 2019

Re: Tracktion Universe 2020

Post Tue Feb 04, 2020 4:15 pm

Kott wrote:
Tue Feb 04, 2020 2:57 pm
GuitarPlayerinNYC wrote:
Tue Feb 04, 2020 12:32 pm

However, this doesn't address how a 32 bit, rejected plugin works. Answer: Because WF10 can handle 32 bit VSTs. Source: Traction support, when I opened a ticket on my problem. It shouldn't load 32 bit VSTs, and I don't know if WF has a built-in bridge, but it can, and it does.

Seems the impossible, is possible. From Tracktion support: waveform runs 32 bit.JPG

Guess Tracktion is convincingly spreading false information about their own product.

Some people should remain silent, and be thought a fool, than open their mouth, and remove all doubt (not directed at you, fde101). Me, I like to collect facts, before jumping to specious conclusions.
Maybe Tracktion team means their 32-plugins, like Biotek2 or Collective?
Your statement that these plugins was in menu can be explained by messed T7/W10 configuration files.


I think this discussion has to be moved in separate thread.
No, read the quote I screenshot from support, and support addressed my 3rd party AGML.dll- he said that was a 32 bit.

Support's explanation for the doubling of my fx menu was Waveform obviously scanned for, and installed 32 bit plugins. They're still working on it, as they asked for more screenshots today.

There is no discussion. I just mentioned I thought WF10 was glitchy, then exponent1 chimed in, saying I'm spreading misinformation, when all I did was clarify why I thought it was glitchy. Half my plugins disappearing, and loading 32 bit .dlls shouldn't happen, but they clearly did.

If there's mods here, and they want to move this, that's their call. I think it's relevant now, because WF11 will likely be released in Beta, and, if it's built on WF10's core, and there's some kind of glitch, my sending them screenshots will ideally help all WF users. Plus, there's plenty of WF10 users in this thread, and if there's a big enough glitch, maybe a patch will be released.

The easy solution to removing 32 bit plugins from your plugin menu is to go to Settings>plugins, then remove them- if you want to keep the 32 bit plugins. If you have no use for the 32 bit plugins, you can just go to the pertinent vst folder, and manually delete them.

GuitarPlayerinNYC
KVRist
63 posts since 23 Dec, 2019

Re: Tracktion Universe 2020

Post Tue Feb 04, 2020 4:23 pm

aMUSEd wrote:
Tue Feb 04, 2020 1:56 pm
dupont wrote:
Fri Jan 17, 2020 10:20 am
Hope it will be less buggy than previous versions on OSX.
Much as I love Tracktion’s interface and workflow the DSP engine is still, after several years of version updates, impossibly glitchy on Mac. Until recently I thought it may be due to my 2 core MacMini but now I have a 6 core iMac and it’s still glitchy.
Try support@traction? I've found them very helpful. I wouldn't go through their zendesk portal; my initial problem sat there for 4 days, then I wrote them, and we're communicating via email now.

Kott
KVRist
145 posts since 12 Mar, 2013 from Russia, Vladivostok

Re: Tracktion Universe 2020

Post Tue Feb 04, 2020 5:04 pm

No, read the quote I screenshot from support, and support addressed my 3rd party AGML.dll- he said that was a 32 bit.
Your screenshot explains not much without context. It's better to provide whole conversation.

Waveform's Developers:
viewtopic.php?p=7121135#p7121135
viewtopic.php?p=7280402#p7280402
viewtopic.php?p=7202039#p7202039

I've tried some 32-bit plugin and it obviously didn't loaded.

GuitarPlayerinNYC
KVRist
63 posts since 23 Dec, 2019

Re: Tracktion Universe 2020

Post Tue Feb 04, 2020 6:54 pm

Kott wrote:
Tue Feb 04, 2020 5:04 pm
No, read the quote I screenshot from support, and support addressed my 3rd party AGML.dll- he said that was a 32 bit.
Your screenshot explains not much without context. It's better to provide whole conversation.

Waveform's Developers:
viewtopic.php?p=7121135#p7121135
viewtopic.php?p=7280402#p7280402
viewtopic.php?p=7202039#p7202039

I've tried some 32-bit plugin and it obviously didn't loaded.
Read back about 8 posts for the conversation. The "conversation" was whether or not 32 bit plugins will work in WF10. Clearly, it does. I've removed all the 32 bit fx from DAW Essentials that appeared in my plugin menu.

The AGML2x86.dll is from this program, Ample Guitar M Lite v2.31, downloaded from https://www.amplesound.net/en/download.asp The first Windows Installer. The dll does not validate within Waveform, but you can paste the filename here: https://www.pconlife.com/searchfile/windowsosfile/ it says it's a 32 bit .dll. Yet, it's in my plugin menu, and it works. Support said it's a 32 bit dll.

Don't take this the wrong way, but your links are meaningless to me. I've been communicating with Support for 2 days, and they've said WF10 can run 32 bit plugins. But it's not designed to support them. I guess since it was their FX, they have an interest, but I really don't know. And they're trying to figure out how half my plugins disappeared.

Because it's never happened to you, doesn't mean it can't happen anywhere else. The vast majority of my 32 bit VSTs don't load. 32 bit Traction FXs, and AGML did. I'm in no position to explain why, that's why I contacted support. My report to them is 10X longer than this post, explaining step by step, everything I did to fix it. But it all started with my starting WF for the first time that day, half my plugins were gone, and Traction FX were doubled.

What more can I say? I thought you wanted this thread moved? Should anyone else run into this, ideally, I can help them. It took me 8 hours to get things right. I just wanted Support to tell me what might have gone wrong, or if there's a known glitch, to create a fix.

Kott
KVRist
145 posts since 12 Mar, 2013 from Russia, Vladivostok

Re: Tracktion Universe 2020

Post Tue Feb 04, 2020 8:16 pm

The "conversation" was whether or not 32 bit plugins will work in WF10. Clearly, it does.
Give to the support link to this thread, and if Devs confirm 32-64 bridging in >W9, I will admit that you're right.
32 bit Traction FXs, and AGML did
Installer contains both version 32 and 64.
I'm sure in 146% that you load 64-bit dlls, but think that it 32 :)

fedexnman
KVRAF
2630 posts since 4 Jan, 2005

Re: Tracktion Universe 2020

Post Tue Feb 04, 2020 8:24 pm

+1 on @Kott last comment .

User avatar
whyterabbyt
Beware the Quoth
27840 posts since 4 Sep, 2001 from R'lyeh Oceanic Amusement Park and Funfair

Re: Tracktion Universe 2020

Post Wed Feb 05, 2020 2:22 am

GuitarPlayerinNYC wrote:
Tue Feb 04, 2020 12:32 pm

However, this doesn't address how a 32 bit, rejected plugin works. Answer: Because WF10 can handle 32 bit VSTs. Source: Traction support, when I opened a ticket on my problem. It shouldn't load 32 bit VSTs, and I don't know if WF has a built-in bridge, but it can, and it does.

Seems the impossible, is possible. From Tracktion support: waveform runs 32 bit.JPG

Guess Tracktion is convincingly spreading false information about their own product.

Some people should remain silent, and be thought a fool, than open their mouth, and remove all doubt (not directed at you, fde101). Me, I like to collect facts, before jumping to specious conclusions.
Yes, some people do like to collect facts before jumping to specious conclusions. And its a fact that the developers of Tracktion/Waveform have repeatedly and specifically referred to 32-bit plugins not being intrinsically supported in 64-bit versions of Waveform.
If you dont believe me, feel free to use KVR's search to confirm the number of times dRowAudio refers to jbridge.

If that has changed, its not been mooted significantly as a feature, and thus is unknown to a large number of very seasoned Tracktion/Waveform users. And its still the case that the 64-bit build only scans 64-bit plugin folders by default.
And, personally, its the case that the version of Waveform 10 that I have does not accept x86 plugins as valid, and I see no option to make that change.
Its also a fact that sometimes, support staff are mistaken.

These things are all facts, so any statement that the x64 version of Waveform doesnt support x86 plugins is a non-specious conclusion. There are plenty of facts which support it as a conclusion.

I get the impression that may not be enough for you though. So Ive PM'd dRowAudio, the main developer, and asked him for an authoritive statement.
"The bearer of this signature is a genuine and authorised pope."

Return to “Tracktion”