Cream in Reaper x64?

Official support for: kirnuarp.com
KVRer
3 posts since 27 Feb, 2006

Post Sun Feb 17, 2013 12:37 am

I've tried the free Kirnu and it worked great so I got the Cream version to support development (And because it looks awesome)

Try as I may, I can't get Cream to work in Reaper with anything but midi channel 1

I'm using LASS2 which receives on midi channel 16 for auto-divisi to work, so my keyboard is sending on channel 16 and LASS2 is receiving on channel 16 and I've set cream's midi in/out to ch 16. I can see cream is getting midi as the midi light is flickering in cream.

Strange thing is if I swap cream for the free kirnu and set the in/out channels to 16 it works right away.

I've tried with other vsti's like Zebra2 or Omnispere and it's the same deal there, if I set input to anything but channel 1, no midi is sent to the vsti on the track.

I'm probably doing something wrong somewhere the manual is still kinda skimpy, anyone know how to get cream working in Reaper?

KVRist
40 posts since 16 Apr, 2004

Post Sun Feb 17, 2013 1:39 am

work fine for me in reaper 64 :

be careful to the track parameters.


for VST ,it only works with midi notes, not with midi cc.

if you wantto send midi cc to a vst, you have to outpout midi to a virtual midi port.

KVRer

Topic Starter

3 posts since 27 Feb, 2006

Post Sun Feb 17, 2013 2:54 am

Are you using anything other than channel 1 though?

Here's how I've set Cream up:

Add instrument track with kontakt on it, loaded instrument in kontakt set to port a channel 16.

My keyboard is set to send on channel 16, I can hear kontakt when I play.

Add cream to the fx chain, making sure it's above kontant in the list.

Set cream track 1 to receive on channel 16 (What my keyboard sends on), and set output channel to 16 (What kontakt receives on)

No sound.

If I do the above, but set channels to 1 instead, it works, I just can't do that because LA Scoring strings needs to use channel 16 for the internal scripting to work.

I've tried setting up cream on a dedicated track and adding a send to the kontakt track, same thing only channel 1 works, set it to something else and no sound.

I've made sure that the inputs and outputs on the track in Reaper is set correctly.

If I add the old free Kirnu instead of cream, everything works fine.

KVRist
40 posts since 16 Apr, 2004

Post Sun Feb 17, 2013 3:45 am

i have one track that outpout on several channels and tracks.
i will test with several inputs channel asap

KVRist
40 posts since 16 Apr, 2004

Post Sun Feb 17, 2013 4:07 am

result :

5 tracks

kirnu on track 3
track 1 and 2 send midi to kirnu on midi channel 1 and 2

2 vst on channel 4 and 5 that receive on midi channel 1 and 2


it works but if i mute the channel 2, kirnu track 2 doesn't stop, it continue to play the last played note

KVRist
40 posts since 16 Apr, 2004

Post Sun Feb 17, 2013 6:10 am

test 1 : reaper 64 kirnu32. first problem come with other daw(energyxt)
test2 reaper 64 kirnu 64

i've made an other test :

when i active the track 2 the track 1 stop.

it's a bug

KVRer

Topic Starter

3 posts since 27 Feb, 2006

Post Sun Feb 17, 2013 7:02 am

Yeah that's what I was thinking, because I'm using other midi generating plugins and no problems there, and the free kirnu works fine.

Return to “Kirnu”