the Fre(a)koscope: FEATURE REQUEST here

Official support for: smartelectronix.com
declassified
KVRian
1236 posts since 24 May, 2004 from Germany

Post Wed Mar 09, 2011 1:51 pm

I have been using this for some time and I really like it, but I think there are a few points that could be improved:

- We need magnitude zooming. The slider on the left should change the sensitivity of the amplitude axis. If turned all the way up, the graph would display a range of 0dB to -40dB, if turned all the way down, it would display 0dB to -100dB. Right now the graph appears too "flat", even if a signal (such as a snare) actually has significant peaks.

- At slow refresh rates, the graph jumps between seemingly random snapshots of time that don't really tell a lot about the signal. At fast refresh rates, it moves so fast that it's very hard to read. The "peak hold" curve is much smoother and better; I usually just look at that, but it's quite hard to read because of the colour...maybe there is a way to make the normal curve behave a little smoother? :)


Again, this is a very great plugin already and it's generous to give it away for free! :) If you can fix these points, I'll be happy to make a donation. :)

wjmwpg
KVRer
10 posts since 30 Apr, 2011 from Winnipeg MB

Post Sat Apr 30, 2011 11:58 am

zmix wrote: FYI: Logic does not read, use or understand VST plugins or instruments.

You will need to use a VST to AU Wrapper... (google that term).
Has anyone been able to get Fre(a)koscope successfully wrapped from VST to AU and running in Logic? I have two different VST to AU wrapping programs, and neither will wrap Fre(a)koscope - but it seems they'll wrap anything else!

Any advice would be greatly appreciated as I really could use this plug-in!

:help:

vic_france
KVRian
653 posts since 17 Mar, 2002 from Paris

Post Sun May 01, 2011 5:44 am

(btw, I can confirm that FXpansion's VST to AudioUnit Adapter does't succeed in wrapping the Fre(a)koscope VST)

I have just discovered that it does... almost!.. work in Cubase 5 Mac and also in Cubase 6 (32-bit mode only, obviously).. on OS X 10.6.7 here..
It loads o.k. but doesn't appear to be displaying any data. I discovered, purely by accident, that it works o.k. so long as I keep the mousebutton pressed over one of the GUI's knobs!

I'd certainly make pals with PayPal for an updated version of Fre(a)koscope! ;)
I did get a life,once...but it was faulty, so I sent it back.

wjmwpg
KVRer
10 posts since 30 Apr, 2011 from Winnipeg MB

Post Sun May 01, 2011 8:24 am

vic_france wrote:(btw, I can confirm that FXpansion's VST to AudioUnit Adapter does't succeed in wrapping the Fre(a)koscope VST)

I'd certainly make pals with PayPal for an updated version of Fre(a)koscope! ;)
I second that motion! My finger's on the Paypal trigger just waiting for a Fre(a)koscope update that I can run on my mac!

Nanakai
KVRian
588 posts since 3 Oct, 2011

Post Wed Oct 26, 2011 6:08 pm

Just wanted to throw my voice in here. I am ready to put my money in your pocket for an AU version so i can run this in Logic.

antelectro
KVRer
4 posts since 11 Sep, 2015

Re: the Fre(a)koscope: FEATURE REQUEST here

Post Thu Sep 10, 2015 5:00 pm

Hello,

I'm a beginner in audio,

Just got Welsh's synth cookbook, and he uses Freakoscope throughout, I would love to use it too ! But my daw is 64 bit :/

Is it possible to have it in 64 bit ? Does a 64 bit version exist, or can one be made ?

It would be really great !

Merci ! :)

jdubiner
KVRer
1 posts since 30 Nov, 2015

Re: the Fre(a)koscope: FEATURE REQUEST here

Post Mon Nov 30, 2015 9:10 am

I'm also working through the exercises in Walsh's Synth Cookbook, and I'd like to be able to use the Fre(a)koscope on my Max. 2014MBP / Intel / 64bit.

I would be willing to recompile the binary for 64 bit if the source is available.

Thanks

-- Joel

urospetkovic
KVRer
1 posts since 23 Mar, 2017

Re: the Fre(a)koscope: FEATURE REQUEST here

Post Thu Mar 23, 2017 8:44 am

I can't make it work on my Mac, running Yosemite 10.10.5 with Cubase 8.5. Works on Windows but here not, any ideas?

Dewdman42
KVRian
1499 posts since 14 Mar, 2006

Re: the Fre(a)koscope: FEATURE REQUEST here

Post Wed Jul 12, 2017 8:43 pm

The downloadable VST is PPC, will not work on modern intel macs. Maybe someday we can see it built for universal binary...vst and AU of course, but anyway, the VST isn't gonna work with any wrappers unless you're on a pretty old mac

Return to “Smart Electronix”