Spire: Problems and trouble shooting help

Official support for: reveal-sound.com
User avatar
kimik
KVRist
123 posts since 4 Sep, 2004 from Finland

Post Wed Oct 14, 2015 11:22 am

hey,

logic X on OSX 10.10.5

I have an active window problem with Spire that's very annoying, other synths don't do this. Everytime I want to control spire I need to first click on the GUI window to activate it (the controls don't work when clicking first time)
http://www.soundcloud.com/kimik --- Preset banks for TAL Bassline 101, TAL-UNO-LX-V2 + GForce Oddity2 available @ The Patchbay: https://thepatchbay.co.uk/

extratoe
KVRer
1 posts since 18 Feb, 2015

Re: Spire: Problems and trouble shooting help

Post Tue Nov 03, 2015 5:42 am

Hi there,

as an exploration (I'm new to this) I'm trying to use the step sequencer on some factory preset.

I guess I tried everything but I can't figure out why the sequence doesn't even start.


Here is the preset in attachement - can someone please explain me what I'm missing ?

Fyi, the preset is not meant to be nice. It's just about exercising.


Thank you in advance everybody
You do not have the required permissions to view the files attached to this post.

User avatar
jasonwoodman
KVRist
30 posts since 10 Mar, 2015 from UK

Re: Spire: Problems and trouble shooting help

Post Thu Nov 19, 2015 12:49 pm

Hello,

I've been getting this error starting from today. Wierd as I have had it installed for atleast 6 months.

Problem signature:
Problem Event Name: APPCRASH
Application Name: Cubase8.exe
Application Version: 8.0.30.536
Application Timestamp: 55e48727
Fault Module Name: Spire.dll
Fault Module Version: 1.0.20.0
Fault Module Timestamp: 54f8e698
Exception Code: c0000005
Exception Offset: 00000000000abad3
OS Version: 6.1.7601.2.1.0.768.3
Locale ID: 2057
Additional Information 1: 5846
Additional Information 2: 5846ada3738e20c6ba2f5f236fcd24e1
Additional Information 3: 7dab
Additional Information 4: 7dab8a03de5552f4c4ea666df2134969

I tried un/reinstalling it, but no difference.

It happens when I close and re-open spires gui a couple of times.

Any thoughts?

User avatar
fisherKing
KVRAF
2136 posts since 6 Aug, 2009

Re: Spire: Problems and trouble shooting help

Post Mon Nov 30, 2015 4:51 pm

i posted this on another thread, but time to dive in to the troubleshooting thread:

installed 1.1 (logic X 10.2, on os x 10.11.2). some sounds will NOT play from the keyboard (except for a stray note here or there); they WILL play from a sequence already written. seems...weird. and LX crashed once, so far: Spire 1.1 was to blame.

anyone else experiencing notes not playing? i emailed reveal-sound support, just wondering who else is seeing this...
https://upstatebrooklyn.com
always one plugin short of perfection...

psknak
KVRer
3 posts since 20 May, 2013 from Pittsburgh

Re: Spire: Problems and trouble shooting help

Post Thu Dec 10, 2015 7:12 pm

just purchased Spire and it does not work with FL Studio. The VST does not allow you to change presets without exiting the VST each time in order to hear the sound. In addition it freezes and the sound ring out without stopping. I followed the Buffer template they sent to me as a remedy to no prevail. This was not worth my time and effort and money. The product worked great a few years ago when I used it as a demo, now I purchased it and it is unusable. And yes I am not an amateur user, I am trained in the field of computers and I am a musician with over 500+ Vst's . If anyone out there has had these issues, let me know.
michael coury

patcub
KVRer
28 posts since 28 Mar, 2009

Re: Spire: Problems and trouble shooting help

Post Thu Dec 10, 2015 7:15 pm

I installed Spire 1.1, I noticed cubase crashes sometimes out of nowhere since then.

Also when I select an instrument track with spire in it, it seems like it's triggering a note in spire (option "enable record on selected track" set on).

I like Spire a lot, but I notice it's not 100% stable with cubase unfortunately.

Im on cubase 8.0.3 64bits, windows 7 64 bits).

chk071
KVRAF
23199 posts since 11 Apr, 2010 from Germany

Re: Spire: Problems and trouble shooting help

Post Thu Dec 10, 2015 7:36 pm

Did you send Reveal-Sound a support mail?

GilJ
KVRist
259 posts since 16 Mar, 2005

Re: Spire: Problems and trouble shooting help

Post Tue Dec 22, 2015 2:55 pm

Hi,

It's now been a couple of weeks that I have heavily been playing with Spire v1.1.

Reveal Sound have really done a great job with the CPU optimizations :tu:

However I am having quite often some crashes (which didn't happen with v1.0.20), mainly when stopping/starting playback in my DAW (Ableton Live 9 on Win7) or when jumping between different parts while the sequencer is playing (in arrangement view).

I get either some loud blasts or Live freezing :?

Anyone having the same issues here?

Thanks,
GilJ.

Ven Adams
KVRer
5 posts since 29 Jun, 2014

Re: Spire: Problems and trouble shooting help

Post Wed Dec 23, 2015 12:31 pm

GilJ wrote: However I am having quite often some crashes (which didn't happen with v1.0.20), mainly when stopping/starting playback in my DAW (Ableton Live 9 on Win7) or when jumping between different parts while the sequencer is playing (in arrangement view).

I get either some loud blasts or Live freezing :?

Anyone having the same issues here?

Thanks,
GilJ.

Same problems in Reaper 5, Ableton live 9, Bigwig 1.3.5 , Logic 10.2.0 . Mac Os 10.10.5
Last edited by Ven Adams on Thu Dec 24, 2015 12:39 pm, edited 1 time in total.

User avatar
ATN69
KVRAF
2034 posts since 5 Oct, 2015 from Swedish / Living in Hong Kong

Re: Spire: Problems and trouble shooting help

Post Thu Dec 24, 2015 2:05 am

Hi all.

In the past I bought many plugins and most of them were quite easy to install, and some of them were just messy. I just bought Spire and I just installed it. I have Windows 7 - 64 pro and FL studio 12. I have done everything by the book and when I open Spire in FL it open without problems. But the problem is that there is no sound at all. I do find the sound banks and I can load them in Spire, but no sound is heard. This is the first time ever I have this problem. I would be happy to get suggestions because I run out of ideas. I tried everything I can think of to solve this issue.

Merry Christmas! :party:
Win 10 -64bit, CPU i7-7700K, 32Gb, Focusrite 2i2, FL-studio 20, Studio One 4, Reason 10

User avatar
ATN69
KVRAF
2034 posts since 5 Oct, 2015 from Swedish / Living in Hong Kong

Re: Spire: Problems and trouble shooting help

Post Thu Dec 24, 2015 2:38 am

ATN69 wrote:Hi all.

In the past I bought many plugins and most of them were quite easy to install, and some of them were just messy. I just bought Spire and I just installed it. I have Windows 7 - 64 pro and FL studio 12. I have done everything by the book and when I open Spire in FL it open without problems. But the problem is that there is no sound at all. I do find the sound banks and I can load them in Spire, but no sound is heard. This is the first time ever I have this problem. I would be happy to get suggestions because I run out of ideas. I tried everything I can think of to solve this issue.

Merry Christmas! :party:
Just wanted to add that I now can see that Spire is crashing when I try to open it in FL. The GUI is there and it looks okay but FL throw me an error message. I used to have Spire as demo some time ago and I wonder if some old remaining files could cause this?
Win 10 -64bit, CPU i7-7700K, 32Gb, Focusrite 2i2, FL-studio 20, Studio One 4, Reason 10

User avatar
ATN69
KVRAF
2034 posts since 5 Oct, 2015 from Swedish / Living in Hong Kong

Re: Spire: Problems and trouble shooting help

Post Thu Dec 24, 2015 2:49 am

ATN69 wrote:
ATN69 wrote:Hi all.

In the past I bought many plugins and most of them were quite easy to install, and some of them were just messy. I just bought Spire and I just installed it. I have Windows 7 - 64 pro and FL studio 12. I have done everything by the book and when I open Spire in FL it open without problems. But the problem is that there is no sound at all. I do find the sound banks and I can load them in Spire, but no sound is heard. This is the first time ever I have this problem. I would be happy to get suggestions because I run out of ideas. I tried everything I can think of to solve this issue.

Merry Christmas! :party:
Just wanted to add that I now can see that Spire is crashing when I try to open it in FL. The GUI is there and it looks okay but FL throw me an error message. I used to have Spire as demo some time ago and I wonder if some old remaining files could cause this?
I found the solution here: http://reveal-sound.com/knowledge.php?27-30 ...some times it pays off to be stubborn :wink:
Win 10 -64bit, CPU i7-7700K, 32Gb, Focusrite 2i2, FL-studio 20, Studio One 4, Reason 10

GilJ
KVRist
259 posts since 16 Mar, 2005

Re: Spire: Problems and trouble shooting help

Post Tue Dec 29, 2015 7:15 am

Ven Adams wrote:
GilJ wrote: However I am having quite often some crashes (which didn't happen with v1.0.20), mainly when stopping/starting playback in my DAW (Ableton Live 9 on Win7) or when jumping between different parts while the sequencer is playing (in arrangement view).

I get either some loud blasts or Live freezing :?

Anyone having the same issues here?

Thanks,
GilJ.

Same problems in Reaper 5, Ableton live 9, Bigwig 1.3.5 , Logic 10.2.0 . Mac Os 10.10.5
Just wanted to say that v1.1.1 is running quite smooth so far 8)

User avatar
HamHat
KVRist
301 posts since 28 May, 2013 from Utah

Re: Spire: Problems and trouble shooting help

Post Tue Dec 29, 2015 4:45 pm

Why doesn't 1.1.1 vst replace 1.1 vst?

chk071
KVRAF
23199 posts since 11 Apr, 2010 from Germany

Re: Spire: Problems and trouble shooting help

Post Tue Dec 29, 2015 5:15 pm

HamHat wrote:Why doesn't 1.1.1 vst replace 1.1 vst?
It did here.

Return to “Reveal Sound”