Airwave - yet another WINE VST bridge for Linux (April 12 update)

Official support for: bitwig.com
User avatar
KVRist

Topic Starter

413 posts since 27 Mar, 2014

Post Sat Dec 10, 2016 12:51 am

You need to get the VST SDK. There is a pre-built binary for Ubuntu, is there a reason you try to build it yourself?

KVRer
8 posts since 10 Dec, 2016

Post Sat Dec 10, 2016 9:02 am

Hello,

I've downloaded the ZIP of the VST3 SDK and extracted it to the airwave directory, and I changed the path name appropriately, which is why I'm confused. I'm very new to linux, is there an easy GUI install that I'm missing out on or something? I'm just following the instructions on the github page.

User avatar
KVRist

Topic Starter

413 posts since 27 Mar, 2014

Post Sat Dec 10, 2016 9:05 am

What Linux distribution do you use? If it's Debian or its derivatives (Mint, Ubuntu, Kubuntu, etc) then you may just download the *.deb file and install it with your package manager

Code: Select all

dpkg -i <filename.deb>
https://github.com/phantom-code/airwave ... _amd64.deb

KVRer
8 posts since 10 Dec, 2016

Post Sat Dec 10, 2016 9:10 am

Phantom, thank you so much! I had no idea there was even a .deb file for this... I was pulling my hair out for so long. I'm very new to github, is a .deb file usually listed somewhere in github pages?

User avatar
KVRist

Topic Starter

413 posts since 27 Mar, 2014

Post Sat Dec 10, 2016 9:16 am

Well, I build a deb package when I release a new version of airwave. Some developers do this, others don't. Every project is different. Just look to "releases" page:
Image

User avatar
KVRist

Topic Starter

413 posts since 27 Mar, 2014

Post Sat Dec 10, 2016 9:17 am

phantom-one wrote:Well, I build the deb package when I release a new version of airwave. Some developers do this, others don't. Every project is different. Just look to "releases" page:
Image

User avatar
KVRist

Topic Starter

413 posts since 27 Mar, 2014

Post Sat Dec 10, 2016 9:17 am

deleted

KVRer
8 posts since 10 Dec, 2016

Post Sat Dec 10, 2016 9:19 am

Thanks so much again phantom! Until now, for the past month I was building every github app I used from source haha.

Now if I get an error that for the "VST Plugin" field that "Selected Prefix Directory Doesn't Exist" would that be something to do with the WINE version I have? I have wine 1.8.5 for ubuntu.

KVRer
8 posts since 10 Dec, 2016

Post Sat Dec 10, 2016 9:28 am

Phantom, sorry for asking that. I realized I just had to run wine on the setup.exe file I had for the VST and that created paths for me to operate on. Thanks for all the help, very surprised I got such a quick response from you.

KVRer
8 posts since 10 Dec, 2016

Post Sat Dec 10, 2016 9:45 am

Actual question now:

If airwave gives me the error that the link location is corrupted, does that mean that the .dll file itself is corrupted that I'm trying to use, or is there a problem with the path that I have chosen? I chose a VST folder on my dekstop, which is what my bitwig has as a VST location to look in.

User avatar
KVRist

Topic Starter

413 posts since 27 Mar, 2014

Post Sat Dec 10, 2016 9:52 am

Have you moved any .so file manually?

KVRer
8 posts since 10 Dec, 2016

Post Sat Dec 10, 2016 9:59 am

Nope, I tried loading another VST and it doesn't output that error though, and bitwig just spends forever trying to index that location. I'm assuming that the .dll files are corrupted or something.

For the second VST, if it gives me a "child process terminated" message in the log and bitwig just keeps trying to index the VST folder that I specified, should I be changing the log level?

KVRer
8 posts since 10 Dec, 2016

Post Sat Dec 10, 2016 3:58 pm

Nevermind, I figured it out! Looks like the application only works with the 32 bit plugins I have, and some of the others don't work at all. Such is life :p

Please let me know if there is anywhere I can donate to you, this is awesome for me and really helps my workflow issues.

User avatar
KVRist

Topic Starter

413 posts since 27 Mar, 2014

Post Sun Dec 11, 2016 12:03 am

There is a chance that you have a 32-bit wineprefix. Personally, I think it's better to use 32-bit plugins.
I made this bridge just for fun and because I need it myself. Airwave has a ton of issues with different hosts and plugins. It is almost impossible to make it rock-stable and I just can't accept donations for such a "weak" thing. Anyway, thanks for offering and have fun! I hope it will work well for you! :wink:

KVRist
151 posts since 11 Aug, 2016

Post Tue Dec 13, 2016 10:50 pm

Serum activation seems doesnt work, when I insert the key, it just go down like this.
Image

Return to “Bitwig”