Bitwig in Flatpak

Official support for: bitwig.com
KVRian
788 posts since 26 May, 2013 from France, Sisteron

Post Wed Apr 14, 2021 5:45 pm

They share the same user data.
You can try to only have the flatpak one installed and if you stumble across a new issue please let us know.
Thank you :)

KVRist

Topic Starter

107 posts since 27 Mar, 2014

Post Wed Apr 14, 2021 9:34 pm

BTW, the new, kind of official, flatpak for bitwig studio is: https://github.com/bitwig/bitwig-studio-flatpak/

I, regularly, try to collaborate with them on the upgrades.

It's pretty cool because it is compatible with pipewire, which rocks. Just make sure you configure pipewire correctly (or use Fedora 34).

User avatar
KVRAF
8192 posts since 4 Jan, 2017 from Warsaw, Poland

Post Wed Apr 14, 2021 10:05 pm

Renich wrote:
Wed Apr 14, 2021 9:34 pm
BTW, the new, kind of official, flatpak for bitwig studio is: https://github.com/bitwig/bitwig-studio-flatpak/

I, regularly, try to collaborate with them on the upgrades.

It's pretty cool because it is compatible with pipewire, which rocks. Just make sure you configure pipewire correctly (or use Fedora 34).
This is the same that @Abique posted.
Music tech enthusiast.
DAW, VST & hardware hoarder.
My "music": https://soundcloud.com/antic604

KVRian
788 posts since 26 May, 2013 from France, Sisteron

Post Thu Apr 15, 2021 1:14 am

Renich wrote:
Wed Apr 14, 2021 9:34 pm
BTW, the new, kind of official, flatpak for bitwig studio is: https://github.com/bitwig/bitwig-studio-flatpak/

I, regularly, try to collaborate with them on the upgrades.

It's pretty cool because it is compatible with pipewire, which rocks. Just make sure you configure pipewire correctly (or use Fedora 34).
Hi Renich,
It is now online on flathub: https://flathub.org/apps/details/com.bi ... twigStudio

KVRist

Topic Starter

107 posts since 27 Mar, 2014

Post Thu Apr 15, 2021 1:39 am

Whoa! Awesome! Didn't know, hehe.

KVRer
27 posts since 11 Feb, 2021

Post Tue Apr 27, 2021 6:50 am

abique wrote:
Wed Apr 14, 2021 7:18 am
lunardigs wrote:
Wed Apr 14, 2021 7:00 am
abique wrote:
Tue Apr 13, 2021 11:56 pm
You can now install bitwig from flathub: https://flathub.org/apps/details/com.bi ... twigStudio
Wow, this is super! Thanks, abique!

Are there any limitations, or peculiarities to be aware of? I know this kind of thing can happen with Flatpaks, sometimes for the better.
You are welcome.
From my testing it is working well. It is sandboxed, so there might be some limitations like writing files outside of your home folder, but we'll discover it over time.
Would this be a reason why I can't import samples from an external drive?
For some reason it is also not picking up VST's from .wine

Anndddd for some reason JACK (w/ Pipewire Fedora 34) is not giving any actual output...

:D

KVRian
788 posts since 26 May, 2013 from France, Sisteron

Post Tue Apr 27, 2021 6:57 am

There should be a way to disable the sandbox when starting the application.

KVRist

Topic Starter

107 posts since 27 Mar, 2014

Post Tue Apr 27, 2021 8:09 am

Josephhh wrote:
Tue Apr 27, 2021 6:50 am
Would this be a reason why I can't import samples from an external drive?
For some reason it is also not picking up VST's from .wine

Anndddd for some reason JACK (w/ Pipewire Fedora 34) is not giving any actual output...

:D
Well, when you use

Code: Select all

flatpak run --help
you will see many options. You can enable/disable features and that sort of things. Try your luck with that and reading the manual from flatpak. https://docs.flatpak.org/en/latest/

On the jack side, I've experienced that too sometime. I run Fedora 34 as well. Sometimes a reboot fixes it. Also, here're my settings so you can compare. Only including what I've changed.

/etc/pipewire/pipewire.conf

Code: Select all

# Daemon config file for PipeWire version "0.3.26" #

context.properties = {
    support.dbus                          = true
    link.max-buffers                       = 16
    default.clock.rate        = 48000
    default.clock.quantum     = 128
    default.clock.min-quantum = 64
    default.clock.max-quantum = 2048

    vm.overrides = {
        default.clock.min-quantum     = 64
    }
}
/etc/pipewire/jack.conf

Code: Select all

jack.properties = {
     node.latency = 128/48000
     jack.merge-monitor = true
     jack.short-name = true
     jack.filter-name = true
}
After that, just reboot to make sure. You could, alternatively, try:

Code: Select all

pkill -f pipewire
but, sometimes, that doesn't work, IDKW.

KVRist

Topic Starter

107 posts since 27 Mar, 2014

Post Tue Apr 27, 2021 8:09 am

That said, I haven't experienced the loss of audio in a long time.

KVRer
27 posts since 11 Feb, 2021

Post Tue Apr 27, 2021 8:26 am

Renich wrote:
Tue Apr 27, 2021 8:09 am
Josephhh wrote:
Tue Apr 27, 2021 6:50 am
Would this be a reason why I can't import samples from an external drive?
For some reason it is also not picking up VST's from .wine

Anndddd for some reason JACK (w/ Pipewire Fedora 34) is not giving any actual output...

:D
Well, when you use

Code: Select all

flatpak run --help
you will see many options. You can enable/disable features and that sort of things. Try your luck with that and reading the manual from flatpak. https://docs.flatpak.org/en/latest/

On the jack side, I've experienced that too sometime. I run Fedora 34 as well. Sometimes a reboot fixes it. Also, here're my settings so you can compare. Only including what I've changed.

/etc/pipewire/pipewire.conf

Code: Select all

# Daemon config file for PipeWire version "0.3.26" #

context.properties = {
    support.dbus                          = true
    link.max-buffers                       = 16
    default.clock.rate        = 48000
    default.clock.quantum     = 128
    default.clock.min-quantum = 64
    default.clock.max-quantum = 2048

    vm.overrides = {
        default.clock.min-quantum     = 64
    }
}
/etc/pipewire/jack.conf

Code: Select all

jack.properties = {
     node.latency = 128/48000
     jack.merge-monitor = true
     jack.short-name = true
     jack.filter-name = true
}
After that, just reboot to make sure. You could, alternatively, try:

Code: Select all

pkill -f pipewire
but, sometimes, that doesn't work, IDKW.
Thank you for the informative post :)

I had manually set the latencies in there but nothing else.... Iv'e matched those settings basically and still nothing :(

I had to manually change the node name to unhook the sound card to get ALSA to work in /etc/pipewire/media-session.d/alsa-monitor.conf ... and made the age old mistake of overwriting and not backing up haha. is your node name set to "~alsa_input.*" ?

I had pipewire working before with bitwig on an Arch based system, and it works with PA at the moment

EDIT: Ok, changing permission was easy enough and worked fine :) but just to test I tried out the .deb archive and jack works fine ....

KVRist

Topic Starter

107 posts since 27 Mar, 2014

Post Tue Apr 27, 2021 11:15 am

OK, here's another thing to check when using pipewire's "jack". I like to use qjackctl to check the graph. It helps me visualize what the config is. Pretty cool.

Image

KVRer
27 posts since 11 Feb, 2021

Post Tue Apr 27, 2021 9:12 pm

Renich wrote:
Tue Apr 27, 2021 11:15 am
OK, here's another thing to check when using pipewire's "jack". I like to use qjackctl to check the graph. It helps me visualize what the config is. Pretty cool.
Cheers, appreciate it :hug:

KVRist

Topic Starter

107 posts since 27 Mar, 2014

Post Wed Apr 28, 2021 7:15 am

One last thing. I cleanly installed Fedora 34 yesterday on my laptop and installed Bitwig Studio from Flatpak. It worked out of the box. Yet, I configured the outputs correctly since *system/capture_1* doesn't work.

It worked right "out of the box".

KVRer
27 posts since 11 Feb, 2021

Post Wed Apr 28, 2021 7:36 am

Renich wrote:
Wed Apr 28, 2021 7:15 am
One last thing. I cleanly installed Fedora 34 yesterday on my laptop and installed Bitwig Studio from Flatpak. It worked out of the box. Yet, I configured the outputs correctly since *system/capture_1* doesn't work.

It worked right "out of the box".
Lol classic :dog:

Anyway, I had to go back to the normal version as I don't think running bridged plugins with wine is doable through flatpak (without signifigant effort).... Any wisdom regardng this?

KVRist

Topic Starter

107 posts since 27 Mar, 2014

Post Wed Apr 28, 2021 7:44 am

Well, as far as I know, you just need to add some flags to the flatpak command. Judging from:

Code: Select all

flatpak run --help
; I'd say it would be enough to do:

Code: Select all

flatpak run --filesystem=/home/whatever-your-user-is/path/to/vst/folder com.bitwig.BitwigStudio
or something like that.

Return to “Bitwig”