Sporadic XRUNS / Linux

Official support for: bitwig.com
sth
KVRist
247 posts since 20 May, 2018

Post Tue Jun 16, 2020 12:59 pm

lilith93 wrote:
Tue Jun 16, 2020 11:58 am
Somebody just posted a Bitwig stresstest @discord: https://www.heise.de/select/ct/2020/7/s ... k.softlink


I can run 34 instances without any xrun. The DSP and CPU load are @ 100%, but no xruns. xruns start when I add the 35 instance with 1024 samples @ 48kHz with i5 Intel Core i5-4460 Quadcore, using Jack on Debian Buster (Behringer UMC 204)

So I guess my system is optimized well and that the spikes are caused by something else.

https://i.imgur.com/9HpBKaD.png
Nice, I opened all 70 and I'm at about 64% DSP Load with no xruns.

User avatar
KVRist

Topic Starter

103 posts since 7 Apr, 2018

Post Sun Jun 21, 2020 8:23 am

At the moment it's quite robust and don't get these these spikes with these settings:

1) I'm using the Debian RT kernel 4.19.0-9-rt-amd64 with rtirq (https://alsa.opensrc.org/Rtirq)
2) I switched off sand boxing (VST option: within Bitwig)

Buffer size 1024 samples

I don't dare to touch the settings at the moment, cause it's working.

KVRer
24 posts since 14 Jan, 2015 from Tallinn, Estonia

Post Thu Oct 15, 2020 2:58 am

Having the same problem on Linux Mint 20 + Jack, and the only way to fix it was to disable the plug-in sandboxing which leaves Bitwig without one of its best features. Any ideas why plug-in sandboxing may cause regular and predictable xruns which can be seen on Bitwig's DSP graph?

KVRian
785 posts since 26 May, 2013 from France, Sisteron

Post Thu Oct 15, 2020 3:09 am

sudo cpupower frequency-set -g performance

User avatar
KVRAF
7964 posts since 4 Jan, 2017 from Warsaw, Poland

Post Thu Oct 15, 2020 3:22 am

abique wrote:
Thu Oct 15, 2020 3:09 am
sudo cpupower frequency-set -g performance
Hey, what are you doing here?! Go and release the v3.3 beta! ;) :D :hug: :love:

BTW, this will be useful as I'm moving to Linux! :hyper:
Music tech enthusiast.
DAW, VST & hardware hoarder.
My "music": https://soundcloud.com/antic604

KVRer
24 posts since 14 Jan, 2015 from Tallinn, Estonia

Post Thu Oct 15, 2020 4:37 am

abique wrote:
Thu Oct 15, 2020 3:09 am
sudo cpupower frequency-set -g performance
Hi, abique! Unfortunately I've tried it before and all my CPU cores are already in "performance mode. I've also noticed that these periodic spikes never happen when Bitwig's sandbox mode is set to "Within Bitwig" and always showing up when sandbox is turned on (i.e. "together" or more advanced modes).

Attaching DSP graphs of idle state (no music, just one u-he or Moddart plug-in is loaded in a project):
Image

Image

Here's the result of realtimeconfigquickscan utility:

Code: Select all

Checking if you are root... no - good
Checking filesystem 'noatime' parameter... 5.4.0 kernel - good
(relatime is default since 2.6.30)
Checking CPU Governors... CPU 0: 'performance' CPU 1: 'performance' CPU 10: 'performance' CPU 11: 'performance' CPU 2: 'performance' CPU 3: 'performance' CPU 4: 'performance' CPU 5: 'performance' CPU 6: 'performance' CPU 7: 'performance' CPU 8: 'performance' CPU 9: 'performance'  - good
Checking swappiness... 10 - good
Checking for resource-intensive background processes... none found - good
Checking checking sysctl inotify max_user_watches... >= 524288 - good
Checking whether you're in the 'audio' group... yes - good
Checking for multiple 'audio' groups... no - good
Checking the ability to prioritize processes with chrt... yes - good
Checking kernel support for high resolution timers... found - good
Kernel with Real-Time Preemption... not found - not good]
Kernel without 'threadirqs' parameter or real-time capabilities found
For more information, see https://wiki.linuxaudio.org/wiki/system_configuration#do_i_really_need_a_real-time_kernel
Checking if kernel system timer is high-resolution... found - good
Checking kernel support for tickless timer... found - good
My hardware is:
- USB audio interface: Tascam US-2x2
- CPU: AMD Ryzen 5 1600
- RAM: 16 gb DDR4
- Graphics: NVidia GeForce GTX 1060 6 gb (using proprietary driver ver. 450)

I didn't have the same problem with Bitwig on Windows 10 installation.
Also tried to turn off Bluetooth and Wi-Fi -- still the same.

KVRian
785 posts since 26 May, 2013 from France, Sisteron

Post Thu Oct 15, 2020 4:42 am

What if you use alsa instead of jack?
Through it should not matter.
Do you use plugins or it is a bitwig only project?

KVRian
785 posts since 26 May, 2013 from France, Sisteron

Post Thu Oct 15, 2020 4:42 am

antic604 wrote:
Thu Oct 15, 2020 3:22 am
BTW, this will be useful as I'm moving to Linux! :hyper:
This is a good idea :-)

KVRer
24 posts since 14 Jan, 2015 from Tallinn, Estonia

Post Thu Oct 15, 2020 4:48 am

abique wrote:
Thu Oct 15, 2020 4:42 am
What if you use alsa instead of jack?
Through it should not matter.
Do you use plugins or it is a bitwig only project?
Yeah, ALSA vs JACK does not matter, the only thing that has an influence is Bitwig's sandbox setting.
The problem appears only when I use 3rd-party native VST's (u-he Repro-1/5, ZebraHZ, Bazille) or LV2 (Pianoteq 6). At first I suspected Wine VST layer "yabridge" could do this, but turning off and removing all Windows VSTs didn't help at all.
Bitwig runs very smoothly and without xruns when I use only stock devices, regardless of selected sandbox mode (that is not surprising).

KVRian
785 posts since 26 May, 2013 from France, Sisteron

Post Thu Oct 15, 2020 4:51 am

Are you on Ubuntu?

KVRer
24 posts since 14 Jan, 2015 from Tallinn, Estonia

Post Thu Oct 15, 2020 4:53 am

abique wrote:
Thu Oct 15, 2020 4:51 am
Are you on Ubuntu?
Linux Mint 20 with Cinnamon DE. Also tried some simple window manager instead of DE, and even with i3wm the problem persists.

KVRian
785 posts since 26 May, 2013 from France, Sisteron

Post Thu Oct 15, 2020 5:01 am

I think I've already heard of this issue. It could be related on how the plugin host is supposed to wake up and get scheduled. Nothing you can do on your side I presume, and maybe it is something we should spend sometime to look into. For now maybe keep the plugins inside the engine.

I'm on Arch and I use the zen kernel: https://www.archlinux.org/packages/?name=linux-zen and I don't have your issue.

KVRer
24 posts since 14 Jan, 2015 from Tallinn, Estonia

Post Thu Oct 15, 2020 5:03 am

abique wrote:
Thu Oct 15, 2020 5:01 am
I think I've already heard of this issue. It could be related on how the plugin host is supposed to wake up and get scheduled. Nothing you can do on your side I presume, and maybe it is something we should spend sometime to look into. For now maybe keep the plugins inside the engine.

I'm on Arch and I use the zen kernel: https://www.archlinux.org/packages/?name=linux-zen and I don't have your issue.
Ok, so I'll just avoid sandbox mode for a while. Thanks for feedback, abique!
Last edited by perkelekurat on Thu Oct 15, 2020 5:41 am, edited 1 time in total.

KVRer
24 posts since 14 Jan, 2015 from Tallinn, Estonia

Post Thu Oct 15, 2020 5:30 am

abique wrote:
Thu Oct 15, 2020 5:01 am
I think I've already heard of this issue. It could be related on how the plugin host is supposed to wake up and get scheduled. Nothing you can do on your side I presume, and maybe it is something we should spend sometime to look into. For now maybe keep the plugins inside the engine.

I'm on Arch and I use the zen kernel: https://www.archlinux.org/packages/?name=linux-zen and I don't have your issue.
I've just found an alternative to zen kernel for Debian-based systems -- Liquorix -- and installed it instead of stock lowlatency kernel from official Mint repository. The problem has disappeared, no more spikes with sandbox mode! :party: So liquorix kernel might be a solution to anyone who experience the same problem with Bitwig sandbox mode.

KVRian
1239 posts since 15 May, 2002 from Finland

Post Thu Oct 15, 2020 12:15 pm

I have the exactly same kind of regular spikes at least in one project, I use Ubuntu Studio. It's notable that the interval looks identical. They are even about the same height on 1024 samples (i7 6700)

They are present also with the low latency kernel, but less than with the generic kernel. I think the project had one or two Windows VSTs running. I'll have to check with a full native project. I tried installing Liquorix, but apparently it does not work out of the box in Ubuntu Studio, I fail to get it available in the boot menu. I have notified the creator of this...

Return to “Bitwig”