BWS 3.3.7 available

Official support for: bitwig.com
KVRist
204 posts since 21 Feb, 2012

Post Thu Apr 01, 2021 7:03 am

Changes in Bitwig Studio 3.3.7 [released 31 March 2021]

FIXES:
- Windows: With WASAPI, audio engine
  would sometimes crash when devices
  disconnected from WASAPI (because of
  computer sleep/wake, disconnecting
  bluetooth speakers, etc.) [25540]
- Mac: MP3 import was failing on
  macOS 10.13
- Linux: Text input was delayed with
  certain OS settings
Last edited by horizon7 on Wed Apr 07, 2021 2:08 pm, edited 1 time in total.

KVRist
47 posts since 28 Mar, 2010

Post Thu Apr 01, 2021 7:26 am

This is how you know we are at the end of Bitwig 3 and moving onto version 4. They always like to leave the last version as stable as possible for those who don't upgrade
Studio One 5.2, Bitwig 3.3.5, FL Studio 20.8.2 + Windows 10

KVRAF
6670 posts since 2 Dec, 2004 from North Wales

Post Thu Apr 01, 2021 8:26 am

I hope it is the last one, I am actually getting a bit fed up of all these little releases and have just started skipping them. Some are 'pre-release bug fixes (?), some updates, most are tiny little things that should really all be lumped together.

Every time they update I have to uninstall and old version and re-install a new version and then a week later, another little bug fix update. Ableton have a much better system, updates within the program with complete re-installs and uninstalls to fix a small bug.
PC, BWS, Live and Studio One, Renoise, X32 Desk, Hardware Synths + Eurorack, MPC Live, A4 and RYTM, PT, TD27 V Drums, Guitars, Basses

KVRist
130 posts since 12 Apr, 2006

Post Thu Apr 01, 2021 9:01 am

hi ! since v3.3.7 i have problems on the startup preset with the VCO 2 of brainworx bx_oberhausen v 1.4.0 latest v. ! VCO 2 complet out of order !
on bitwig v. 3.3.6 the VCO 2 was working on the start up preset because i had worked on it yesterday ! i have no clue . well just 1 presets but a bit strange ! any body else ?
+ when u press " shift " and tip with the mouse on it the sustain knob on ENV 1 starts to move works just on sustain knob on ENV 1 :hihi: .
this is not a april joke :help: :pray: :nutter:
win 10 64bit
Last edited by hihat on Thu Apr 01, 2021 9:48 am, edited 6 times in total.

User avatar
KVRAF
18516 posts since 3 Feb, 2005 from in the wilds

Post Thu Apr 01, 2021 9:03 am

SLiC wrote:
Thu Apr 01, 2021 8:26 am
I hope it is the last one, I am actually getting a bit fed up of all these little releases and have just started skipping them. Some are 'pre-release bug fixes (?), some updates, most are tiny little things that should really all be lumped together.

Every time they update I have to uninstall and old version and re-install a new version and then a week later, another little bug fix update. Ableton have a much better system, updates within the program with complete re-installs and uninstalls to fix a small bug.
I really prefer the Bitwig system... at least on Mac. I download the new update, launch it, drag it to the applications folder and I have a choice to overwrite and keep both. I always keep both in case I want to roll back. When I am satisfied with the new update, I can simply delete the older version.

I never have to be concerned about issues in a new update cause the old one is always right there. Best system for me with complex software like a DAW.

KVRAF
6670 posts since 2 Dec, 2004 from North Wales

Post Thu Apr 01, 2021 10:28 am

pdxindy wrote:
Thu Apr 01, 2021 9:03 am
SLiC wrote:
Thu Apr 01, 2021 8:26 am
I hope it is the last one, I am actually getting a bit fed up of all these little releases and have just started skipping them. Some are 'pre-release bug fixes (?), some updates, most are tiny little things that should really all be lumped together.

Every time they update I have to uninstall and old version and re-install a new version and then a week later, another little bug fix update. Ableton have a much better system, updates within the program with complete re-installs and uninstalls to fix a small bug.
I really prefer the Bitwig system... at least on Mac. I download the new update, launch it, drag it to the applications folder and I have a choice to overwrite and keep both. I always keep both in case I want to roll back. When I am satisfied with the new update, I can simply delete the older version.

I never have to be concerned about issues in a new update cause the old one is always right there. Best system for me with complex software like a DAW.
I can see the advantages as you suggest, but not every couple of weeks! Are these releases even beta tested? There always seems to be new problems with ever release and then a release to correct the new problem introduced...rolling all of these little bug fixes together with a proper beta test period would seem better solution to me.
PC, BWS, Live and Studio One, Renoise, X32 Desk, Hardware Synths + Eurorack, MPC Live, A4 and RYTM, PT, TD27 V Drums, Guitars, Basses

KVRAF
6670 posts since 2 Dec, 2004 from North Wales

Post Thu Apr 01, 2021 10:52 am

hihat wrote:
Thu Apr 01, 2021 9:01 am
hi ! since v3.3.7 i have problems on the startup preset with the VCO 2 of brainworx bx_oberhausen v 1.4.0 latest v. ! VCO 2 complet out of order !
on bitwig v. 3.3.6 the VCO 2 was working on the start up preset because i had worked on it yesterday ! i have no clue . well just 1 presets but a bit strange ! any body else ?
+ when u press " shift " and tip with the mouse on it the sustain knob on ENV 1 starts to move works just on sustain knob on ENV 1 :hihi: .
this is not a april joke :help: :pray: :nutter:
win 10 64bit
I can confirm that the knob keeps moving when you hold shift down...
I also get a crash on exit, had to go to task manager to close. This seems random (maybe when the wheel is spinning/scanning?)
PC, BWS, Live and Studio One, Renoise, X32 Desk, Hardware Synths + Eurorack, MPC Live, A4 and RYTM, PT, TD27 V Drums, Guitars, Basses

KVRist
130 posts since 12 Apr, 2006

Post Thu Apr 01, 2021 7:00 pm

thanx :tu: .so i guess wait for v.3.3.8 or 1.4.1. because nobody want believe either bitwig or brainworx.
they will ask me if I haven't paid enough :D
btw. havent checked my other brainworx plug the spl iron :scared:

User avatar
KVRAF
8011 posts since 4 Jan, 2017 from Warsaw, Poland

Post Thu Apr 01, 2021 10:42 pm

---
Music tech enthusiast.
DAW, VST & hardware hoarder.
My "music": https://soundcloud.com/antic604

KVRist
160 posts since 6 Jun, 2018 from Liverpool >> Berlin

Post Fri Apr 02, 2021 1:11 am

hihat wrote:
Thu Apr 01, 2021 7:00 pm
thanx :tu: .so i guess wait for v.3.3.8 or 1.4.1. because nobody want believe either bitwig or brainworx.
they will ask me if I haven't paid enough :D
btw. havent checked my other brainworx plug the spl iron :scared:
ahh my youngest was talking about that during breakfast this morning, didn't get it, but now i see what she meant ;)
she uses 3.3.6 and saw it happen with spl, bx_ and ada
just tested it in S1 5 and Live: no weirdness there, not with spl nor bx_ or ada.

so 3.3.7 is even worse? not going to update bs for her then...

KVRist
130 posts since 12 Apr, 2006

Post Fri Apr 02, 2021 4:05 am

I didn't notice the running button in version 3.3.6. But in 3.3.6 the vco 2 was perfect and in 3.3.7 there are at least 2-3 presets in bx oberhausen where vco 2 did not work. had no time to test spl iron
i will send this thread link to brainworx and bitwig Support :D

KVRist

Topic Starter

204 posts since 21 Feb, 2012

Post Fri Apr 02, 2021 4:55 am

SLiC wrote:
Thu Apr 01, 2021 10:52 am
hihat wrote:
Thu Apr 01, 2021 9:01 am
hi ! since v3.3.7 i have problems on the startup preset with the VCO 2 of brainworx bx_oberhausen v 1.4.0 latest v. ! VCO 2 complet out of order !
on bitwig v. 3.3.6 the VCO 2 was working on the start up preset because i had worked on it yesterday ! i have no clue . well just 1 presets but a bit strange ! any body else ?
+ when u press " shift " and tip with the mouse on it the sustain knob on ENV 1 starts to move works just on sustain knob on ENV 1 :hihi: .
this is not a april joke :help: :pray: :nutter:
win 10 64bit
I can confirm that the knob keeps moving when you hold shift down...
I also get a crash on exit, had to go to task manager to close. This seems random (maybe when the wheel is spinning/scanning?)
Yes the exit issue happens to me also it causes a freeze for long time & I have to stop it via task manager, As I’m using windows.
The exit issue causes a cpu overload.

KVRAF
6670 posts since 2 Dec, 2004 from North Wales

Post Fri Apr 02, 2021 5:56 am

horizon7 wrote:
Fri Apr 02, 2021 4:55 am
SLiC wrote:
Thu Apr 01, 2021 10:52 am
hihat wrote:
Thu Apr 01, 2021 9:01 am
hi ! since v3.3.7 i have problems on the startup preset with the VCO 2 of brainworx bx_oberhausen v 1.4.0 latest v. ! VCO 2 complet out of order !
on bitwig v. 3.3.6 the VCO 2 was working on the start up preset because i had worked on it yesterday ! i have no clue . well just 1 presets but a bit strange ! any body else ?
+ when u press " shift " and tip with the mouse on it the sustain knob on ENV 1 starts to move works just on sustain knob on ENV 1 :hihi: .
this is not a april joke :help: :pray: :nutter:
win 10 64bit
I can confirm that the knob keeps moving when you hold shift down...
I also get a crash on exit, had to go to task manager to close. This seems random (maybe when the wheel is spinning/scanning?)
Yes the exit issue happens to me also it causes a freeze for long time & I have to stop it via task manager, As I’m using windows.
The exit issue causes a cpu overload.
I had already reported the not closing down properly bug, thought it was just me!
PC, BWS, Live and Studio One, Renoise, X32 Desk, Hardware Synths + Eurorack, MPC Live, A4 and RYTM, PT, TD27 V Drums, Guitars, Basses

KVRist
130 posts since 12 Apr, 2006

Post Mon Apr 05, 2021 11:15 am

the spl iron also has small quirks since the bitwig update 3.3.7. the setting of the rotary controls jump back and forth immediately after touching
and bitwig doesn't save when the plugin is on screen

KVRist
338 posts since 17 Apr, 2004

Post Tue Apr 06, 2021 12:24 pm

My SoundToys stuff won't load up in 3.3.7. Just kind of eternally scans them.

Return to “Bitwig”