Arturia Beatstep and Beatstep Pro support is here

turbo_kev
KVRian
510 posts since 18 Dec, 2014

Post Tue Mar 29, 2016 3:28 pm

Hi

has the script been updated to work with 1.3.9 ????

I cant get anything to work

cheers
kev
BWS 2.4.3, Spark LE, V Collection 6.2, BS 1 & BS PRO, Keystep, keylab 25, Axiom pro 49,Focusrite Scarlett 8i6,Launchpad Pro,ProFx8 v2,Icon m+ & D2,KRK 10/3,win 10 pro,i7 5820k 4ghz ,16G ddr 4 ,1TB NVMe.M2, msi x99a sli + , Nvidia GF Gt 710,

User avatar
moss
KVRian
1407 posts since 13 May, 2004

Re: Arturia Beatstep and Beatstep Pro support is here

Post Tue Mar 29, 2016 11:16 pm

turbo_kev wrote:Hi

has the script been updated to work with 1.3.9 ????

I cant get anything to work

cheers
kev
There are no changes on the scripting side with 1.3.9.

Can you be more specific what's your problem? Any errors in the script log (View -> Show Control Script Console)?

turbo_kev
KVRian
510 posts since 18 Dec, 2014

Re: Arturia Beatstep and Beatstep Pro support is here

Post Wed Mar 30, 2016 2:02 pm

Hi Moss

After watching the video I understand that we can now use the shift key to change the modes

When I first turn on the beat step and press the shift key

pad ( 1 2 RED ) ( 3 4 5 PINK ) ( 6 BLUE ) ( 7 out ) ( 8 RED ) top row

Pad ( 9 BLUE ) ( 10 RED ) ( 11 PINK ) ( 12 13 14 15 out ) ( 16 PINK ) bottom row

But no matter what pads I press it just stays in mode 1
the big knob moves the play head. knob 16 crossfade knob 8 volume knob 7 play head
knob 6 tempo knob 4 solo knob 3 mute knob 2 pan knob 1 volume knob 9 send

there are NO errors in the script console

Nothing else seems to work ?
What am I doing wrong ?
thanks for your hard work

Cheers
Kevin
BWS 2.4.3, Spark LE, V Collection 6.2, BS 1 & BS PRO, Keystep, keylab 25, Axiom pro 49,Focusrite Scarlett 8i6,Launchpad Pro,ProFx8 v2,Icon m+ & D2,KRK 10/3,win 10 pro,i7 5820k 4ghz ,16G ddr 4 ,1TB NVMe.M2, msi x99a sli + , Nvidia GF Gt 710,

User avatar
moss
KVRian
1407 posts since 13 May, 2004

Re: Arturia Beatstep and Beatstep Pro support is here

Post Wed Mar 30, 2016 10:37 pm

turbo_kev wrote:Hi Moss

After watching the video I understand that we can now use the shift key to change the modes

When I first turn on the beat step and press the shift key

pad ( 1 2 RED ) ( 3 4 5 PINK ) ( 6 BLUE ) ( 7 out ) ( 8 RED ) top row

Pad ( 9 BLUE ) ( 10 RED ) ( 11 PINK ) ( 12 13 14 15 out ) ( 16 PINK ) bottom row

But no matter what pads I press it just stays in mode 1
the big knob moves the play head. knob 16 crossfade knob 8 volume knob 7 play head
knob 6 tempo knob 4 solo knob 3 mute knob 2 pan knob 1 volume knob 9 send

there are NO errors in the script console

Nothing else seems to work ?
What am I doing wrong ?
thanks for your hard work

Cheers
Kevin
Hmm, weird. What OS are you on? Are you running the latest Beatstep Firmware?

turbo_kev
KVRian
510 posts since 18 Dec, 2014

Re: Arturia Beatstep and Beatstep Pro support is here

Post Thu Mar 31, 2016 10:55 am

Hi moss

Yes I am on firmware 1.2.0.3

and I am running windows 10 pro 64 bit
and Bitwig studio 1.3.9 RC 3

I did notice in your video that Pad 11 was out on startup but mine is pink??
cheers
kev
BWS 2.4.3, Spark LE, V Collection 6.2, BS 1 & BS PRO, Keystep, keylab 25, Axiom pro 49,Focusrite Scarlett 8i6,Launchpad Pro,ProFx8 v2,Icon m+ & D2,KRK 10/3,win 10 pro,i7 5820k 4ghz ,16G ddr 4 ,1TB NVMe.M2, msi x99a sli + , Nvidia GF Gt 710,

turbo_kev
KVRian
510 posts since 18 Dec, 2014

Re: Arturia Beatstep and Beatstep Pro support is here

Post Sat Apr 02, 2016 1:31 pm

HI moss
I was Just Playing around with the BS and just happen by chane to press Recall and pad 7
then the script started to work WAAAHOOOO


I have a question?

Can you just select different clips and make them paly like you can the whole scene

Many thanks
Cheers
Kev
BWS 2.4.3, Spark LE, V Collection 6.2, BS 1 & BS PRO, Keystep, keylab 25, Axiom pro 49,Focusrite Scarlett 8i6,Launchpad Pro,ProFx8 v2,Icon m+ & D2,KRK 10/3,win 10 pro,i7 5820k 4ghz ,16G ddr 4 ,1TB NVMe.M2, msi x99a sli + , Nvidia GF Gt 710,

User avatar
moss
KVRian
1407 posts since 13 May, 2004

Re: Arturia Beatstep and Beatstep Pro support is here

Post Sun Apr 03, 2016 11:10 pm

turbo_kev wrote: then the script started to work WAAAHOOOO
Great you got it working!
turbo_kev wrote: Can you just select different clips and make them paly like you can the whole scene
Sorry no, only scenes.

User avatar
moss
KVRian
1407 posts since 13 May, 2004

Re: Arturia Beatstep and Beatstep Pro support is here

Post Mon Aug 22, 2016 12:23 am

Time for a little new release:

#2.03
  • Fixed: Track bank was not adjusted when track selection was changed in Bitwig.
Get it from http://mossgrabers.de/Software/Bitwig/Bitwig.html

Enjoy!

stimresp
KVRian
1008 posts since 1 Jul, 2008

Re: Arturia Beatstep and Beatstep Pro support is here

Post Wed Sep 07, 2016 3:35 am

Hi Jürgen,

I recently got both Bitwig and a Beatstep, for different purposes.

Happy was I to discover your script, and I am even happier to report that it seems to work very well with the latest firmware. Still finding my way around - helped by your vids - but impressed with the depth of control options so far, and so far having fun making music again.

Thank you very much!
8)

NukeArts
KVRist
92 posts since 3 Dec, 2015

Re: Arturia Beatstep and Beatstep Pro support is here

Post Mon Nov 28, 2016 11:58 am

hello moss,

maybe you can help me get the script with the beatstep running.
using shift and the pads selects the functions accordingly.
i can also use the pads. but all knobs inclusive the big one are only generating these entries in the console:
unused Midi CC: 7 (for each knob a different cc).

Is there any presetup to be done on the beatstep itself? like loading a sysex with a mapping?

Beatstep firmware 1.2.0.3
Bitwig 1.3.14
Windows 10

cheers,
nuke

User avatar
moss
KVRian
1407 posts since 13 May, 2004

Re: Arturia Beatstep and Beatstep Pro support is here

Post Tue Nov 29, 2016 11:42 pm

NukeArts wrote: Is there any presetup to be done on the beatstep itself? like loading a sysex with a mapping?
See: https://github.com/git-moss/Beatstep4Bi ... stallation

NukeArts
KVRist
92 posts since 3 Dec, 2015

Re: Arturia Beatstep and Beatstep Pro support is here

Post Wed Nov 30, 2016 10:23 am

moss wrote:
NukeArts wrote: Is there any presetup to be done on the beatstep itself? like loading a sysex with a mapping?
See: https://github.com/git-moss/Beatstep4Bi ... stallation
Thank you moss! It works now.

E.D.L.
KVRer
7 posts since 11 Sep, 2014

Re: Arturia Beatstep and Beatstep Pro support is here

Post Fri Dec 23, 2016 10:41 am

Hi moss ... thanks your for your fantastic job!.

Tried it out today first time but I have a strange behaviour with the step-sequencer ... the follow-led thing leaves traces ... any idea?

https://www.youtube.com/watch?v=CpYxb1Fwrlo

I'm using the latest Beatstep firmware (tried version 1.1 too but no change). Latest Bitwig version (on OS X) and of course latest Version of your script (2.03).

Step sequencer feature request: I would like to hear the step I add on adding. Something like a (switchable) play feature in the sequence mode. In this way it could be easer to add the sounds in the right velocity.

User avatar
moss
KVRian
1407 posts since 13 May, 2004

Re: Arturia Beatstep and Beatstep Pro support is here

Post Sun Dec 25, 2016 2:48 pm

E.D.L. wrote:Hi moss ... thanks your for your fantastic job!.

Tried it out today first time but I have a strange behaviour with the step-sequencer ... the follow-led thing leaves traces ... any idea?

https://www.youtube.com/watch?v=CpYxb1Fwrlo

I'm using the latest Beatstep firmware (tried version 1.1 too but no change). Latest Bitwig version (on OS X) and of course latest Version of your script (2.03).

Step sequencer feature request: I would like to hear the step I add on adding. Something like a (switchable) play feature in the sequence mode. In this way it could be easer to add the sounds in the right velocity.
You must not use the play/stop button. See the Wiki in the section "Features": https://github.com/git-moss/Beatstep4Bitwig/wiki

E.D.L.
KVRer
7 posts since 11 Sep, 2014

Re: Arturia Beatstep and Beatstep Pro support is here

Post Mon Dec 26, 2016 9:49 am

Haven't used them, moss. Has nothing todo with the internal beatstep sequencer. It happens without any touch to the start/stop-buttons. Fresh start of Bitwig, Beatstep and your script ...

I tried it on another machine - the same. I unplugged other controllers (Launchpad and Roland A-49) and tried to run beatstep and your script only - no change. I tried different step sequencer resolutions and bpm ... it happens always and the traces seems to come completely randomly.

My launchpad script has also a step sequencer included ... this kind ofrunning led works flawless on the launchpad, but it's of course a completely different script code.

Return to “Controller Scripting”