DrivenByMoss - Bitwig extension for lots of controller devices (and more)

User avatar
moss
KVRAF
1960 posts since 13 May, 2004

Post Mon Jan 20, 2020 1:13 pm

peemge wrote:
Sun Jan 19, 2020 9:05 am
Here are some problems I went through:
Sorry, absolutely no idea.
peemge wrote:
Sun Jan 19, 2020 9:05 am
One last thing, maybe more on the BW side: I can't find the option that you are talking about in your 2nd YT video at 5:49 about scale layout. It doesn't appear in the controller settings page. Is this
The scale settings have been moved to the document, so you can safe it with each song (and not globally).

User avatar
hexfarmer
KVRer
17 posts since 9 Jan, 2020

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Mon Jan 20, 2020 1:32 pm

peemge wrote:
Sun Jan 19, 2020 9:05 am
Hi Jürgen,

I just discovered your extension for BW, but i ran into some problems with my Beatstep controller.
  • I'm running Bitwig 3.03 (my update plan has just finished) on Win10-64b;
  • I downloaded v7.60 of the script from your homepage;
  • the provided template has been loaded through Arturia's MCC;
  • MIDI channel 1 is selected.

Thanks
Arnaud
Hi Arnaud,
I am in the same situation as you are. I have bitwig 3.02 with Moss's extension 7.60 and trying to get it to work with arturias beatstep.
However I am not even able to change modes.
Do you have any idea what I am doing wrong?
I have done the same steps as you have detailed above.
If you need more detail maybe you can check my other posts; I have recently joined KVR and all my 5 posts are regarding this issue.

Thanx

Alma Mare
KVRer
9 posts since 10 Apr, 2018

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Mon Jan 20, 2020 7:02 pm

Howdy, sorry to bother again. Still have a couple of doubts on the Launchpad X functionality:

1 - In the volume view, I can't use the second row pads (the ones who'd put the volume at 0db; instead it also adds the first row and sets the volume at +3.2 dB. What could be causing this?

2 - Is there a workaround to make the Launchpad behave like it transmits notes on the omnichannel? My current setup has several HW devices each assigned to their own channel and controlled by a keytboard. It'd be easy to slide the launchpad right along, but having it stuck on channel 1 stops that... any ideas?

Thanks again!

esq1
KVRist
50 posts since 28 Mar, 2014

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Mon Jan 20, 2020 9:39 pm

Hello everybody,

i use the Moss Script 7.6 under Bitwig 3.0.3 and work through piece by piece according to the instructions from Jürgens github side. But i have a few questions for you PUSH 1 users:
  • There is a possibility to call the function "show clip luncher" as if i was using the "L" key on my PC Keyboard?
  • if i use a LFO in "POLY GRID" i can move the Encoders, the value was changed in the LFO Modul but the values it is not shown in the PUSH display. Is this a bug in Bitwigs "POLY Grid"?
  • Can i add a effect at the end of the Device chain? E.g First Device is a Polysynth next is a Delay. After the Delay i I would like to insert a other effect.

Thanks a lot for help !! :)

User avatar
stamp
KVRian
750 posts since 10 Sep, 2014

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Tue Jan 21, 2020 7:53 am

Hi moss,

I have another feature request (yes, I know I'm annoying...) to speed up device editing.
This could come in handy when you are editing plugins with more then 8 macro pages.
As it is now the left/right arrows move 1 device page to the left/right at a time and when you are at last page on the left/right it will switch to the next group of 8 pages.
I find the behaviour counterintuitive since I can simply select the page I need by pressing the track state buttons (2nd row of buttons under screen).
So my request is to move 8 pages at a time instead of 1. This would speed things up a notch.

Hope you consider this request.

Cheers!

User avatar
stamp
KVRian
750 posts since 10 Sep, 2014

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Tue Jan 21, 2020 7:56 am

esq1 wrote:
Mon Jan 20, 2020 9:39 pm
Can i add a effect at the end of the Device chain? E.g First Device is a Polysynth next is a Delay. After the Delay i I would like to insert a other effect.
Select the device after which you want to insert the new device and press 'add effect'. Select the device you want and press 'browse' to insert it.

Reckon104
KVRist
119 posts since 16 Jul, 2018

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Tue Jan 21, 2020 9:05 am

Alma Mare wrote:
Mon Jan 20, 2020 7:02 pm
Howdy, sorry to bother again. Still have a couple of doubts on the Launchpad X functionality:

1 - In the volume view, I can't use the second row pads (the ones who'd put the volume at 0db; instead it also adds the first row and sets the volume at +3.2 dB. What could be causing this?
I am experiencing same issue, also with "pan" view

esq1
KVRist
50 posts since 28 Mar, 2014

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Tue Jan 21, 2020 10:35 am

stamp wrote:
Tue Jan 21, 2020 7:56 am
esq1 wrote:
Mon Jan 20, 2020 9:39 pm
Can i add a effect at the end of the Device chain? E.g First Device is a Polysynth next is a Delay. After the Delay i I would like to insert a other effect.
Select the device after which you want to insert the new device and press 'add effect'. Select the device you want and press 'browse' to insert it.
thanks a lot for your help. I'm definitely doing something wrong but for me he always adds the effect after the first. E.g i use my polysynth -> add effect (a delay) i have this chain. POLYSYNTH -> DELAY. I choose the DELAY on push -> add effect (e.g REVERB) i do become the chain:

POLYSYNTH -> REVERB -> DELAY not the reverb as the last one.

Echoes in the Attic
KVRAF
7871 posts since 12 May, 2008

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Tue Jan 21, 2020 11:07 am

stamp wrote:
Tue Jan 21, 2020 7:53 am
Hi moss,

I have another feature request (yes, I know I'm annoying...) to speed up device editing.
This could come in handy when you are editing plugins with more then 8 macro pages.
As it is now the left/right arrows move 1 device page to the left/right at a time and when you are at last page on the left/right it will switch to the next group of 8 pages.
I find the behaviour counterintuitive since I can simply select the page I need by pressing the track state buttons (2nd row of buttons under screen).
So my request is to move 8 pages at a time instead of 1. This would speed things up a notch.

Hope you consider this request.

Cheers!
I agree. That would be best!
System: Windows 10, Dell XPS 2-in-1, Bitwig 3, Steinberg UR44.

User avatar
moss
KVRAF
1960 posts since 13 May, 2004

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Tue Jan 21, 2020 11:14 am

Reckon104 wrote:
Tue Jan 21, 2020 9:05 am
Alma Mare wrote:
Mon Jan 20, 2020 7:02 pm
Howdy, sorry to bother again. Still have a couple of doubts on the Launchpad X functionality:

1 - In the volume view, I can't use the second row pads (the ones who'd put the volume at 0db; instead it also adds the first row and sets the volume at +3.2 dB. What could be causing this?
I am experiencing same issue, also with "pan" view
I cannot reproduce that. Can you give some steps how to get to this problem? Did you select a specific mode before?
Did you do any custom mappings? Are you running the latest Firmware?

User avatar
moss
KVRAF
1960 posts since 13 May, 2004

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Tue Jan 21, 2020 11:17 am

Alma Mare wrote:
Mon Jan 20, 2020 7:02 pm
2 - Is there a workaround to make the Launchpad behave like it transmits notes on the omnichannel? My current setup has several HW devices each assigned to their own channel and controlled by a keytboard. It'd be easy to slide the launchpad right along, but having it stuck on channel 1 stops that... any ideas?
You can simply remap the MIDI channel in the track settings (left hand window) in Bitwig.

User avatar
moss
KVRAF
1960 posts since 13 May, 2004

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Tue Jan 21, 2020 11:20 am

esq1 wrote:
Mon Jan 20, 2020 9:39 pm
  • There is a possibility to call the function "show clip luncher" as if i was using the "L" key on my PC Keyboard?
Keep the Master button pressed, on the screen you see now different panes you can show/hide. Select the "clip launcher" to toggle.
esq1 wrote:
Mon Jan 20, 2020 9:39 pm
  • if i use a LFO in "POLY GRID" i can move the Encoders, the value was changed in the LFO Modul but the values it is not shown in the PUSH display. Is this a bug in Bitwigs "POLY Grid"?
Did you map the LFO control you want to change to a remote control page?

User avatar
moss
KVRAF
1960 posts since 13 May, 2004

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Tue Jan 21, 2020 11:48 am

esq1 wrote:
Tue Jan 21, 2020 10:35 am
stamp wrote:
Tue Jan 21, 2020 7:56 am
esq1 wrote:
Mon Jan 20, 2020 9:39 pm
Can i add a effect at the end of the Device chain? E.g First Device is a Polysynth next is a Delay. After the Delay i I would like to insert a other effect.
Select the device after which you want to insert the new device and press 'add effect'. Select the device you want and press 'browse' to insert it.
thanks a lot for your help. I'm definitely doing something wrong but for me he always adds the effect after the first. E.g i use my polysynth -> add effect (a delay) i have this chain. POLYSYNTH -> DELAY. I choose the DELAY on push -> add effect (e.g REVERB) i do become the chain:

POLYSYNTH -> REVERB -> DELAY not the reverb as the last one.
You don't do anything wrong. It was a bug which I already fixed yesterday. Will be in the next update.

peemge
KVRer
7 posts since 10 Mar, 2014

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Tue Jan 21, 2020 12:20 pm

moss wrote:
Mon Jan 20, 2020 1:13 pm
The scale settings have been moved to the document, so you can safe it with each song (and not globally).
Thanks Jürgen for this!

I tested again the Beatstep script with BW 2.5 and sadly I got same problems as I described earlier... No idea what I miss.

hexfarmer wrote:
Mon Jan 20, 2020 1:32 pm
If you need more detail maybe you can check my other posts; I have recently joined KVR and all my 5 posts are regarding this issue.
Hi hexfarmer,
I read your posts but I couldn't explain why it's not working at all for you, sorry.
Did you read and followed Moss' wiki on GitHub? Both Installation and Beatstep pages?
I only copied the extension file in BW extension folder and load the Beatstep template with Arturia MMC software. I have no other extension or controller scripts installed. Main MIDI channel is 1 ( AFAIK CV/Gate and sequencer MIDI channels are not used in the extension). My firmware is 1.2.0.3.

Let me know if you have any luck with your install.

User avatar
hexfarmer
KVRer
17 posts since 9 Jan, 2020

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Tue Jan 21, 2020 2:31 pm

peemge wrote:
Tue Jan 21, 2020 12:20 pm


Hi hexfarmer,
I read your posts but I couldn't explain why it's not working at all for you, sorry.
Did you read and followed Moss' wiki on GitHub? Both Installation and Beatstep pages?
I only copied the extension file in BW extension folder and load the Beatstep template with Arturia MMC software. I have no other extension or controller scripts installed. Main MIDI channel is 1 ( AFAIK CV/Gate and sequencer MIDI channels are not used in the extension). My firmware is 1.2.0.3.

Let me know if you have any luck with your install.
Yes I certainly followed all the steps, he also tried to help me here on the forum but I just cant figure it out.

What I find really strange is that it 'half works'... the big knob moves the cursor, some of the knobs work and pads work when global channel is set to 1 with MCC, but I simply cannot change modes. It is the play mode I would like with the ability to change octaves and the ability to chose scales sounds amazing but alas, I cant get it to work.

I wonder if perhaps my beatstep is broken.... I thought maybe my shift button was no good but it does light up in MCC when I press it.

I have a question about the controller settings is BW, does it matter what the pads are set to?
the section where it says "convert poly aftertouch to..." I have it set to poly aftertouch, does it matter what this is set to?

Or perhaps my beatstep has some weird configuration setting on it..
I bought it used from someone else, is there any chance there is some weird setting on it and I need to return it to factory reset before I load Moss' template?

Is there some sort of test I can perform on the beatstep to make sure it is functioning well or that it is the right state to work with Moss' template?

Thanx again for trying to help this is driving me nuts, I feel so close to getting it to work properly
You do not have the required permissions to view the files attached to this post.

Return to “Controller Scripting”