DrivenByMoss - Bitwig extension for lots of controller devices (and more)

User avatar
aMUSEd
KVRAF
29655 posts since 14 Sep, 2002 from In teh net

Post Sun Apr 08, 2018 9:47 am

No problem - this is still a huge leap forwards, thanks again

User avatar
aMUSEd
KVRAF
29655 posts since 14 Sep, 2002 from In teh net

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Sun Apr 08, 2018 9:49 am

btw I cross posted this on the Komplete Kontrol NI forum - feel free to join the discussion

https://www.native-instruments.com/foru ... k2.327013/

User avatar
Vathek
KVRist
42 posts since 5 Feb, 2015

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Mon Apr 09, 2018 12:30 am

Somehow the newest version of the extension doesn't work here with the Push2's display. I get a dark display and the following error:
Screen Shot 2018-04-09 at 10.18.19.png
Also my Novation SL61 mkii is not recognised anymore? But that looks like a different issue as rolling back the extension doesn't remedy this, whereas the Push2 display works just fine when I do so. I can add it as a generic keyboard, but not as a SL mkii, neither automatically nor manually. Could be related to macOS 10.13.4?
You do not have the required permissions to view the files attached to this post.

User avatar
moss
KVRian
1380 posts since 13 May, 2004

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Mon Apr 09, 2018 1:32 am

Vathek wrote:Somehow the newest version of the extension doesn't work here with the Push2's display. I get a dark display and the following error:
Seems I broke something. Can you please test: http://mossgrabers.de/stuff/push2display.zip

User avatar
Vathek
KVRist
42 posts since 5 Feb, 2015

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Mon Apr 09, 2018 1:56 am

This works. Thank you!

The SL61 mkii is less important for me as long as just the keys work, but do you have any idea why that's not recognised anymore?

User avatar
aMUSEd
KVRAF
29655 posts since 14 Sep, 2002 from In teh net

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Mon Apr 09, 2018 2:32 am

moss wrote:
aMUSEd wrote:OK thanks - all very cool. So the not recording into clips is by design? Still not clear why record arms overwrite mode instead of activates record? This is not how it works in Live.
I hear you :-) Will look into this but takes some time since I am busy the next week.
Actually the more I use this I'm wondering if it makes more sense to keep the way it works in clips using the jogwheel to move between them and clip record, which is very smooth and fast, but have the record button activate record in arranger view (ie global record) and without needing shift (and not activating overwrite either - or maybe that could be the shift function?) with this (would be faster not to have to press 2 buttons and really that was how I had expected it would work from the start)

User avatar
moss
KVRian
1380 posts since 13 May, 2004

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Mon Apr 09, 2018 9:16 am

I updated the download with the fixed push2display. If you are a Push 2 user please download again.

Zola40
KVRer
1 posts since 8 Jul, 2006

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Thu Apr 12, 2018 1:32 pm

Oh man, I'm so excited about this - Thank you! Will you please help me troubleshoot why this is partially functional for me? Currently all functions seem to work except plug in lose focus when I navigate away from them like they should, but will not return when I navigate back. I've tried removing all other devices that use your scripts or are Maschine devices to rule out conflict. I've updated KK firmware, drivers, OS (Win 10), Komplete (2.0) and Bitwig (2.3). I've tried running Bitwig as an Administrator. Removing, reinstalling your scripts and Extension. Disabled my Mackie controller that also uses your script.

Of note - when I re-assign or reset the controller in Bitwig, it does recognize the first KK Plug in and allows me to adjust the parameters. In fact when adding a new instrument it works as it should - but when I change tracks or navigate away, I cannot return to the Plug - In screen in KK. In fact, the plug in and browse buttons are disabled. Further, when I select instance there are no other instances recognized... Please help and thanks again for this!~

Echoes in the Attic
KVRAF
6153 posts since 12 May, 2008

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Thu Apr 19, 2018 6:48 am

I came across this video below of a launchpad script with a very useful note layout that mimics a keyboard layout. While this is less useful for playing an instrument, it can be really useful for certain instruments that are laid out across the keyboard where some sounds are grouped in certain ways that depend on the white and black key layouts. Examples might be drum layout like Addictive drums where something like high hats might be grouped in a set of black keys. Or other GM type percussion layouts that are easier with this view than the isomorphic view. I was wondering if the Push script has a mode like this? It would be very useful! Especially if there was also a sequencer view like in the video where the top half was for sequencing.
See 13:05 here:
https://youtu.be/48qBVXyzot0?t=13m5s

Note at 23:30 where it shows the sequencer version of the key layout (in addition to the other grid layouts for sequencing).
This is a block of text that can be added to posts you make. There is a 255 character limit. Once I have something clever, I will certainly fill it in.

dckyoto
KVRist
115 posts since 19 May, 2014

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Thu Apr 19, 2018 6:44 pm

I can't seem to get my Novation 49 SLmkii to work.

The displays seem to be displaying something related to bitwig but none of the knobs work and I can't get any midi playing through. Various knobs appear assigned (within Bitwig they are marked and on the display on the mkii)

It must just be some daft configuration problem - I seem to only be able to select MIDI IN2 (2-SL mkii) or a port called "2-SL mkii" (and of course MIDI OUT2.

Any idea what I might be doing wrong?

dckyoto
KVRist
115 posts since 19 May, 2014

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Thu Apr 19, 2018 6:48 pm

solved... sorry, was hitting a brick wall but by swapping MIDI IN2 to the first drop down, and 2-SL MKii to the second drop down menu it works at last!

dckyoto
KVRist
115 posts since 19 May, 2014

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Thu Apr 19, 2018 10:45 pm

hmm.. can't get the drum pads to send any midi notes though.

User avatar
moss
KVRian
1380 posts since 13 May, 2004

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Thu Apr 19, 2018 11:41 pm

dckyoto wrote:hmm.. can't get the drum pads to send any midi notes though.
They currently don't do anything, since they are pretty unusable. On one hand you have to hit it with a hammer to send out a signal but on the other hand they sometimes send a wrong trigger without doing anything.

User avatar
moss
KVRian
1380 posts since 13 May, 2004

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Thu Apr 19, 2018 11:43 pm

Echoes in the Attic wrote:I came across this video below of a launchpad script with a very useful note layout that mimics a keyboard layout.
This "Piano layout" is available on Push and the next upcoming release of DrivenByMoss will also add it to the Launchpad.

dckyoto
KVRist
115 posts since 19 May, 2014

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Fri Apr 20, 2018 1:52 am

moss wrote:
dckyoto wrote:hmm.. can't get the drum pads to send any midi notes though.
They currently don't do anything, since they are pretty unusable. On one hand you have to hit it with a hammer to send out a signal but on the other hand they sometimes send a wrong trigger without doing anything.
Oh right is this is a common problem with this keyboard?

Return to “Controller Scripting”