DrivenByMoss - Bitwig extension for lots of controller devices (and more)

KVRer
4 posts since 18 Jun, 2006

Post Thu May 13, 2021 9:51 am

Hi Moss,

Thanks for all this great stuff! I was very excited to see the updated Maschine Jam Bitwig support - it maybe my favourite bit of kit (even more so when I saw all the eye popping features you added). The new Maschine support is also really cool btw - it was starting to gather dust before this update :)

Unfortunately, I'm unable to get the Maschine Jam to work correctly. I initially suspected it might be my setup, but this latest version is working slightly better: the previous version, I couldn't even get it to switch between Maschine and Bitwig. But buttons still do the wrong things, or don't respond, and other mystifying stuff happens :)

Would a list of the reproduceable issues be useful? I can make videos demonstrating them, if that would help. I'd jump into the code and try and fix things, but I'm a bit of a ways away from that at this point :) (Still not ruling out my production environment as the cause of the problems, although it is pretty standard. I do have a lot of midi devices attached though.)

In any case, thanks for all you work.

User avatar
KVRAF

Topic Starter

2806 posts since 13 May, 2004

Post Thu May 13, 2021 11:56 am

walter_sear wrote:
Thu May 13, 2021 9:51 am
Hi Moss,

Thanks for all this great stuff! I was very excited to see the updated Maschine Jam Bitwig support - it maybe my favourite bit of kit (even more so when I saw all the eye popping features you added). The new Maschine support is also really cool btw - it was starting to gather dust before this update :)

Unfortunately, I'm unable to get the Maschine Jam to work correctly. I initially suspected it might be my setup, but this latest version is working slightly better: the previous version, I couldn't even get it to switch between Maschine and Bitwig. But buttons still do the wrong things, or don't respond, and other mystifying stuff happens :)

Would a list of the reproduceable issues be useful? I can make videos demonstrating them, if that would help. I'd jump into the code and try and fix things, but I'm a bit of a ways away from that at this point :) (Still not ruling out my production environment as the cause of the problems, although it is pretty standard. I do have a lot of midi devices attached though.)

In any case, thanks for all you work.
Did you install and select the template?

KVRer
11 posts since 27 Dec, 2019

Post Thu May 13, 2021 1:20 pm

moss wrote:
Wed May 12, 2021 10:30 pm

Yes, great to hear. You also needed to make the template work.
Next update will contain full support, hopefully already later today!
I just checked your ncmp with Bitwig, added Maschine+ as the controller this time vs MK3, and it works! :clap: :party:

KVRer
4 posts since 18 Jun, 2006

Post Thu May 13, 2021 7:26 pm

moss wrote:
Thu May 13, 2021 11:56 am
Did you install and select the template?
Doh! I did - but only for the mk3 sitting next to it.

Many thanks.

KVRer
21 posts since 9 Oct, 2020

Post Mon May 17, 2021 3:12 pm

The drum sequencer on my launchpad pro mk3 has 4 colored pads at the bottom of the sequencer page section, and it's preventing me from creating 32 bar sequences. I don't see any mention of these pads in the docs. Am I missing something?
launchpaddrumseq.jpg
Thanks!
You do not have the required permissions to view the files attached to this post.

User avatar
KVRAF

Topic Starter

2806 posts since 13 May, 2004

Post Mon May 17, 2021 11:20 pm

sequethin wrote:
Mon May 17, 2021 3:12 pm
The drum sequencer on my launchpad pro mk3 has 4 colored pads at the bottom of the sequencer page section, and it's preventing me from creating 32 bar sequences. I don't see any mention of these pads in the docs. Am I missing something?
It is in section 21.10.5 but not in the image.

Also see here: https://www.youtube.com/watch?v=xKGC-8T ... L&index=15

KVRer
21 posts since 9 Oct, 2020

Post Tue May 18, 2021 1:59 pm

Ahhhhh thank you!

Update: OMG THIS IS AMAZING!

KVRist
177 posts since 22 Oct, 2014

Post Wed May 19, 2021 3:18 am

Hi Jürgen,
first of all 1001thx for your great work in general! Espacilly your open stage control is absolut brilliant! I dont need any other controller anymore :-)))) But i would love to add some personal stuff.

1.
i have the current OSC 1.97 - it seems there is no TAB anymore? Your osc4bws does still support this, but if i try to add a new tab (or try to copy/paste a complete tab), i did not find any way. Ist tab no more supported, or am i blind?
2.
Do you have a textfile which osc-line is doing what in BWS?
Espacially if i just want to add some fader, button ect. for my special stuff like normal midi-learn stuff... what do i have to "script"????

User avatar
KVRAF

Topic Starter

2806 posts since 13 May, 2004

Post Wed May 19, 2021 5:09 am

kukident-youth wrote:
Wed May 19, 2021 3:18 am
1.
i have the current OSC 1.97 - it seems there is no TAB anymore? Your osc4bws does still support this, but if i try to add a new tab (or try to copy/paste a complete tab), i did not find any way. Ist tab no more supported, or am i blind?
If you enable editing you should see the "Project tree" on the left. Right click on the "root" node and select "Add tab".
kukident-youth wrote:
Wed May 19, 2021 3:18 am
2.
Do you have a textfile which osc-line is doing what in BWS?
Espacially if i just want to add some fader, button ect. for my special stuff like normal midi-learn stuff... what do i have to "script"????
All OSC commands are documented in the DrivenByMoss manual (included in the download). For MIDI learn you can use the user parameter commands.

KVRAF
1781 posts since 5 Oct, 2003

Post Wed May 19, 2021 5:21 am

I was reading through the docs and still have a few questions. Sorry ahead of time if I overlooked the answers.

Is it possible to stop and start Bitwig's transport using the Launchpad X and/or flexi script?

Also, can I assign a CC# to a pad and use aftertouch to modulate the CC value from 0 to 127 through the Launchpad X and/or flexi scripts?

Is it possible to use the custom page assignments for the Launchpad X using either script?

Many thanks and huge thanks for the scrips to begin with !!

KVRist
177 posts since 22 Oct, 2014

Post Thu May 20, 2021 1:54 am

Thanks Jürgen, the TAB i found :-)
But the ask about osc commands is still unclear.
YOU used eg. for "adress" this line
/user/@{parent.variables.n}/value
but this line (parents, n….) seems for clones and not for UNIQUE midi-learn-like knobs/Faders, etc…

if i eg for this

/user/{1-8}/name
try&error make
/user/{1}/knob

it will not work!!!

I dont understand the syntax itself. I guess i need 2,3 examples to get that point (feeling for the syntax).
SO please could you help???? thankyou!

User avatar
KVRAF

Topic Starter

2806 posts since 13 May, 2004

Post Thu May 20, 2021 2:09 am

kukident-youth wrote:
Thu May 20, 2021 1:54 am
Thanks Jürgen, the TAB i found :-)
But the ask about osc commands is still unclear.
YOU used eg. for "adress" this line
/user/@{parent.variables.n}/value
but this line (parents, n….) seems for clones and not for UNIQUE midi-learn-like knobs/Faders, etc…

if i eg for this

/user/{1-8}/name
try&error make
/user/{1}/knob

it will not work!!!

I dont understand the syntax itself. I guess i need 2,3 examples to get that point (feeling for the syntax).
SO please could you help???? thankyou!
The included example template contains a USER PARAMETER page. Enable MIDI learn on one of the parameters in Bitwig, then move one of the sliders. If you got this going check out the used commands in this part of the template.

User avatar
KVRAF

Topic Starter

2806 posts since 13 May, 2004

Post Thu May 20, 2021 2:11 am

killmaster wrote:
Wed May 19, 2021 5:21 am
I was reading through the docs and still have a few questions. Sorry ahead of time if I overlooked the answers.
Is it possible to stop and start Bitwig's transport using the Launchpad X and/or flexi script?
Are you sure that you read the manual? Transport is the most basic feature which is available in every supported device.
killmaster wrote:
Wed May 19, 2021 5:21 am
Also, can I assign a CC# to a pad and use aftertouch to modulate the CC value from 0 to 127 through the Launchpad X and/or flexi scripts?
Haven't tested but it should work with Flexi.
killmaster wrote:
Wed May 19, 2021 5:21 am
Is it possible to use the custom page assignments for the Launchpad X using either script?
With Flexi.

KVRAF
1781 posts since 5 Oct, 2003

Post Thu May 20, 2021 4:23 am

moss wrote:
Thu May 20, 2021 2:11 am
killmaster wrote:
Wed May 19, 2021 5:21 am
I was reading through the docs and still have a few questions. Sorry ahead of time if I overlooked the answers.
Is it possible to stop and start Bitwig's transport using the Launchpad X and/or flexi script?
Are you sure that you read the manual? Transport is the most basic feature which is available in every supported device.
killmaster wrote:
Wed May 19, 2021 5:21 am
Also, can I assign a CC# to a pad and use aftertouch to modulate the CC value from 0 to 127 through the Launchpad X and/or flexi scripts?
Haven't tested but it should work with Flexi.
killmaster wrote:
Wed May 19, 2021 5:21 am
Is it possible to use the custom page assignments for the Launchpad X using either script?
With Flexi.
Thanks for the response. Will take closer look for sure.

KVRist
177 posts since 22 Oct, 2014

Post Thu May 20, 2021 6:26 am

moss wrote:
Thu May 20, 2021 2:09 am
The included example template contains a USER PARAMETER page. Enable MIDI learn on one of the parameters in Bitwig, then move one of the sliders. If you got this going check out the used commands in this part of the template.
This is exactly what i did/tried and where i took the (....parent/n) line. i tried to "copy+1" the osc-lines from first user-fader to an extra fader/knob... of my own, but if i duplicate or just copy your (clone-master) osc-lines to my extra knob... this will be the "same" fader where booth influences each other.

So i tried instead your osc-adress
/user/@{parent.variables.n}/value
this osc-adress
/user/fader_9/value
(fader_9 = the widget id), but this dont work. (i also tried with @ and some brackets....) but allways donst work :-(

Return to “Controller Scripting”