DrivenByMoss - Bitwig extension for lots of controller devices (and more)

KVRist
213 posts since 10 Oct, 2003 from London

Post Tue Sep 28, 2021 6:35 am

Hi Moss, sorry to ask again but ...

On Push 2 with Bitwig, Is there any way to make the 'pads' or the mix view follow 'track selection'?

My problem is that if I 'directly select' a track by mouse or MIDI, the pads only update if I'm in the right 'mixer page'...

Video to illustrate - I select a few tracks via MIDI - all works fine till I select one that's not in view: https://photos.app.goo.gl/dxich8cTQLUpJaD97

Thanks!

KVRian
1427 posts since 19 Aug, 2009

Post Wed Sep 29, 2021 3:25 am

moss wrote:
Tue Sep 28, 2021 1:22 am
DrivenByMoss 14.0 is online!

Get it from http://mossgrabers.de
  • Support for Akai MPC Live
  • Support for Akai MPC Live II
  • Support for Akai MPC One
  • Support for Akai MPC X
  • Support for Akai Force
https://youtu.be/_wtQLUAxMxg

Enjoy!
That is so cool :tu:

I can't test it for the time being, but it does seem great :hyper:

KVRist
318 posts since 27 Nov, 2016

Post Wed Sep 29, 2021 1:34 pm

moss wrote:
Thu Sep 23, 2021 3:58 am
Buckster wrote:
Thu Sep 23, 2021 3:13 am
First off I would like to say a HUGE thankyou to Moss for such a fantastic addition for Bitwig

Has anyone else on here have any issues though using a Launchpad Pro MK3 and the DrivenbyMoss script and Bitwig ?

Works perfectly, except sometimes (and haven't narrowed it down completely yet) Bitwig/script won't communicate with the Launchpad unless I unplug it and plug it back in

Symptom is the Launchpad is illuminated - yet when press any button you just get the initialised light blue and pink screen (not sure what symbol its meant to be) - if I check Bitwig controller settings the Launchpad is detected yet won't respond

unplug it and plug it back in and all perfect - just a bit of a faff and not great with regards to the life of the connectors

any ideas please ? I've not narrowed down if its after a period of time, each time I start bitwig or after a reboot but I will endeavor to find out

hoping its not the Launchpad Pro thats faulty

all my other usb controllers (MOXF) and Arturia Keystep seem to respond correctly

I will try without script to see if makes any difference

many many thanks
Haven't heard so far of such an issue, so could be a hardware issue but maybe not the device itself, could be a faulty cable, problematic hub, the usual USB fun...

Thanks very much for reply I'll try different usb ports and or if that doesn't work a powered usb hub

Sorry for delay in answering been feeling under weather - confirmed today as Covid :(

KVRist
195 posts since 22 Jun, 2019

Post Thu Sep 30, 2021 4:06 am

Hi Moss!
I'm using your extension both with launchpad pro and pro mk3 a lot.
I really like to play that controller with the chromatic "guitar alike" layout but I found it's pretty hard to record clips in the clip launcher that way. Would there be a mean to stop the current clip recording (and start it to loop) without having to go to the script's session mode hitting the good matrix clip wich I always end up missing...
Thank you for awesome work anyway!

KVRer
5 posts since 24 Aug, 2021

Post Thu Sep 30, 2021 5:14 am

moss wrote:
Tue Sep 28, 2021 1:22 am
DrivenByMoss 14.0 is online!

Get it from http://mossgrabers.de
  • Support for Akai MPC Live
  • Support for Akai MPC Live II
  • Support for Akai MPC One
  • Support for Akai MPC X
  • Support for Akai Force
https://youtu.be/_wtQLUAxMxg

Enjoy!
Hey, Moss! Very thank you for updates! Can you explain plz if I could use your Beastep cript with BSP? If so how can I do it? Sorry for noobsih queastions!

User avatar
KVRAF

Topic Starter

2979 posts since 13 May, 2004

Post Fri Oct 01, 2021 3:04 am

ElVincente wrote:
Thu Sep 30, 2021 4:06 am
Hi Moss!
I'm using your extension both with launchpad pro and pro mk3 a lot.
I really like to play that controller with the chromatic "guitar alike" layout but I found it's pretty hard to record clips in the clip launcher that way. Would there be a mean to stop the current clip recording (and start it to loop) without having to go to the script's session mode hitting the good matrix clip wich I always end up missing...
Thank you for awesome work anyway!
I can only suggest to create clips of fixed length with the "New" function. This way you do not need to switch. 2nd solution is to get another launchpad (or similar) :-)

User avatar
KVRAF

Topic Starter

2979 posts since 13 May, 2004

Post Fri Oct 01, 2021 3:06 am

btvd wrote:
Thu Sep 30, 2021 5:14 am
Hey, Moss! Very thank you for updates! Can you explain plz if I could use your Beastep cript with BSP? If so how can I do it? Sorry for noobsih queastions!
I dropped specific support for the BSP since it did not really make much sense (no colors on the pads, etc.). Instead you can use the Generic Flexi (even with modes). See my Youtube channel for several Geneirc Flexi tutorials.

User avatar
KVRAF

Topic Starter

2979 posts since 13 May, 2004

Post Fri Oct 01, 2021 3:46 am

present wrote:
Tue Sep 28, 2021 6:35 am
Hi Moss, sorry to ask again but ...

On Push 2 with Bitwig, Is there any way to make the 'pads' or the mix view follow 'track selection'?

My problem is that if I 'directly select' a track by mouse or MIDI, the pads only update if I'm in the right 'mixer page'...

Video to illustrate - I select a few tracks via MIDI - all works fine till I select one that's not in view: https://photos.app.goo.gl/dxich8cTQLUpJaD97

Thanks!
Thanks for the report. I can reproduce it and know what the reason is but that's a bit tricky. Let's see if I can fix this...

User avatar
KVRAF

Topic Starter

2979 posts since 13 May, 2004

Post Fri Oct 01, 2021 11:33 am

moss wrote:
Fri Oct 01, 2021 3:46 am
present wrote:
Tue Sep 28, 2021 6:35 am
Hi Moss, sorry to ask again but ...

On Push 2 with Bitwig, Is there any way to make the 'pads' or the mix view follow 'track selection'?

My problem is that if I 'directly select' a track by mouse or MIDI, the pads only update if I'm in the right 'mixer page'...

Video to illustrate - I select a few tracks via MIDI - all works fine till I select one that's not in view: https://photos.app.goo.gl/dxich8cTQLUpJaD97

Thanks!
Thanks for the report. I can reproduce it and know what the reason is but that's a bit tricky. Let's see if I can fix this...
I did some more testing: the bug that I can reproduce is when I click inside of a group (with more than 8 tracks) and click on a track which is not on the first page of the group. Is that the case too with your issue? I could not reproduce that with all tracks being flat.

EDIT: Just noticed that this bug is already documented: :roll:
https://github.com/teotigraphix/Framewo ... issues/251

KVRer
5 posts since 24 Aug, 2021

Post Fri Oct 01, 2021 1:18 pm

moss wrote:
Fri Oct 01, 2021 3:06 am
btvd wrote:
Thu Sep 30, 2021 5:14 am
Hey, Moss! Very thank you for updates! Can you explain plz if I could use your Beastep cript with BSP? If so how can I do it? Sorry for noobsih queastions!
I dropped specific support for the BSP since it did not really make much sense (no colors on the pads, etc.). Instead you can use the Generic Flexi (even with modes). See my Youtube channel for several Geneirc Flexi tutorials.
Thank you! Will have a look! Cheers!

User avatar
KVRAF

Topic Starter

2979 posts since 13 May, 2004

Post Sun Oct 03, 2021 7:26 am

DrivenByMoss 14.1 is online!
  • Generic Flexi
    • New: Scene: Create Scene - Creates a new scene at the end of the scene list.
  • Launchpad
    • New: Drum mode: The loop length area has now new functions. There is one red button on the right bottom to toggle the functions on and off. If enabled, the 2nd row contains the previous combination buttons. The first row now allows to toggle note repeat, enable the selection of note repeat period with the Scene buttons, enable the selection of note repeat note length with the Scene buttons.
  • OSC
    • New: /scene/add - Creates a new scene at the end of the scene list.
  • Push
    • New: Select+Duplicate: Creates a new scene at the end of the scene list.
    • Fixed: Push 1: Notification messages on the display were canceled too early.
    • Fixed: Push 2: Drawing glitch when no track was selected when navigating into a group with the cursor keys on the computer keyboard.
Drum Mode changes of Launchpad:
https://youtu.be/ELOm9w7oCVY

KVRer
3 posts since 3 Oct, 2021

Post Sun Oct 03, 2021 8:17 am

AUTO-ADMIN: Non-MP3, WAV, OGG, SoundCloud, YouTube, Vimeo, Twitter and Facebook links in this post have been protected automatically. Once the member reaches 5 posts the links will function as normal.
Hi Moss, I'm having a problem with my Launchkey 49 mk3 running on Bitwig 4 using Moss script 14.1.0, on Linux based on Ubuntu 21.04.

It's stuck like this:
Image https://imgur.com/RYDgIcx (https://imgur.com/RYDgIcx)
Image https://imgur.com/0Z5fwXK (https://imgur.com/0Z5fwXK)

I cannot access the session controls at all, and the buttons/faders/knobs don't work. I have tried reflashing the keyboard's firmware, and downgrading Bitwig, but no luck.

However when I connect it to my gf's pc running Bitwig 8-track and an older version of the script, it works as intended. Additionally it used to work as intended on my own PC just a few days ago, not sure what changed. Are there any further ways I could trouble this and try to get my Launchkey working again? Thank you.

User avatar
KVRAF

Topic Starter

2979 posts since 13 May, 2004

Post Sun Oct 03, 2021 10:00 am

vjxyz wrote:
Sun Oct 03, 2021 8:17 am
Hi Moss, I'm having a problem with my Launchkey 49 mk3 running on Bitwig 4 using Moss script 14.1.0, on Linux based on Ubuntu 21.04.

It's stuck like this:
Image https://imgur.com/RYDgIcx
Image https://imgur.com/0Z5fwXK

I cannot access the session controls at all, and the buttons/faders/knobs don't work. I have tried reflashing the keyboard's firmware, and downgrading Bitwig, but no luck.

However when I connect it to my gf's pc running Bitwig 8-track and an older version of the script, it works as intended. Additionally it used to work as intended on my own PC just a few days ago, not sure what changed. Are there any further ways I could trouble this and try to get my Launchkey working again? Thank you.
Just tested it on Linux (latest Ubuntu Studio) and it works fine. Make sure that your firmware is really up to date. It should output 197 in the Javascript console when started.

KVRer
3 posts since 3 Oct, 2021

Post Sun Oct 03, 2021 10:37 am

Thanks Moss, I was able to fix it by deleting the Launchkey in Bitwig settings and letting Bitwig + your script autodetect them again.

KVRer
1 posts since 3 Oct, 2021

Post Sun Oct 03, 2021 11:32 am

Hi Moss,

I was wondering would it be possible to do a script for Native Instuments S8 controller for bitwig that makes use of its screens? I was thinking it would be cool controller for a dj/live setup if you could use the screen to view 8 channels of launched clips.

have you ever considered it or know if its possible? The screens use QML, im not sure if thats the same as Maschine or Komple Kontrol screens.

Return to “Controller Scripting”