Feature Request: sticky menus (resolved)

Official support for: nusofting.com
User avatar
KVRAF
3399 posts since 3 Jan, 2003 from Vancouver

Post Wed Aug 06, 2003 8:52 am

One thing that's consistently bothered me with the Dash plugs is the non-sticky menu. I'm so used to clicking and releasing to get a menu, but when I do this on these plugins I usually end up resetting all the presets or something. Is it possible to make these menus sticky or will I just have to adjust like I did with Macs (which, circa OS9, also had non-sticky menus) a few years ago?

User avatar
Banned
5103 posts since 12 Jun, 2001 from Wusik Dot Com

Post Wed Aug 06, 2003 11:53 am

This is actually a feature from the OS, the menus we use are from Steinberg VST-GUI Library, and they use the default OS menus. So there is not much we can do right now without having to do an entire new GUI library on our own. :(

Wk

User avatar
KVRAF

Topic Starter

3399 posts since 3 Jan, 2003 from Vancouver

Post Wed Aug 06, 2003 12:19 pm

Damn. I guess I'll just have to keep choosing things at random before browsing the menu to find what I actually want! :(

User avatar
Banned
5103 posts since 12 Jun, 2001 from Wusik Dot Com

Post Wed Aug 06, 2003 12:27 pm

Maybe I don't quite get your problem. You mean the global synth menu? Give me an example on what you are doing and how you think it should work. :wink:

Regards, WilliamK

User avatar
KVRAF

Topic Starter

3399 posts since 3 Jan, 2003 from Vancouver

Post Wed Aug 06, 2003 12:45 pm

The menu that comes up when you click on the synth's logo - the one that has "about" and volume levels and such. I'm used to clicking once to get a menu showing, but because this menu requires me to hold down the mouse button, it means I click, slide the mouse a little (which selects something) and then when I let go of the button (which I always expect to just leave the menu active) it runs whatever the mouse happened to be over. Gets me every time.

If that doesn't describe it well enough, I'll do some screen captures when I get home... :) I know I'm very bad at describing things (you know, the guy with the jacket who did the stuff - he was in that show with the girl)

User avatar
Banned
5103 posts since 12 Jun, 2001 from Wusik Dot Com

Post Wed Aug 06, 2003 12:49 pm

Strange, for me here I just click once to open the menu, I don't need to keep the mouse-bt down... Wich windows are you using? On W98, ME and XP it all worked that way for me, and we didn't changed anything on the code that would make that happen.

Try clicking only once to open the menu, it should stay open after you release the mouse-buttom.

Best Regards, WilliamK

User avatar
KVRAF

Topic Starter

3399 posts since 3 Jan, 2003 from Vancouver

Post Wed Aug 06, 2003 1:08 pm

I'm using Windows 2000. Maybe I'm just sloppy with my mouse control...

User avatar
Banned
5103 posts since 12 Jun, 2001 from Wusik Dot Com

Post Wed Aug 06, 2003 1:11 pm

pough wrote:I'm using Windows 2000. Maybe I'm just sloppy with my mouse control...
:lol: Good one. It happens to all of us one time, we all get sloppy... :P Here if I press too fast it does open and click on the first thing it finds, but just when I do too fast. But I also found that other programs does that too, so I'm more carefull with menus now. ;)

Hope I helped somehow...

Best Regards, WilliamK

Return to “NUSofting”