New thread, Modelonia 2.0 beta 32 64-bit Windows And Mac! (beta closed)

Official support for: nusofting.liqihsynth.com
User avatar
KTlin
KVRist
485 posts since 20 Jul, 2009 from beyond

Post Mon Sep 21, 2015 9:58 am

Hi Luigi

Nasty bug when using Modelonia (Modelonia_2.0_Windows_DLLs_build_29) in Ableton Live 9.1 64bit.
It loads and plays ok, but when I load another preset, the preset name remains the same (it doesn't read the name of the new preset loaded) and the left channel gets muted (only right channel outputs sound).

User avatar
tl
KVRist
471 posts since 8 May, 2002 from ... , germany

Re: New thread, Modelonia 2.0 beta 32 64-bit Windows And Mac!

Post Mon Sep 21, 2015 2:08 pm

liqih wrote:
tl wrote:oops.
using the parameter/settings mutate feature in bidule caused a crash:
cheers,
tl.
"mutate feature" you say, ok I will check that,
thanks, have you used VST or AU, 32-bit or 64-bit?
very late answer:
32 bit vst in bidule 32 bit on win xp sp3.

cheers,
tl.

User avatar
KTlin
KVRist
485 posts since 20 Jul, 2009 from beyond

Re: New thread, Modelonia 2.0 beta 32 64-bit Windows And Mac!

Post Tue Sep 22, 2015 4:09 am

KTlin wrote:Hi Luigi
Nasty bug when using Modelonia (Modelonia_2.0_Windows_DLLs_build_29) in Ableton Live 9.1 64bit.
It loads and plays ok, but when I load another preset, the preset name remains the same (it doesn't read the name of the new preset loaded) and the left channel gets muted (only right channel outputs sound).
Also, it crashes Bitwig the moment I load Modelonia.

liqih
DASH Guy
7271 posts since 20 Sep, 2001

Re: New thread, Modelonia 2.0 beta 32 64-bit Windows And Mac!

Post Tue Sep 22, 2015 9:01 am

KTlin wrote:Hi Luigi

Nasty bug when using Modelonia (Modelonia_2.0_Windows_DLLs_build_29) in Ableton Live 9.1 64bit.
It loads and plays ok, but when I load another preset, the preset name remains the same (it doesn't read the name of the new preset loaded) and the left channel gets muted (only right channel outputs sound).
"only right channel outputs sound" is for a mistake I made for that build
restoring variables after debug, it's already fixed now. Anyway, in the build you're using, just turning on AP EQ will skip the mistake and both channels work.

About the name issue, please tell where do you see that, in the GUI or in the Live menu?, Loading XML Modelonia file, or FXP preset?

Thanks

We will check Bitwig demo too. if possible.

Thanks tl for the info.
http://nusofting.com
NUSofting : Peti Modelonia Sinnah

User avatar
KTlin
KVRist
485 posts since 20 Jul, 2009 from beyond

Re: New thread, Modelonia 2.0 beta 32 64-bit Windows And Mac!

Post Wed Sep 23, 2015 8:01 am

liqih wrote: Anyway, in the build you're using, just turning on AP EQ will skip the mistake and both channels work.
Nope. It doesn't work. When I turn the AP EQ on, I get no sound at all.
liqih wrote:About the name issue, please tell where do you see that, in the GUI or in the Live menu?, Loading XML Modelonia file, or FXP preset?
If I try to load an XML file, Live crashes instantly.
If I load a preset from the drop-down menu, the name of the preset remains the same, both in the GUI and in the Live menu. So no matter what preset I select, the name "000 BLN Absolutely!" doesn't change.
If I try to change presets by using the left-right arrows (<<< >>>) I have to click twice on them in order to get to the next/previous preset. This is very annoying.
Also, some presets are way too loud so the sound gets distorted.
liqih wrote:"only right channel outputs sound" is for a mistake I made for that build
Is there any newer build I could download?

Cheers

liqih
DASH Guy
7271 posts since 20 Sep, 2001

Re: New thread, Modelonia 2.0 beta 32 64-bit Windows And Mac!

Post Wed Sep 23, 2015 9:08 am

Sorry for all the issues in a row!

Here is an update I made now:
http://nusofting.liqihsynth.com/modelon ... ild_23.zip
Note that the DLLs and also the skin folders must be updated with the ones in the zip linked above.

Presets are not updated yet. Thanks for your patience.
http://nusofting.com
NUSofting : Peti Modelonia Sinnah

liqih
DASH Guy
7271 posts since 20 Sep, 2001

Re: New thread, Modelonia 2.0 beta 32 64-bit Windows And Mac!

Post Wed Sep 23, 2015 9:09 am

tl also please try this update. Thanks
http://nusofting.com
NUSofting : Peti Modelonia Sinnah

User avatar
KTlin
KVRist
485 posts since 20 Jul, 2009 from beyond

Re: New thread, Modelonia 2.0 beta 32 64-bit Windows And Mac!

Post Wed Sep 23, 2015 3:14 pm

I downloaded the new build, and all the problems I had before are gone now :tu:
But there's a new issue: everything on the GUI is very sluggish. When I move a knob or a slider I get very low refresh rate on the GUI. The entire Modelonia window behave the same, as well as the meters in Live (if I replace Modelonia with another plugin, the meters in Live go back to normal motion).

liqih
DASH Guy
7271 posts since 20 Sep, 2001

Re: New thread, Modelonia 2.0 beta 32 64-bit Windows And Mac!

Post Wed Sep 23, 2015 3:25 pm

KTlin wrote:I downloaded the new build, and all the problems I had before are gone now :tu:
But there's a new issue: everything on the GUI is very sluggish. When I move a knob or a slider I get very low refresh rate on the GUI. The entire Modelonia window behave the same, as well as the meters in Live (if I replace Modelonia with another plugin, the meters in Live go back to normal motion).
Ok I think I know what it could be, the new resize code for the displays to make the fonts bigger, I will check that.

Thanks.
http://nusofting.com
NUSofting : Peti Modelonia Sinnah

liqih
DASH Guy
7271 posts since 20 Sep, 2001

Re: New thread, Modelonia 2.0 beta 32 64-bit Windows And Mac!

Post Thu Sep 24, 2015 11:43 am

Another update
http://nusofting.liqihsynth.com/modelon ... ild_24.zip

please try this and tell if the GUI is still sluggish
http://nusofting.com
NUSofting : Peti Modelonia Sinnah

User avatar
KTlin
KVRist
485 posts since 20 Jul, 2009 from beyond

Re: New thread, Modelonia 2.0 beta 32 64-bit Windows And Mac!

Post Thu Sep 24, 2015 1:36 pm

The entire Modelonia window and the meters in Ableton are moving smooth now, so that seems to be fixed, but the knobs and sliders are still sluggish and jumpy.

Also, there's one more bug I noticed (actually I noticed it some time ago, but I forgot to write about it): if I move the Horn's R+B slider with the mouse and then send some aftertouch data from the keyboard, that R+B slider starts to move somehow randomly, even though it isn't assigned to aftertouch. If I click on any other knob/slider, the R+B slider stops moving when sending aftertouch.

liqih
DASH Guy
7271 posts since 20 Sep, 2001

Re: New thread, Modelonia 2.0 beta 32 64-bit Windows And Mac!

Post Thu Sep 24, 2015 2:00 pm

Thanks for the reports, we will check those issues too.
http://nusofting.com
NUSofting : Peti Modelonia Sinnah

liqih
DASH Guy
7271 posts since 20 Sep, 2001

Re: New thread, Modelonia 2.0 beta 32 64-bit Windows And Mac!

Post Thu Sep 24, 2015 2:11 pm

confirmed the bug of aftertouch to R+B even if not linked, should be easy to fix,

knobs and sliders move smoothly on my PC, but I will check with others.
http://nusofting.com
NUSofting : Peti Modelonia Sinnah

User avatar
KTlin
KVRist
485 posts since 20 Jul, 2009 from beyond

Re: New thread, Modelonia 2.0 beta 32 64-bit Windows And Mac!

Post Thu Sep 24, 2015 3:13 pm

I just tested it in Bitwig, and I don't get these bugs. The knobs/sliders are moving smoothly and the R+B/aftertouch issue doesn't appear here.

liqih
DASH Guy
7271 posts since 20 Sep, 2001

Re: New thread, Modelonia 2.0 beta 32 64-bit Windows And Mac!

Post Thu Oct 01, 2015 4:29 pm

Strange, it could be Live issue, I also have the aftertouch weirdness only in Live
http://nusofting.com
NUSofting : Peti Modelonia Sinnah

Return to “NUSofting + DashSignature”