Modelonia : presets files on Mac ?

Official support for: nusofting.com
KVRer
5 posts since 28 Feb, 2017

Post Wed Jan 08, 2020 6:35 am

Yeah, I've tried both AU and VST2 and both give me the same error 'No Presets Folder'. The plugin works fine other than that, only issue is finding where the presets are located. Do you have any idea where the installer might have copied the preset folder? Or is it just that the installer did not copy the presets at all?

Thank you so much for taking the time to read this and I hope we can have Modelonia fully working very soon.

Looking forward to hearing from you.

KVRist
481 posts since 13 May, 2003 from Sydney, Australia

Post Thu Jan 09, 2020 4:08 am

Hi, sorry to see that you are having problems with Modelonia finding its presets.
carlos.gon90 wrote:
Wed Jan 08, 2020 6:35 am
Do you have any idea where the installer might have copied the preset folder?
Just to be clear, the Modelonia installer doesn't install the presets; rather the first time you run Modelonia it copies the presets out of the installed plug-in bundle and into what should be a standard place for plug-ins to find presets (~/Library/Audio/Presets). I guess it's possible that with each increasingly stricter release of macOS it's getting harder for apps and plug-ins to access directories like that.

So, if you are happy to run some terminal commands, first start with seeing whether the Modelonia presets directory is actually there:

Code: Select all

ls -l ~/Library/Audio/Presets
Is a directory named Modelonia in that list?

If so, is there anything in that directory? Check by running:

Code: Select all

ls -l ~/Library/Audio/Presets/Modelonia
If the directory isn't there and you are willing to run a command that copies files around on your machine on the say-so of some guy on the internet then this one should do the same thing that the Modelonia first-run code is doing behind the scenes:

Code: Select all

rsync -aiv /Library/Audio/Plug-Ins/VST/Modelonia.vst/Contents/Resources/Presets/Modelonia ~/Library/Audio/Presets/
If the presets are already there, then I'm confused why Modelonia can't find them.

While, as @liqih says, we have not done any deep testing of Modelonia on macOS Catalina, I can say that my copy of Modelonia, previously installed on an older macOS version, still opens in both Logic Pro X and Ableton Live 9, finds and loads presets in both and can produce audio. So I'm hoping this is just a "first-run" issue in macOS Catalina.

KVRer
5 posts since 28 Feb, 2017

Post Thu Jan 09, 2020 7:29 pm

Hi Blurk, thanks for taking the time to reply.

So i've checked and was able to find the presets inside the VST package, so I copied it to the presets folder in my library. So the presets are already there and inside the folder I can see all the presets with their names and all, they are all XML files.

What I'm having problems now with is when I open Modelonia in Ableton Live 10, I still get the 'no presets folder' error. I've reversed to Mojave and everything is working fine except Modelonia. What's you advice here? Everything is where it's supposed to be but Modelonia can't seem to find the presets.

One thing I notice is, when I launch the installer it says both the VST and the AU are updates, is that how it's supposed to read? So I launch the installer, follow the instructions and I click where it says customize, and there I see both the VST and the AU, and both say 'Upgrade' under the action column.

Other than that I think everything is where it's supposed to be. Are presets inside the Modelonia folder itself or is there another folder inside that Modelonia one holding the presets?

Looking forward to hearing back from you.

May be you can send me an older installer? I think that might be the problem.

Thank you so much!

DASH Guy
7617 posts since 20 Sep, 2001

Post Thu Jan 09, 2020 8:13 pm

Hi Carlos, while waiting for the Mac expert Blurk to say "how", I think the best things to do in your case is to check whether the preset location has the right permissions to allow Modelonia to read the XML files. Meanwhile I also uploaded all 407 presets in Modelonia_Presets.zip for further and easy retrieval.
http://nusofting.com/modelonia/Modelonia_Presets.zip
http://nusofting.com
NUSofting : Peti Modelonia Sinnah

KVRist
481 posts since 13 May, 2003 from Sydney, Australia

Post Mon Jan 13, 2020 2:48 am

Yeah, I'm at a bit of a loss to know what else to suggest right now.

What's the output of these commands?

Code: Select all

ls -l ~/Library/Audio/Presets
ls -l ~/Library/Audio/Presets/Modelonia
I genuinely don't think an older installer is going to help. That's likely to have older code that's fighting more against what Apple is trying to lock down. We've put quite a bit of effort in the latest version to conform more to using the locations Apple has been advising.

KVRer
5 posts since 28 Feb, 2017

Post Mon Jan 20, 2020 1:04 pm

Hey guys, how are you?

So after some extensive reading and trying things on my system I was finally able to solve this issue. After reverting to Mojave and installing Modelonia, I noticed the presets were installed correctly in the presets folder on my system (On Catalina presets are not installed in that folder) but I was still getting the same 'No Presets Folder' error on Ableton Live 10. I went on this blog where it said that when installing applications (I Installed a lot after my clean install of Mojave) some of them modify permissions temporarily, which is normal, but sometimes those same installers don't return permissions to their original state, leaving your permissions totally changed and of course affecting other applications, in this case my access to presets from Modelonia.

After resetting permissions on my mac, which no longer can be done from the disk utility but instead through the terminal, I was able to open Modelonia as I usually did in the past, with no errors and all presets there, which made me really happy. So I wanted to let you know and of course share the blog post that helped me repair my permissions so that other people that are struggling with the same issue can solved it. You can follow the steps here: https://www.makeuseof.com/tag/mac-disk- ... ns-repair/

After doing this permissions repair I also went ahead and did a SMC reset on my mac also because of some apple recommendations and you can also do a vram reset as well, all for the health of your computer.

Thank you so much liquih and Burk for having the best customer service ever, this would have been impossible with out your help.

Are you guys planning on releasing a new instrument at some point? Love your products

KVRist
481 posts since 13 May, 2003 from Sydney, Australia

Post Tue Jan 21, 2020 2:32 am

carlos.gon90 wrote:
Mon Jan 20, 2020 1:04 pm
Hey guys, how are you?
Great now, thanks to your post here.
So after some extensive reading and trying things on my system I was finally able to solve this issue. After reverting to Mojave and installing Modelonia, I noticed the presets were installed correctly in the presets folder on my system (On Catalina presets are not installed in that folder) but I was still getting the same 'No Presets Folder' error on Ableton Live 10. I went on this blog where it said that when installing applications (I Installed a lot after my clean install of Mojave) some of them modify permissions temporarily, which is normal, but sometimes those same installers don't return permissions to their original state, leaving your permissions totally changed and of course affecting other applications, in this case my access to presets from Modelonia.
Yes, I recall seeing that before when we got a directory listing from one of the users here. I would just like to clarify that the NUSofting macOS installers just use the standard macOS installer without any cunning extra scripts to change permissions. Some of the older ones do try to copy files into the home directory, but we changed that approach from round about Modelonia onwards. Basically, I rather have an installer fail than risk messing up someone else's system by second-guessing permissions.
After resetting permissions on my mac, which no longer can be done from the disk utility but instead through the terminal, I was able to open Modelonia as I usually did in the past, with no errors and all presets there, which made me really happy. So I wanted to let you know and of course share the blog post that helped me repair my permissions so that other people that are struggling with the same issue can solved it. You can follow the steps here: https://www.makeuseof.com/tag/mac-disk- ... ns-repair/
And thank you very much for taking the time to come back here and letting us know. It's always good to know that things are working again.
Thank you so much liquih and Burk for having the best customer service ever, this would have been impossible with out your help.

Are you guys planning on releasing a new instrument at some point? Love your products
Awww, thanks. And yes, Liquih has been teasing a new instrument here.

KVRer
5 posts since 28 Feb, 2017

Post Tue Jan 21, 2020 4:40 am

My pleasure guys!

I didn't mean Modelonia, I think other installers where responsible for the change in my permissions. Since I did a clean Install of Mojave I had to install 100s of plugins and anyone of those could have temporarily changed my permissions and the installer just did't returned them to their original state.

Thanks for all your help and I'm really excited about the new instrument. Would you guys be down to getting in touch over email and may be discussing me doing some presets for you guys?

Excited to hear back from you!

DASH Guy
7617 posts since 20 Sep, 2001

Post Tue Jan 21, 2020 7:03 am

carlos.gon90 wrote:
Tue Jan 21, 2020 4:40 am
Thanks for all your help and I'm really excited about the new instrument. Would you guys be down to getting in touch over email and may be discussing me doing some presets for you guys?
Yes I would be pleased, you can send to lqhminei -usual glyph here- nusofting.com
http://nusofting.com
NUSofting : Peti Modelonia Sinnah

Return to “NUSofting”