U-he plugins in Linux Reapers (Debian Stretch, XFCE), undo issue

User avatar
lilith93
KVRist
70 posts since 7 Apr, 2018

Post Sat Jun 15, 2019 1:52 pm

Hi,

this might be of interested for the U-he linux devs.
I ran into an issue with Reaper and U-he plugis which is also described here:

https://forum.cockos.com/showpost.php?p ... tcount=330
https://forum.cockos.com/showpost.php?p ... tcount=335
https://forum.cockos.com/showpost.php?p ... tcount=337

Short: When loading for instance Repro-1/5, Diva or Hive into Reaper, there's a problem with Reapers Undo function. It only happens with the above U-he plugins. Triplecheese and Podolski are fine. For more details please see the reaper forum.

The problem occurs in Debian Stretch with the XFCE WM. I made a test with the recent MXLinux and this behaves fine.

User avatar
lilith93
KVRist
70 posts since 7 Apr, 2018

Re: U-he plugins in Linux Reapers (Debian Stretch, XFCE), undo issue

Post Sun Jun 16, 2019 5:41 am

The problem is solved. At least it´ s working at the moment. It was related to the decimal separator. I set everything to en_US.utf8 on my system now (Debian / Stretch). Before it was German. I also had a comma sometimes in the REAPER.ini file as decimal separator next to point which likely caused the issue.

User avatar
lilith93
KVRist
70 posts since 7 Apr, 2018

Re: U-he plugins in Linux Reapers (Debian Stretch, XFCE), undo issue

Post Fri Dec 13, 2019 3:09 pm

Hi,

I recently upgraded to Buster and ran again into this issue. When loading DIVA (REV 8272) or HIVE2 or Repro-1 in Reaper the plugin will convert some points to commas in the Reaper preferences settings. As far I can see I have LC_NUMERIC set to en_US.UTF-8, at least that's what "locale" shows me:

Code: Select all

locale
LANG=en_US.utf8
LANGUAGE=
LC_CTYPE="en_US.utf8"
LC_NUMERIC=en_US.UTF-8
LC_TIME=de_DE.UTF-8
LC_COLLATE="en_US.utf8"
LC_MONETARY=de_DE.UTF-8
LC_MESSAGES="en_US.utf8"
LC_PAPER=de_DE.UTF-8
LC_NAME=de_DE.UTF-8
LC_ADDRESS=de_DE.UTF-8
LC_TELEPHONE=de_DE.UTF-8
LC_MEASUREMENT=de_DE.UTF-8
LC_IDENTIFICATION=de_DE.UTF-8
LC_ALL=
When I start Reaper in the terminal it's perfectly working though. I'm using Debian 10 with XFCE. Does anyone have any idea what's wrong here?

User avatar
lilith93
KVRist
70 posts since 7 Apr, 2018

Re: U-he plugins in Linux Reapers (Debian Stretch, XFCE), undo issue

Post Sat Dec 14, 2019 4:24 am

I could replicate and solve the behaviour on a second PC. Obviously the command

Code: Select all

echo 'export LC_NUMERIC="en_US.UTF-8"' >>~/.bashrc

Code: Select all

source ~/.bashrc


only affects programs started from the terminal.

What works is:

Code: Select all

update-locale LC_NUMERIC=en_US.UTF-8
You need root rights for that. It changes the entry in /etc/defaut/locale

After reboot the change will work. If I can reproduce it on my music PC the issue is solved.

Return to “u-he Linux support”