Big Sur + u-he plugins compatibility notice

Official support for: u-he.com
User avatar
KVRian
1224 posts since 25 Sep, 2011 from Colombia

Post Sat Feb 27, 2021 6:15 am

Urs wrote:
Fri Feb 26, 2021 11:34 pm
Yorrrrrr wrote:
Fri Feb 26, 2021 6:12 pm
Sigh...Can't wait for RePro to be fully compatible with Big Sur/Apple Silicon (and Ableton Live 11 on it..). RePro 5 VST2 is giving me huge CPU spikes (no other third party VST is doing the same). Any ETA?
We have not heard of CPU spikes at all. Any particular preset or situation in which that happens?

ETA is "soon" as we have next to no negative feedback for the native version of Hive 2.1. Only, because there's no way to build AAX natively for Apple Silicon, we're bit miffed that we probably have to do a two-stage release for everything.
No, it happens randomly when playing RePro 5 (Ableton Live 11, MBP 16" 2019, MacOS Big Sur, VST2 version). No particular preset or situation that I notice. But I'll investigate further.

User avatar
KVRAF
10071 posts since 16 Feb, 2005 from Kingston, Jamaica

Post Sat Feb 27, 2021 6:45 am

I have random spikes on my macbook pro too, not specific to Repro but I realise now (eventually) that it happens when the laptop is not being cooled sufficiently. Which is why it seems random. I can run a project first thing the morning and it runs fine and the same project running at 2pm might give me trouble unless I increase the sample buffer size.

rsp
sound sculptist

KVRer
5 posts since 29 May, 2003 from Madison, WI

Post Sat Feb 27, 2021 11:12 am

I have random spikes that cause audio glitches on my 2019 27” i9 iMac (64GB RAM, 2TB internal SSD, AMD Radeon Pro Vega 48, NI Komplete Audio 6 rev. 1) with Repro5 VST2 as well. Running Ableton Live 11 and Big Sur. 48khz / 128 buffer.

The spikes and audio glitches happen more frequently when the plugin window is displayed, but can also happen when it isn’t showing. I’m using the sRGB IEC61966-2.1 color profile. They are worse with the native iMac color profile.

Are the Mac UI optimizations that have been applied to the Hive 2.1 beta going to make their way into your other plugins?

User avatar
Urs
u-he
25500 posts since 8 Aug, 2002 from Berlin

Post Sun Feb 28, 2021 2:35 am

Garion2k wrote:
Sat Feb 27, 2021 11:12 am
Are the Mac UI optimizations that have been applied to the Hive 2.1 beta going to make their way into your other plugins?
Yes, those spikes will be gone. They probably happen when keyboard control (bottom) and edit display (on top) update at the same time and - since Mojave/Catalina - the OS insists that the whole window needs to be redrawn.

Before Mojave/Catalina, the OS would give us an array of rectangles to update, but since then all these rectangles are somehow merged into one big one, causing an excess need to redraw the UI estate by an average factor of 10 (!).

In addition, the new handling of bitmaps with color profiles has taxed the CPU even more because less work is done on the GPU.

We have completely reworked these areas (despite Apple's lack of advice) and those glitches will be gone, hopefully for many iterations of macOS to come.

KVRer
5 posts since 29 May, 2003 from Madison, WI

Post Sun Feb 28, 2021 10:57 am

Great news, thank you! Apple sure doesn’t make it easy.

User avatar
KVRian
1224 posts since 25 Sep, 2011 from Colombia

Post Thu Mar 04, 2021 7:27 pm

Yorrrrrr wrote:
Sat Feb 27, 2021 6:15 am
Urs wrote:
Fri Feb 26, 2021 11:34 pm
Yorrrrrr wrote:
Fri Feb 26, 2021 6:12 pm
Sigh...Can't wait for RePro to be fully compatible with Big Sur/Apple Silicon (and Ableton Live 11 on it..). RePro 5 VST2 is giving me huge CPU spikes (no other third party VST is doing the same). Any ETA?
We have not heard of CPU spikes at all. Any particular preset or situation in which that happens?

ETA is "soon" as we have next to no negative feedback for the native version of Hive 2.1. Only, because there's no way to build AAX natively for Apple Silicon, we're bit miffed that we probably have to do a two-stage release for everything.
No, it happens randomly when playing RePro 5 (Ableton Live 11, MBP 16" 2019, MacOS Big Sur, VST2 version). No particular preset or situation that I notice. But I'll investigate further.
In latest Hive 2.1 RC 11017 I get the same CPU usage spikes/sound pops-glitches as with RePro, but MUCH worse.

Return to “u-he”