I am done with Spitfire Audio’s Labs.

Sampler and Sampling discussion (techniques, tips and tricks, etc.)
KVRAF
22321 posts since 20 Oct, 2007 from not here

Post Sat May 08, 2021 5:26 am

that's what I thought I was looking at, one at a time. I did the first one on the list; now bored, I went to do other things and when I came back they were all done. It appears to involve a Repair All, there is a button, but what that does with a cleared-out Patches and Presets is download what's been installed previously, but doesn't Install, which is manual.

KVRist
101 posts since 2 Mar, 2018

Post Tue May 18, 2021 7:02 pm

I've used various LABS stuff. Never had an issue.

KVRer
2 posts since 6 May, 2021

Post Fri May 21, 2021 11:49 am

I wish they'd not use their proprietary format. I've had so many issues with Labs, HZ Strings and the EW choirs where i have to get support to renew my license cause it broke and theirs no easy way to define where the files it needs should be.

User avatar
KVRian
924 posts since 31 May, 2017

Post Thu Jun 03, 2021 10:14 am

What an absolutely infuriating experience using LABS. So I had the libraries need repairing issue and followed their instructions to fix the issue (which did not quite work right at first and was a generally buggy process). But now that the libraries are repaired many of the instances of LABS in my old projects are all screwed up. For some instances the plugin settings got messed up so whatever volume, filter, reverb, etc levels I had set are all wrong and the tracks with LABS are super loud and clipping my project. And for others the wrong presets are loaded, so when I originally recorded something with let’s say a string preset it now loads a percussion patch. It’s really annoying because half the time I don’t remember exactly what preset I had used or how I had it set.
The fact that these samples are given away for free is no excuse for such shoddy programming and unprofessional attention to detail.

Very strange way for them to introduce their products to new users because I would never even consider paying for anything from Spitfire after this experience.

KVRAF
22321 posts since 20 Oct, 2007 from not here

Post Thu Jun 03, 2021 10:21 am

that would piss me off.
fortunately, I have revisited one thing since I repaired the thing, which had to be right for that project, it was very specific double-tongued trumpet (Trumpet Fields) which fit the timing and mix just_so and it was fine. Its levels are determined by automation, there's no difference.
I don't want to get too reliant on something free or unsupported at this point tho

User avatar
KVRian
924 posts since 31 May, 2017

Post Thu Jun 03, 2021 10:44 am

Yeah, very frustrating. Honestly I should be more diligent about these kinds of things and make a point of bouncing in place all tracks (or at least those where I don’t have full faith in the developer yet) but ultimately that just doesn’t suit my workflow.
As a composer/songwriter/producer I am constantly writing and recording in a number of different styles and genres and I am always primarily focused on getting ideas out quickly even if they are just little fragments or sketches or scraps. Sometimes I will return (even years later) to those scraps for important projects. I can’t break my stride just because a dev is unreliable.
The better thing for me is to just identify the devs that I can’t trust and remove them from my workflow as quickly as possible.

KVRAF
22321 posts since 20 Oct, 2007 from not here

Post Thu Jun 03, 2021 11:02 am

Well if the thing broke like it did as though during my sleep one night, during that project (I've had at least one project where it was essential but could be replaced by throwing a little money at the problem, this will have ruined me) I'd have a grudge. I'm not really in the market anyway, I don't like their Kontakt GUI at all, the things I'd be interested in would have to be automatable and they just aren't (the 'evolutions' engine, or whatever).

User avatar
KVRian
924 posts since 31 May, 2017

Post Tue Jun 08, 2021 11:16 am

I’m going to bump this thread every time I open an old project and LABS has replaced all of my patches with the default percussion patch :x

If you value reliability and are thinking of using Spitfire products, I highly recommend you read through this thread first.

KVRAF
22321 posts since 20 Oct, 2007 from not here

Post Tue Jun 08, 2021 1:49 pm

after seeing this I checked that one project. sho nuff, some preset in another whole instrument loaded.
this is abysmal, really.

apparently updating the OS from 15.6 to 15.7 resulted in files which didn't make it, I was apprised of something 'recovery' folder with nothing in it so far as I can discern; so far I'd not noticed, but most of the LABS presets I re-established fairly recently were missing. IE: everything of presets extant at the time of the update are gone, only two new things were there.

an absolute pall on me buying anything Spitfire in future. Repair all LABS again some more.

KVRAF
22321 posts since 20 Oct, 2007 from not here

Post Tue Jun 08, 2021 2:03 pm

this was def. more insane than the last two times

everything has to be deleted, not just what's in the folders, all the folders under 'Spitfire', first.
don't be a chump and take words like "repair" and "install" literally.

limiting myself to five of these now.
gwyne update to Big Sur soon, and that will mean doing it all again, I'd bet money.

Return to “Samplers, Sampling & Sample Libraries”