Classic ZynAddSubFX VST download

Official support for: zynaddsubfx.sourceforge.net
User avatar
per99
KVRist
197 posts since 5 Oct, 2017 from Närförort söder

Post Sun Sep 13, 2020 9:08 pm

Dear jackoo!

Have you got any idea what causes this (I'm using .519beta):

When I use the mouse to write notes in the midi tracks (double-clicking in Reaper), the volume settings for ZynAddSubFx is somehow overridden. What I hear in the loudspekers, when I doubleclick, sounds as if the main volume for the part as well as the main volume for the entire ZASFX were set to maximum, which is not the case. A lot of noise and distortion! (But when I listen to the track the normal way, afterwards, everything i OK.) This does not happen when I do the same thing with other plugins. In those cases the expected volume, determined by the velocity used, is what I hear.

In fact, a couple of months ago, the opposite happened. I was using another program/instrument (strings) and another version of ZASFX (probably .505). Then I could hardly hear the instrument when I created the track, because everything was so silent. But again: playing back/listening to the track worked as expected.

It would be great if this problem is possible to overcome, now that ZASFX has got its midi automation and also the timing is much improved, due to the internal buffers!
To be is to do — Socrates.
To do is to be — Jean-Paul Sartre.
Do be do be do — Frank Sinatra.

User avatar
jackoo
KVRian
720 posts since 3 Jul, 2006

Post Mon Sep 14, 2020 12:20 am

Hi, I'll try to have a look next weekend...

User avatar
per99
KVRist
197 posts since 5 Oct, 2017 from Närförort söder

Post Mon Sep 14, 2020 5:32 am

jackoo wrote:
Mon Sep 14, 2020 12:20 am
Hi, I'll try to have a look next weekend...
When I used midi cc 7 for volume automation (so far only a straight line in the midi track lane) everything got loud. And in fact, when I had a look at the Zyn's volume knob, it was turned up to maximum. When I instaed tried with another cc number for volume automation, the knob was turned down to zero. (But in both cases, when playing the track/project, everything is normal.)

I had to investigate what happens with no automation involved. So I created a copy of my instrument, but with no automation in the Zyn (that window left empty). Right now things work properly, but I don't know for how long, everything seems to be a bit haphazardly.

This issue must, as far as I can understand, be the result of zyn-features together with specific Reaper-features. I can't remember that this ever happened when I used Cubase (but I may be wrong).

Anyway it's astonishing that the zyn reacts as if midi cc 7 messages with the value 127 is sent just because I double click in the midi editor in order to create a note (with a velocity value other than 127).
To be is to do — Socrates.
To do is to be — Jean-Paul Sartre.
Do be do be do — Frank Sinatra.

User avatar
jackoo
KVRian
720 posts since 3 Jul, 2006

Post Mon Sep 14, 2020 12:35 pm

I've opened Reaper, loaded Zyn but wasn't able to reproduce...
So you're saying the reaction is to midi cc 7.

By default Zyn doesn't respond to cc 7 at all, and in the controllers window Vol is disabled by default.
So did you map it to something in the MIDI window?

Is Reaper sending automation data or pure CC data? Is the automation curve inside the MIDI editor or outside? (via the "Trim" button?)
Does it happen only when you draw notes or also when you click the piano roll to the left?

Do you think you could attach a Zyn master setup file? Or anything that could help me replicate it on my end...

User avatar
per99
KVRist
197 posts since 5 Oct, 2017 from Närförort söder

Post Tue Sep 15, 2020 4:27 am

I mapped cc 7 to the global volume for that part, in the zyn's midi window. And I also tried wiht cc 4 (I think it was). And I wrote the automation curve inside the miditrack, not using the trim function. In order for this strange phenomenom to occur, there has to be at least one dot/point that determines the the volume in the lane in the midi track. With cc7 the global volume increases to 127 when I double click to create notes. With that other midi cc nr, the global volume instaed decreased to 0.

But: When I used an asterisk instead of specific cc numbers in the zyn's midi window, and then used the trim function in Reaper, everything worked as it should. At least so far :?
To be is to do — Socrates.
To do is to be — Jean-Paul Sartre.
Do be do be do — Frank Sinatra.

User avatar
per99
KVRist
197 posts since 5 Oct, 2017 from Närförort söder

Post Tue Sep 15, 2020 9:30 pm

jackoo wrote:
Mon Sep 14, 2020 12:35 pm
Is Reaper sending automation data or pure CC data?
I'm not sure I know the difference.
jackoo wrote:
Mon Sep 14, 2020 12:35 pm
Does it happen only when you draw notes or also when you click the piano roll to the left?
I don't remember, and I have edited the whole project, the automation curve inside the midi track is deleted.
jackoo wrote:
Mon Sep 14, 2020 12:35 pm
Do you think you could attach a Zyn master setup file? Or anything that could help me replicate it on my end...
I will try to post a zipped file later on, if you still need it, after having read this reply and the one before. In that case I will also check the piano roll.
To be is to do — Socrates.
To do is to be — Jean-Paul Sartre.
Do be do be do — Frank Sinatra.

User avatar
jackoo
KVRian
720 posts since 3 Jul, 2006

Post Wed Sep 16, 2020 1:33 am

Hi,
zip file would help to reproduce it here, so I can investigate.
If you could reproduce the bug on a "fresh" Reaper project, sending the Reaper Project would also help.
Many thanks!

User avatar
per99
KVRist
197 posts since 5 Oct, 2017 from Närförort söder

Post Wed Sep 16, 2020 10:30 am

jackoo wrote:
Wed Sep 16, 2020 1:33 am
Hi,
zip file would help to reproduce it here, so I can investigate.
If you could reproduce the bug on a "fresh" Reaper project, sending the Reaper Project would also help.
Many thanks!
Hello again!

I don't know if it matters, but I suggest you create a new folder named Reaperprojekt (that spelling) and place it directly under C, so that you can put the whole unzipped folder inside it, like this: C:\Reaperprojekt\jackoo Then, I hope, you should be able to open the project file. (Hmmm … but in your preferences, maybe you should add, first, that Reaper must look for VST:s in that specific folder, because thats where the .dll is. Or maybe you can do everything in some other way.)

Now volume for part one is controlled by cc 52. When I double click to create a note, everything gets silent (not loud as for cc 7). The same for the keys to the left. If you click on an already existing note, this is supposed to mean that every new note will have the same velocity. But when I click an already existing note, they are often silent, as well. NOTE: It happens that you have to double click two or three times before everything gets silent.

Maybe something essential will get revealed when this is examined?

Cheers
You do not have the required permissions to view the files attached to this post.
To be is to do — Socrates.
To do is to be — Jean-Paul Sartre.
Do be do be do — Frank Sinatra.

User avatar
jackoo
KVRian
720 posts since 3 Jul, 2006

Post Thu Sep 17, 2020 1:36 am

thanks a lot for your feedback.
I will try to investigate during the weekend!

User avatar
jackoo
KVRian
720 posts since 3 Jul, 2006

Post Sat Sep 19, 2020 8:09 am

Hi Per,

Ok, so this is what I think is happening.

When you click, or double click, or do something with your mouse, you might be changing the play-head cursor position in Reaper.
When the play-head cursor is moved in the MIDI editor, Reaper sends default (reset) values for all CCs which contain MIDI automation points.

For CC7, probably the default value is max. For other CCs the default value is 0. Zyn just catches these signals and modifies its volume accordingly.

Now there might be some settings / options in Reaper to disable this behavior, but I don't know this right now.
Maybe there's an option somewhere to choose whether to reset CCs or not, or with mouse modifiers.. I'm not sure at this moment. I'm not sure why Reaper does this.


When I try it, if I click in the notes area, the play head doesn't move, no CCs are sent.
If I click above the notes area, it changes the play head, and CCs with zero are sent, and the volume is being changed unwillingly (in your case with CC53 to zero).

Also, it's possible to scale the CC so that a 127 value doesn't max up the sound but puts it at say 70% or 80% (if you use the min/max values in the MIDI window). Or in the same way, when CC is zero, if the min is not zero, it could only reduce the volume to say 30% or 40%.

If Reaper keeps doing this with CCs, and we can't find a way to disable, maybe a workaround is using native automation lanes (instead of CC, use *, and the trim button).


Secondly, that is a really an amazing bass sound. Sounds as good as a sampled bass to me :)
You have really cool synthesis skills!

However, it seems that your FM modulator goes wild when the velocity is higher than 100.
But you could easily rescale how the velocity affects the modulator.
If I do the changes below, the bass sounds great both at low and high velocities.

Image

You can lower the velocity sensitivity by moving a little bit the slider (V.SNS) to the right.
First play with very high velocity notes (127). Adjust the Vol slider to where it is bright enough but it doesn't distort. Then play soft velocities. Adjust the velocity sensitivity slider to where the sound is soft enough in these low velocity ranges.

I found the values in the picture above to work nicely for my ears.


Thirdly, I think I found a bug with the automation (not related to this issue).
If a controlled is added to the parameter list (with the *) and the host changes it, when the host asks again it sees the old value. This can result in slider or knobs being stuck in the host even if they change the sound.
I'm working on a fix for that.

EDIT:
This should be better.
https://www.dropbox.com/s/s42fkumdm1v1r ... a.zip?dl=1
== VDX == One Man can make a difference!
My music is on http://soundcloud.com/vdxi

User avatar
per99
KVRist
197 posts since 5 Oct, 2017 from Närförort söder

Post Sat Sep 19, 2020 10:24 pm

jackoo wrote:
Sat Sep 19, 2020 8:09 am
If Reaper keeps doing this with CCs, and we can't find a way to disable, maybe a workaround is using native automation lanes (instead of CC, use *, and the trim button).
At first I thougt the native method was an uinconvenient way of doing it, which also occupies a larger area on the screen. But it's possible to hide those lanes and then show them again when you want to. So that's probably the method I'm going to use, although it would be great if control cc:s from the midi track would work as well.
jackoo wrote:
Sat Sep 19, 2020 8:09 am
However, it seems that your FM modulator goes wild when the velocity is higher than 100.
I made these settings this particular way deliberately. I have never played the bass guitar, but in my mind a bass player never uses all the force/power he has in his fingers. And a bass player using a keyborad and a synth bass instead would probably not do it either, since he knows it would ruin the whole concert. (We don't have compressors fast enough for live performances, do we?) And as I currently only use the mouse and the keyboard connected to my computer, the notes I jot down in the midi tracks are usually never below velocity 64 and never over 100, when it comes to the bass (because you only want to have a limited dynamics for the bass – right?).

However, in order for my zyn-bass to be possible to use for people who may want to use it in a live situation, or to use a midi keybord to make an audio recording on a computer, I would like to recommend a velo scaler instead of altering the settings. The screenshot shows a free scaler and the settings I use. The level of the volume acts as normal between velocity 0 – 94, but then, adding more pressure/power/velocity, makes the volume increase only a little bit, whereas the the timbre of the bass continues to get brighter all the way to velocity 127. (But if I post my zyn bass guitar on the presets/patches site, I will probably suggest that you can either use a scaler, or change the settings according to your proposal.)
You do not have the required permissions to view the files attached to this post.
To be is to do — Socrates.
To do is to be — Jean-Paul Sartre.
Do be do be do — Frank Sinatra.

User avatar
per99
KVRist
197 posts since 5 Oct, 2017 from Närförort söder

Post Sat Sep 19, 2020 10:27 pm

Just one more thing:

I happened to notice that the two .dll files in the zipped folder for v.519beta, which are named ZynAddSubFx.dll and ZynAddSubFx_16x.dll in the folder, are named differently when they show up in Reaper's list of available plugins. It could make you a little bit puzzeled, but I guess it's not a big deal (screenshot).

But I still don't understand what the purpose is with the 16x version. Because you cannot route different parts/instruments to different outputs of the zyn, can you? As far as I know the zyn has only one output – right?
You do not have the required permissions to view the files attached to this post.
To be is to do — Socrates.
To do is to be — Jean-Paul Sartre.
Do be do be do — Frank Sinatra.

User avatar
jackoo
KVRian
720 posts since 3 Jul, 2006

Post Sun Sep 20, 2020 2:26 am

Hi Per,
per99 wrote:
Sat Sep 19, 2020 10:27 pm
As far as I know the zyn has only one output – right?
Not exactly. The _16x dll actually has 17 physical outputs.
By default output 1 is used, which mixes the 16 parts.

In the MIDI windows (where you assign CCs) there is a check box "Multi Channel".
If this is ticked, output 1 is not used any more, it will be silent.
Output 2 will be routed to part 1 audio.
Output 3 to part 2, and so on, until output17 routed to part 16.
So this is an actual setup that can be used.

In Reaper, I suggest you only use the _x16 dll, since graphically Reaper doesn't bother you showing the outputs you are not using (not the same as in EnergyXT...).

The dll without the _16x, has only one physical output. If you activate the Multi Channel option it will likely crash. But this is more visually pleasing in EnergyXT, if I don't want to use a multichannel setup. So in your case you can just delete this dll and use the _16x one. Or rename the _16x to the other one (if your projects use the other one).

On a completely different note, coming back to the topic before:
I'm trying to find a workaround in Reaper for regular CCs.
One idea would be to use a midi plugin to filter the zero values sent by Reaper. I have MungRack in mind (this is a great free midi plugin by NicFit), but there are more. They are just old, and I'm not sure they are still around on the internet. Maybe I can ask in the Reaper forums, but they have to let me in first...
== VDX == One Man can make a difference!
My music is on http://soundcloud.com/vdxi

User avatar
jackoo
KVRian
720 posts since 3 Jul, 2006

Post Sun Sep 20, 2020 6:25 am

I found a fix for Reaper.

If you want to disable the "CC reset" globally you can do it in the options here:
Image
Untick those boxes

If you want to disable the "CC reset" just for the CCs you're using to automate volume you can assign "-1" for them as in this example:
Image

This works at least when I try it.

Cheers!
== VDX == One Man can make a difference!
My music is on http://soundcloud.com/vdxi

User avatar
per99
KVRist
197 posts since 5 Oct, 2017 from Närförort söder

Post Sun Sep 20, 2020 6:28 am

jackoo wrote:
Sun Sep 20, 2020 2:26 am
Not exactly. The _16x dll actually has 17 physical outputs.
Wow! Maybe this is mentioned somewhere in the documents? I wouldn't know, since I never, like most people, read manuals 8) Yes, sometimes I do!
jackoo wrote:
Sun Sep 20, 2020 2:26 am
I'm trying to find a workaround in Reaper for regular CCs.
Great! :)
To be is to do — Socrates.
To do is to be — Jean-Paul Sartre.
Do be do be do — Frank Sinatra.

Return to “ZynAddSubFX”