TrackSpacer - First plugin by Wavesfactory

VST, AU, etc. plug-in Virtual Effects discussion
KVRian
1128 posts since 11 Aug, 2004 from Breuillet, France

Post Sat Jun 02, 2018 1:27 am

virtualpt > just did a test at 48 kHz with PluginDoctor and Fabfilter Pro-Q with a bell filter, gain = 2.5 dB and Q = 2.571. I move a little the frequency control under 30 Hz, and I see what happens. Here we go with in order : 10 Hz, 10.834 Hz, 15.299 Hz, 18.504 Hz, 20.252 Hz (the only one looking right), 28.575 Hz.

Image

Image

Image

Image

Image

Image

Things get worse with a higher Q, if I just move a little any of the controls the frequency response switches from something right to one of these wrong things.

I can see the same behaviour even at 44.1 kHz, with low cutoff frequencies (< 30 Hz). And it just becomes nonsense at 96 kHz :)

It's just one filter here by the way. In Trackspacer, we got 30+ of them, and they all have high Q factors...

KVRist
138 posts since 26 Feb, 2016

Post Sat Jun 02, 2018 10:39 am

Ivan_C wrote:virtualpt > just did a test at 48 kHz with PluginDoctor and Fabfilter Pro-Q with a bell filter, gain = 2.5 dB and Q = 2.571. I move a little the frequency control under 30 Hz, and I see what happens. Here we go with in order : 10 Hz, 10.834 Hz, 15.299 Hz, 18.504 Hz, 20.252 Hz (the only one looking right), 28.575 Hz.

Things get worse with a higher Q, if I just move a little any of the controls the frequency response switches from something right to one of these wrong things.

I can see the same behaviour even at 44.1 kHz, with low cutoff frequencies (< 30 Hz). And it just becomes nonsense at 96 kHz :)

It's just one filter here by the way. In Trackspacer, we got 30+ of them, and they all have high Q factors...
Thanks Ivan, I tested with a flat response, so didn't see the same as this.

adl
KVRian
1244 posts since 26 Jun, 2005

Post Sun Jun 03, 2018 8:08 am

The sidechain tutorial for Ableton on the Wavesfactory side is wrong. I refer to this tutorial:
https://www.wavesfactory.com/kb/tracksp ... eton-live/

Here is explained how to do it by Ableton itself:
https://help.ableton.com/hc/en-us/artic ... ty-plug-in

This does make a huge difference, as the way it´s explained on the wavesfactory side does weird things, when you listen solo to a track in Ableton. The way it´s done in the Ableton tutorial doesn´t do that, listening solo to a track works just as it should. Maybe this helps someone, who uses Abelton as well.
proud to produce warezless!
Like Techhouse? Listen to my tracks here:
https://www.facebook.com/mister.adl

User avatar
KVRist

Topic Starter

371 posts since 12 May, 2010

Post Mon Jun 04, 2018 9:40 am

adl wrote:The sidechain tutorial for Ableton on the Wavesfactory side is wrong. I refer to this tutorial:
https://www.wavesfactory.com/kb/tracksp ... eton-live/

Here is explained how to do it by Ableton itself:
https://help.ableton.com/hc/en-us/artic ... ty-plug-in

This does make a huge difference, as the way it´s explained on the wavesfactory side does weird things, when you listen solo to a track in Ableton. The way it´s done in the Ableton tutorial doesn´t do that, listening solo to a track works just as it should. Maybe this helps someone, who uses Abelton as well.
Thanks! I'm going to change that right now and link to the official Ableton one.

adl
KVRian
1244 posts since 26 Jun, 2005

Post Mon Jun 04, 2018 10:32 am

wavesfactory wrote:
adl wrote:The sidechain tutorial for Ableton on the Wavesfactory side is wrong. I refer to this tutorial:
https://www.wavesfactory.com/kb/tracksp ... eton-live/

Here is explained how to do it by Ableton itself:
https://help.ableton.com/hc/en-us/artic ... ty-plug-in

This does make a huge difference, as the way it´s explained on the wavesfactory side does weird things, when you listen solo to a track in Ableton. The way it´s done in the Ableton tutorial doesn´t do that, listening solo to a track works just as it should. Maybe this helps someone, who uses Abelton as well.
Thanks! I'm going to change that right now and link to the official Ableton one.
The way it´s described on your homepage isn´t really "wrong", it´s more of a workaround, when you don´t want to use another track which is basically just used for the routing. So both ways it can be achieved to trigger Trackspacer. :)
proud to produce warezless!
Like Techhouse? Listen to my tracks here:
https://www.facebook.com/mister.adl

KVRer
26 posts since 22 Jul, 2017

Post Thu Jul 19, 2018 5:15 pm

I emailed them asking if I could demo the original version, pre-2.5, which is listed as "obsolete" on their site. They just wrote me back advising to try the demo again; no other info. Not sure really sure what they meant or changed, if anything..

KVRer
1 posts since 23 Jan, 2018

Post Sun Jul 22, 2018 7:45 pm

AUTO-ADMIN: Non-MP3, WAV, OGG, SoundCloud, YouTube, Vimeo, Twitter and Facebook links in this post have been protected automatically. Once the member reaches 5 posts the links will function as normal.
adl wrote:The sidechain tutorial for Ableton on the Wavesfactory side is wrong. I refer to this tutorial:
https://www.wavesfactory.com/kb/tracksp ... eton-live/

Here is explained how to do it by Ableton itself:
https://help.ableton.com/hc/en-us/artic ... ty-plug-in (https://help.ableton.com/hc/en-us/articles/209775325-Sidechaining-a-3rd-party-plug-in)

This does make a huge difference, as the way it´s explained on the wavesfactory side does weird things, when you listen solo to a track in Ableton. The way it´s done in the Ableton tutorial doesn´t do that, listening solo to a track works just as it should. Maybe this helps someone, who uses Abelton as well.
Thanks for this, it's a much better way of working and saves issues with changing two channels whenever you need to tweak something.

User avatar
KVRist

Topic Starter

371 posts since 12 May, 2010

Post Fri Aug 24, 2018 2:18 am

Hi guys,

Trackspacer has been updated to version 2.5.3 with these changes:

- Fixed: serial number doesn’t accept extra characters other than numbers and dashes in order to avoid unwanted inputs that end in serials not being validated.
- Fixed: freeze parameters correctly recalled.
- Fixed: spectrum analyser behaviour in Pro Tools when initialising the plug-in.
- Improved: on an invalid serial input the plug-in will show a popup.
- Improved: attack and release ballistics.

Download here:
Mac: https://trackspacer-wavesfactory.s3.ama ... 02.5.3.pkg
Windows: https://trackspacer-wavesfactory.s3.ama ... 02.5.3.exe

KVRer
2 posts since 6 Dec, 2011 from France

Post Sun Aug 26, 2018 12:42 pm

How does it compare to a dynamic eq like bx_dynEQ using the external sidechain ? It is not multiband but with an appropriate Q you can adress the frequency issue more or less in the same way ?

User avatar
KVRAF
1875 posts since 16 May, 2004 from Soviet Union

Post Sun Aug 26, 2018 2:15 pm

wavesfactory wrote:Hi guys,

Trackspacer has been updated to version 2.5.3 with these changes:

- Fixed: serial number doesn’t accept extra characters other than numbers and dashes in order to avoid unwanted inputs that end in serials not being validated.
- Fixed: freeze parameters correctly recalled.
- Fixed: spectrum analyser behaviour in Pro Tools when initialising the plug-in.
- Improved: on an invalid serial input the plug-in will show a popup.
- Improved: attack and release ballistics.

Download here:
Mac: https://trackspacer-wavesfactory.s3.ama ... 02.5.3.pkg
Windows: https://trackspacer-wavesfactory.s3.ama ... 02.5.3.exe
Thanks for update, tried, very interesting version.

But found strange issue with old v2.05 installer. Just decided uninstall all and install again from scratch, so, install v2.05 first (сhose only vst2 64bit) and found that can't open plugin in daw by some reason, though dll recognize by DAW properly, and appear in plugins list, but after attempt to load plugin appeared just empty daw track without anything. Frankly, first time see such behavior with daw\plugs. Then uninstall v2.05 and tried install again but chose only vst3 64bit, so - was installed anyway both vst3 and vst2 versions, and vst2 again the same issue, but vst3 open properly.

As well noticed that new v2.5 installer replace v2.05 in windows "programs and features" (win7), that not very good if there is plan to use both versions.

Maybe somehow can improve this both moments? Ie make some fix for 2.05 installer maybe.

KVRAF
6400 posts since 5 Aug, 2009

Post Thu Aug 30, 2018 10:26 am

c_voltage wrote:
wavesfactory wrote:Hi guys,

Trackspacer has been updated to version 2.5.3 with these changes:

- Fixed: serial number doesn’t accept extra characters other than numbers and dashes in order to avoid unwanted inputs that end in serials not being validated.
- Fixed: freeze parameters correctly recalled.
- Fixed: spectrum analyser behaviour in Pro Tools when initialising the plug-in.
- Improved: on an invalid serial input the plug-in will show a popup.
- Improved: attack and release ballistics.

Download here:
Mac: https://trackspacer-wavesfactory.s3.ama ... 02.5.3.pkg
Windows: https://trackspacer-wavesfactory.s3.ama ... 02.5.3.exe
Thanks for update, tried, very interesting version.

But found strange issue with old v2.05 installer. Just decided uninstall all and install again from scratch, so, install v2.05 first (сhose only vst2 64bit) and found that can't open plugin in daw by some reason, though dll recognize by DAW properly, and appear in plugins list, but after attempt to load plugin appeared just empty daw track without anything. Frankly, first time see such behavior with daw\plugs. Then uninstall v2.05 and tried install again but chose only vst3 64bit, so - was installed anyway both vst3 and vst2 versions, and vst2 again the same issue, but vst3 open properly.

As well noticed that new v2.5 installer replace v2.05 in windows "programs and features" (win7), that not very good if there is plan to use both versions.

Maybe somehow can improve this both moments? Ie make some fix for 2.05 installer maybe.
any news Wavesfactory?
DAW FL Studio Audio Interface Focusrite Scarlett 1st Gen 2i2 CPU Intel i7-7700K 4.20 GHz, RAM 32 GB Dual-Channel DDR4 @2400MHz Corsair Vengeance. MB Asus Prime Z270-K, GPU Gainward 1070 GTX GS 8GB NT Be Quiet DP 550W OS Win10 64Bit

User avatar
KVRAF
1875 posts since 16 May, 2004 from Soviet Union

Post Thu Aug 30, 2018 11:00 am

Caine123 For just in case - my current temporary solution looks as: install first 2.05 (chose vst3), then install v2.5.3 (vst3 too)
Then just remove any vst2 versions which could been installed.
Now, DAW should see and open properly vst3 of both versions, without any "ghosts".
Last edited by c_voltage on Thu Aug 30, 2018 11:01 am, edited 1 time in total.

KVRAF
6400 posts since 5 Aug, 2009

Post Thu Aug 30, 2018 11:01 am

c_voltage wrote:Caine123 For just in case - my current temporary solution looks as: install first 2.05 (chose vst3), then install v2.5.3
Then just remove any vst2 versions which could been installed.
Now, DAW should see and open properly vst3 of both versions, without any "ghosts".
thx a lot! i still use vst2 though :/
DAW FL Studio Audio Interface Focusrite Scarlett 1st Gen 2i2 CPU Intel i7-7700K 4.20 GHz, RAM 32 GB Dual-Channel DDR4 @2400MHz Corsair Vengeance. MB Asus Prime Z270-K, GPU Gainward 1070 GTX GS 8GB NT Be Quiet DP 550W OS Win10 64Bit

User avatar
KVRAF
1875 posts since 16 May, 2004 from Soviet Union

Post Thu Aug 30, 2018 11:08 am

Caine123 wrote:
c_voltage wrote:Caine123 For just in case - my current temporary solution looks as: install first 2.05 (chose vst3), then install v2.5.3
Then just remove any vst2 versions which could been installed.
Now, DAW should see and open properly vst3 of both versions, without any "ghosts".
thx a lot! i still use vst2 though :/
Usually, i prefer vst2 too (if there is option in installer). But, here just other case (for use both).

KVRAF
6400 posts since 5 Aug, 2009

Post Thu Aug 30, 2018 11:10 am

i hope wavesfactory sorts it out ;D
DAW FL Studio Audio Interface Focusrite Scarlett 1st Gen 2i2 CPU Intel i7-7700K 4.20 GHz, RAM 32 GB Dual-Channel DDR4 @2400MHz Corsair Vengeance. MB Asus Prime Z270-K, GPU Gainward 1070 GTX GS 8GB NT Be Quiet DP 550W OS Win10 64Bit

Return to “Effects”