Amplitube5 - Release Date 15-16/12/2020

VST, AU, etc. plug-in Virtual Effects discussion
KVRian
1144 posts since 27 May, 2008

Post Mon Dec 28, 2020 1:38 pm

Yeah it needs a scrollbar on equipment routing window

KVRist
243 posts since 8 Feb, 2009

Post Mon Dec 28, 2020 2:13 pm

Yep, same here, the right end of the FX chain disappears.

Seems promising, with some tweaks.

I can live with the two mono amps on the stereo chain and the copy/paste routine since it has stereo stompboxes, HOWEVER this feature was sabotaged by ways of limiting those stereo stompboxes to only... 3. :dog:

KVRist
243 posts since 8 Feb, 2009

Post Mon Dec 28, 2020 2:31 pm

Peter replied on the IK forum the mousewheel scrolls the FX chain.

User avatar
KVRian
662 posts since 2 Sep, 2019

Post Tue Dec 29, 2020 1:51 am

The problem with using the mouse wheel to scroll is a) not everyone has one, and b) when you scroll the stomp box section, the mouse wheel will grab pedals and start changing them as you scroll, especially wah and volume pedals. It ends up screwing up your carefully calibrated “Woman” tone.
THIS MUSIC HAS BEEN MIXED TO BE PLAYED LOUD SO TURN IT UP

User avatar
KVRian
662 posts since 2 Sep, 2019

Post Tue Dec 29, 2020 1:54 am

Another GUI bug:

The EQ81 mic and line buttons are switched. Line engages the preamp, instead of mic.
THIS MUSIC HAS BEEN MIXED TO BE PLAYED LOUD SO TURN IT UP

User avatar
KVRist
107 posts since 28 Mar, 2007 from Scotland

Post Tue Dec 29, 2020 3:26 pm

Enjoying the CS update from AT4 more than expected, being able to resize and hide things we don't own is a welcome bonus. Although for some reason from the 11 packs I own it still lists some presets that load fine when selecting the mode to view things I don't own? To have so many packs showing presets with gear I don't have still seems strange to me, can't help but think it should all be included for people buying packs, that would be appreciated if it can be added. Some presets even requiring a full update are pretty off-putting. Also T-Racks things we own would be good if the versions of them and mics were available in AT5, I'd certainly be more inclined to upgrade to a paid version of AT5 if that happened.
Nova II, FL20+Fire, Sytrus, Transistor Bass, DUNE 3, Thorn, Viper, ANA 2 SynthMaster, Discovery Pro, Reason, SugarBytes, SoundToys, LION, TRIAD, Plugin-Alliance, T-Racks, AmpliTube, MODO Drum/Bass, iZotope MPS 2.
One Day: FLEXXX, Alpha Forever, Diversion 2

User avatar
KVRian
662 posts since 2 Sep, 2019

Post Tue Dec 29, 2020 4:56 pm

Is it just me, or do the phase switches on the BUS channels not do anything? :scared:

I can null identical dual cab setups with the phase switches on MIC 1 and MIC 2, but when I try it with the BUS phase switch, nothing happens at all.
THIS MUSIC HAS BEEN MIXED TO BE PLAYED LOUD SO TURN IT UP

KVRian
835 posts since 28 Jan, 2008

Post Tue Dec 29, 2020 11:16 pm

Anyone else getting frequent lag in the DAW when Amplitube is open? I'm not sure if it's because I'm demoing some modules, but my entire DAW will freeze for 5 or so seconds at a time when the Amplitube 5 window is open, particularly when tweaking parameters.

KVRian

Topic Starter

537 posts since 31 May, 2008 from Australia

Post Wed Dec 30, 2020 12:43 am

No

KVRAF
8266 posts since 16 Aug, 2006

Post Wed Dec 30, 2020 5:28 am

xphen0m wrote:
Tue Dec 29, 2020 11:16 pm
Anyone else getting frequent lag in the DAW when Amplitube is open? I'm not sure if it's because I'm demoing some modules, but my entire DAW will freeze for 5 or so seconds at a time when the Amplitube 5 window is open, particularly when tweaking parameters.
Got that on my Windows laptop in Reaper. Was pretty bad.

KVRian
835 posts since 28 Jan, 2008

Post Wed Dec 30, 2020 7:43 am

Funkybot's Evil Twin wrote:
Wed Dec 30, 2020 5:28 am
Got that on my Windows laptop in Reaper. Was pretty bad.
It's happening to me in Cubase 11 (I forgot to mention that part). I'm curious if I should open a ticket.

KVRAF
8266 posts since 16 Aug, 2006

Post Wed Dec 30, 2020 7:45 am

xphen0m wrote:
Wed Dec 30, 2020 7:43 am
Funkybot's Evil Twin wrote:
Wed Dec 30, 2020 5:28 am
Got that on my Windows laptop in Reaper. Was pretty bad.
It's happening to me in Cubase 11 (I forgot to mention that part). I'm curious if I should open a ticket.
Sure, go for it! Never hurts to report issues to support.

You running a laptop? Desktop? I'm on a very slow Dell that's going to get replaced by a Macbook Pro as soon as they announce the M1X 16" MBP's. So not going to bother reporting this on my side since it struggles to run many plugins with nothing else happening.

KVRian
835 posts since 28 Jan, 2008

Post Wed Dec 30, 2020 7:51 am

Funkybot's Evil Twin wrote:
Wed Dec 30, 2020 7:45 am


You running a laptop? Desktop? I'm on a very slow Dell that's going to get replaced by a Macbook Pro as soon as they announce the M1X 16" MBP's. So not going to bother reporting this on my side since it struggles to run many plugins with nothing else happening.
I'm running on a PC with an i7 3770, and dedicated GPU with 32 GB memory and it does this way too much in certain instances.

KVRAF
3161 posts since 25 Jan, 2007

Post Wed Dec 30, 2020 8:20 am

Just tried CS. I can't get any sound out of standalone (its routed correctly, all the meters waggle but no audio).

Quite like the new UI in the vst version, and browsing is more slick. I currently have 4 Max, so there's a good amount of stuff that shows up. Aside from new amps etc, what else am I missing as compared to the regular full version?
http://www.guyrowland.co.uk
http://www.sound-on-screen.com
W10, i7 7820X, 64gb RAM, RME Babyface, 1050ti, PT 2019 Ultimate, Cubase Pro 10.5
MBP 2015 OSX 10.13.3 2.8ghz 16gb 1TB SSD

User avatar
KVRian
662 posts since 2 Sep, 2019

Post Wed Dec 30, 2020 1:47 pm

Another graphics issue:
The orange and red channel lights on Satch VM look the same. Maybe they're not the same colour exactly, but the difference is too subtle to be able to tell which channel mode is selected. This wasn't a problem in AT4.

Also: the white rack Parametric EQ kills AmpliTube when inserted into the Loop FX.
THIS MUSIC HAS BEEN MIXED TO BE PLAYED LOUD SO TURN IT UP

Return to “Effects”