Tablet 2 MIDI - Bugs thread

Official support for: livelab.dk
lung
KVRist
326 posts since 23 Apr, 2003

Post Thu Apr 13, 2006 10:06 am

ohm wrote:update: the VST crash on close bug has been fixed, and a new version 0.93 is available / has been sent to registered customers.
Thanks for fixing this ohm! Works perfectly now.
Cheers

hansvr
KVRer
12 posts since 6 Jun, 2004

Post Sat Apr 15, 2006 2:49 am

Hello ohm,

The Speed controller behaves very erratically in version 0.93. It seems to produce values only once in a while.
However there is no problem in version 0.74 (the last beta I saved).

ohm
KVRAF
1513 posts since 2 Jul, 2004

Post Tue Apr 18, 2006 1:28 am

hansvr wrote:Hello ohm,

The Speed controller behaves very erratically in version 0.93. It seems to produce values only once in a while.
However there is no problem in version 0.74 (the last beta I saved).
thanks, I'll take a look at it
http://www.livelab.dk - slice up your life

benjamind
KVRian
1023 posts since 4 Aug, 2004 from Ain't tellin' ya...

Post Fri May 12, 2006 7:06 am

Is it possible to have a pitchbend like controller where the value goes back to the standard pitch when the finger is released?
Little Black Dog - 2008-Present

User avatar
SyntheticAurality
KVRAF
8969 posts since 3 Apr, 2002 from Austin, TX USA

Post Wed May 17, 2006 1:06 pm

benjamind wrote:Is it possible to have a pitchbend like controller where the value goes back to the standard pitch when the finger is released?
+1 on this, I'd love to have that kind of a control!!! :D

nis
KVRer
27 posts since 31 Jan, 2003

Post Mon Aug 21, 2006 1:21 pm

I have been trying this tonight, and I like the concept very much. But I have a serious problem using it with my left-handed mouse: the program reponds to mouse clicks in a very weird way: to get a "left click" (for dragging or resizing, or for using the buttons in the top left of the screen), I have to press both mouse buttons quickly one after the other, otherwise it doesn't do anything. And even weirder: in the "drawing area", I have to press the left button first, but to use the buttons in the top left corner, I have to push the right button first :?. Right-click and doubleclick seem to work normally. When I switch to right-handed mode, all is fine.

I am using a Wacom Penpartner tablet with an Asus laptop with a Synaptics touchpad and a Trust cordless mouse. When I set the mouse to left-handed mode, both the mouse and the touchpad show this behavior, it doesn't matter if I set the touchpad to left- or right-handed mode.

ohm
KVRAF
1513 posts since 2 Jul, 2004

Post Mon Aug 21, 2006 1:47 pm

nis wrote:I have been trying this tonight, and I like the concept very much. But I have a serious problem using it with my left-handed mouse: the program reponds to mouse clicks in a very weird way: to get a "left click" (for dragging or resizing, or for using the buttons in the top left of the screen), I have to press both mouse buttons quickly one after the other, otherwise it doesn't do anything. And even weirder: in the "drawing area", I have to press the left button first, but to use the buttons in the top left corner, I have to push the right button first :?. Right-click and doubleclick seem to work normally. When I switch to right-handed mode, all is fine.

I am using a Wacom Penpartner tablet with an Asus laptop with a Synaptics touchpad and a Trust cordless mouse. When I set the mouse to left-handed mode, both the mouse and the touchpad show this behavior, it doesn't matter if I set the touchpad to left- or right-handed mode.
That bug has been fixed and an update will be ready soon
http://www.livelab.dk - slice up your life

acousmod
KVRist
421 posts since 27 Jan, 2004 from France

Post Mon Sep 25, 2006 12:56 pm

Hi,

It appears to be very strange things with the 0.94 version :
Is there a mirror mode (mouse mode) ??

The controller zone has been covered with oblic lines and all the movements are verticaly mirrored (the crosshair follows inverted movements in comparison to the mouse cursor).
After restarting T2M the lines remain (excepted a white rectangle area) and the movements are always inverted now, with new or old patches...

Any idea ?

spritex
KVRian
845 posts since 4 Apr, 2001 from Finland

Post Sat Oct 07, 2006 12:45 pm

I just downloaded the Tablet2Midi demo. I don't yet have any tablet, but tested it anyway in energyXT. Is the "mouse mode" (caps lock) supposed to send values just by moving the mouse, or am I mixing things up?

I can't seem to make it to send any values to synths connected after it in eXT.
Logic - Geist - U-He - NI Komplete 6 - Korg LAE 2007

ingredient t
KVRer
15 posts since 15 Dec, 2005

Post Wed Nov 01, 2006 12:54 pm

I don't know whether or not this can rightly be called a "bug," but I notice when I use the Relative Binary Offset mode with Reaktor it's not possible to have fine control over parameters.

For example, if I create a knob with a range of 0-1000, and set the stepsize to one, I should have 1000 possible steps to choose from, right? Well, using the mouse I can step from 0 to 1 to 2 all the way up to 1000. However, if I try to use Tab2MIDI instead it steps through the values in increments of 8... 0, 8, 16, 24, etc. Which is pretty close to the 7-bit resolution I am trying to surpass.

Perhaps this is a problem with how Reaktor handles Relative MIDI commands, but if there is anything that can be done to fix it I would be most pleased.

Hannes_F
KVRist
175 posts since 17 Aug, 2006

Post Thu Jan 11, 2007 9:43 am

acousmod wrote:Hi,

It appears to be very strange things with the 0.94 version :
Is there a mirror mode (mouse mode) ??

The controller zone has been covered with oblic lines and all the movements are verticaly mirrored (the crosshair follows inverted movements in comparison to the mouse cursor).
After restarting T2M the lines remain (excepted a white rectangle area) and the movements are always inverted now, with new or old patches...

Any idea ?
This happens when you messed up the calibration. Try to calibrate again. I personally ignore the printout and just type into the edges of the field.

Hannes
Maybe doing jokes without the use of smilies ...

L64Science
KVRer
1 posts since 6 Aug, 2007

Post Mon Aug 06, 2007 12:11 pm

Tablet2Midi v0.940 does not seem to be compatible with my Toshiba M200 Portege Tablet PC. Program displays GUI, states "WinTab driver could not be loaded - running in mouse mode". I have checked to see if I'm Wacom penabled and I am. I have WinXP SP2. The program runs as a useless empty dialog box. Right-clicking does nothing and the menu buttons don't work. Let me know if there's anymore information you need to fix this. I'm eager to try your program. Cheers!

-Art

The_Defend
KVRer
1 posts since 15 Sep, 2007

Post Fri Sep 14, 2007 11:18 pm

I just bought Tablet2Midi and while using a small touchscreen monitor as my input device I appreciate it a lot. I am using mouse mode as with the mentioned display there is no tablet mode available.

Changing values by using sliders and the xy-pads works like charm the only problem is that I don't seem to get those buttons to work - at least the way I expect them to: There seems no way to get a midi message to be fired on a simple mouse click or mouse down event.

I have tried out different parameter settings in the buttons context menu but all I am getting to work is the button reacting on mouse move events when activating the second control. I guess this is a special thing concerning mouse mode but unfortunatly I do not have the opportunity to crosscheck against tablet mode.

Any suggestions?

ohm
KVRAF
1513 posts since 2 Jul, 2004

Post Sat Sep 15, 2007 2:24 am

The_Defend wrote:I just bought Tablet2Midi and while using a small touchscreen monitor as my input device I appreciate it a lot. I am using mouse mode as with the mentioned display there is no tablet mode available.

Changing values by using sliders and the xy-pads works like charm the only problem is that I don't seem to get those buttons to work - at least the way I expect them to: There seems no way to get a midi message to be fired on a simple mouse click or mouse down event.

I have tried out different parameter settings in the buttons context menu but all I am getting to work is the button reacting on mouse move events when activating the second control. I guess this is a special thing concerning mouse mode but unfortunatly I do not have the opportunity to crosscheck against tablet mode.

Any suggestions?
I'll investigate - not using mouse mode myself so there could very well be a bug there.
http://www.livelab.dk - slice up your life

philipc
KVRist
80 posts since 16 Feb, 2007

Post Sat Dec 29, 2007 1:40 pm

I'm just trying to set up the free version of Tablet 2 Midi and it doesn't work very well. F4 and F5 don't do anything which makes it difficult to switch back and forth between transparent and opaque. When running the standalone version when you switch back to opaque all the white areas become black so you can't see anything. Also the standalone version won't save.

When it comes to actually trying to play what you've set up, and this may just be my lack of understanding here, nothing happens. In the plugin version I can save each shape as I make it but the only way I can make anything happen is to click on the saved file, which sends a constant midi note that doesn't shut off until you restart the plugin.

I'm not sure how the tablet is supposed to be configured. I installed the drivers and now it operates just like a mouse. I suppose thats correct, it doesn't say otherwise anywhere else. When the pen isn't near the pad the "wintab driver could not be found - running in mouse mode" message is there. I don't know if this is a problem or not. Maybe i'm just thick but I can't seem to figure any of this stuff out.

I'm not sure if development is still going on with this but nevertheless, i'm running a Macbook 1.83ghz under bootcamp with Windows XP Pro SP2. Host for plugin: Ableton Live. Tablet type: Trust TB-3100.

Return to “Livelab.dk”