Tablet 2 MIDI - Bugs thread

Official support for: livelab.dk
pardonfactory
KVRer
6 posts since 11 Dec, 2005 from Melbourne, Australia

Post Fri Mar 17, 2006 8:06 pm

lung wrote:I just downloaded 0.800, and when creating a slider, the type defaults to 'off' on all parameters. I like this, except that if I try to change the type, the program instantly crashes.. empty log file.
I have the exact same problem. They're also not actually off at all, I can create a new slider and it will send all of them, tilt, pressure, etc, despite saying they're turned off. This makes it difficult to use MIDI mapping in Live, as Live uses the last received parameter.

Eska
KVRist
48 posts since 7 Jun, 2005 from Austria

Post Sat Mar 18, 2006 1:52 am

Same here.

ohm
KVRAF
1513 posts since 2 Jul, 2004

Post Sat Mar 18, 2006 2:13 am

bug has been fixed, v.0.81 available for download

do you think it would be better if only one parameter was on when creating a new slider? Then you'd have to turn all parameters on later, or perhaps most of the time you'll just want the position sent anyways? Opinions please

I'm aware of the "auto mapping problem" when sending 3 or 6 parameters from the same controller - perhaps this can be solved in a better way - I'm thinking I could add a solo button in the Controller configuration box so you could quickly send only one parameter at a time.
http://www.livelab.dk - slice up your life

Eska
KVRist
48 posts since 7 Jun, 2005 from Austria

Post Sat Mar 18, 2006 7:19 am

No crashes anymore, but can't get the string mode to work. Under pressure inside/outside detection triggers randomly,
Under speed I get multiple triggers, where speed seems to be routed to note number.

ohm
KVRAF
1513 posts since 2 Jul, 2004

Post Sat Mar 18, 2006 7:25 am

I agree string mode setup it's a bit confusing as it is - You have to disable the speed parameter - string mode uses both speed and pressure to set the velocity, but it's defined under pressure only.

Then to trigger you have to move the pen across the button like you would a plectrum on a string - it works, but I agree not very well...
http://www.livelab.dk - slice up your life

lung
KVRist
326 posts since 23 Apr, 2003

Post Sat Mar 18, 2006 8:33 am

Thanks ohm, 0.810 stops the crashing. Tilt & Angle work. Rotate, Tangent, Z-Pos do not on my Intuos 1 .. beta 0.810. They have not worked on any beta though. I wonder if they are for the mouse/puck thing that you could buy for the Intuos1. Cheers.

comfy
KVRer
9 posts since 4 May, 2005

Post Tue Mar 28, 2006 9:34 am

Ok..... Ive got BIG problems with the VST version. I carnt get it working.! I put the .dll file in my vst folder and loaded up Bidule. Once its loaded the buttons on my mouse wont work. I can move the cursor but not select anything at all. So I closed bidule and did a reboot and loaded up again. This time it hung on the startup screen. So again did a restart and this time decided to load up LIVE 5. Which unfortunatly didnt work either. The "LIVE has experienced a problem and will be shut down" screen poped up before it could even load properly. So removed the tab2mid.dll from a vst folder and everthing was back to normal. I'm guessing here but I think both Bidule and Live scan (and maybe test?) new VST's on start up. Could there be a problem there?

I'm not to bothered about it really.. didnt even know there was a VST version going until yesterday! Although chosing different tablet layouts via program change would be great.

EDIT: ok.... thought I'd give it a go in good ol' faithful fruity loops, and it doesnt work in there either! Floops instantly shuts down after I load in Tab2mid. BTW im using a Wacom Volito2 pad just incase that helps

ohm
KVRAF
1513 posts since 2 Jul, 2004

Post Tue Mar 28, 2006 9:50 am

hmm I guess we should consider the VST version in alpha state then :-( I think you are the fist to try it besides me, and I only tested in energy XT.

It's probably a simple bugfix - in the meantime use the standalone version please.
http://www.livelab.dk - slice up your life

comfy
KVRer
9 posts since 4 May, 2005

Post Tue Mar 28, 2006 9:55 am

Haha no worries mate..... glad to help out!

ohm
KVRAF
1513 posts since 2 Jul, 2004

Post Tue Mar 28, 2006 11:40 am

good news - problem was not as bad as I thought. Should be fixed now, tested in the Live, Bidule, FL, Cubase demos.

Tip of the day:
You can now purchase Tablet 2 MIDI in the LiveLab.dk shop.
Lots of changes recently - get it while it's hot (and cheap at a friendly introduction price).
Read about the new stuff here.
http://www.livelab.dk - slice up your life

comfy
KVRer
9 posts since 4 May, 2005

Post Tue Mar 28, 2006 12:40 pm

Hi again!
Thanks for the mega quick update. The VST version loads up fine now.... BUT:
(applies to VST version ONLY, using LIVE and Bidule)
1) theres no midi output when VST midi is selected as the output (virtual cables still work)
2) it tends to crash the host if the main Table2Midi window is closed using the red cross (standard windows close button)
3) window transparency feature seems a bit bugged

A few more questions though:
I take it that only one instance of Tablet2Midi VST should be loaded? I tried 2 but didnt seem to work. Only one was controlable.
Is there a way to change between saved layouts via midi (program change etc)?

Sweet.... now thats out the way, Im off to set up some new layouts now that I can save more than 2 controllers! YAY

Improv
KVRAF
1950 posts since 21 Mar, 2003 from Labrador

Post Tue Mar 28, 2006 3:32 pm

ohm wrote:good news - problem was not as bad as I thought. Should be fixed now, tested in the Live, Bidule, FL, Cubase demos.

Tip of the day:
You can now purchase Tablet 2 MIDI in the LiveLab.dk shop.
Lots of changes recently - get it while it's hot (and cheap at a friendly introduction price).
Read about the new stuff here.

Does your Wacom tablet support now include the ability to use the Wacom Grafire4 mouse (as well as the pen) instead of needing a seperate mouse (something which I am NOT interested in doing for one program only). I had previously mentioned to you that a hot key 'breakout' might be useful.

Cheers

User avatar
fabi
KVRAF
1702 posts since 1 Jun, 2003

Post Tue Mar 28, 2006 4:13 pm

ohm wrote:good news - problem was not as bad as I thought. Should be fixed now, tested in the Live, Bidule, FL, Cubase demos.

Tip of the day:
You can now purchase Tablet 2 MIDI in the LiveLab.dk shop.
Lots of changes recently - get it while it's hot (and cheap at a friendly introduction price).
Read about the new stuff here.
great news - will purchase as soon as i can afford to. :)

lung
KVRist
326 posts since 23 Apr, 2003

Post Tue Mar 28, 2006 4:51 pm

VST version 0.910 is crashing in energyXT latest version (standalone) using Intuos1, when closing the Tablet2Midi interface:
Exception EAccess Violation in module standalone.exe at 02531A39.
Access violation at address 02532A39. Read of address 02532A39.
Tablet2Midi standalone does not crash, nor does Tracktion1 (as far as I've tested). The second-last beta of energyXT was when unfocusing the window, the latest does not seem to, just when closing the window. Let me know if you need any more info. Thanks :)

Improv
KVRAF
1950 posts since 21 Mar, 2003 from Labrador

Post Wed Mar 29, 2006 10:14 am

Improv wrote:
ohm wrote:good news - problem was not as bad as I thought. Should be fixed now, tested in the Live, Bidule, FL, Cubase demos.

Tip of the day:
You can now purchase Tablet 2 MIDI in the LiveLab.dk shop.
Lots of changes recently - get it while it's hot (and cheap at a friendly introduction price).
Read about the new stuff here.

Does your Wacom tablet support now include the ability to use the Wacom Grafire4 mouse (as well as the pen) instead of needing a seperate mouse (something which I am NOT interested in doing for one program only). I had previously mentioned to you that a hot key 'breakout' might be useful.

Cheers
Bump!

Return to “Livelab.dk”