LiveSlice 1.47 beta thread

Official support for: livelab.dk
ohm
KVRAF
1513 posts since 2 Jul, 2004

Post Sun Mar 16, 2008 1:39 pm

Click problem solved (stupid bug). Thank you all for posting - your comments did help a lot tracking down this one.

I tested the latest build at all buffer sizes and it runs great at all buffer sizes (32 samples to 4096 samples) on my RME Hammerfall. I'm sending out RC7 now. Please let me know if that has any problems. I'll be away for the next week on vacation - I'll try to get Internet access, but I'm not sure it'll be possible, so all you regular supporters please keep an eye on the forums if possible :-) Thanks.
http://www.livelab.dk - slice up your life

ohm
KVRAF
1513 posts since 2 Jul, 2004

Post Sun Mar 16, 2008 1:47 pm

kminardi wrote:Under win xp64 LiveSlice 1.47 RC6 crashes Cubase Studio 4(latest 4.1.3) with the "serious error" and "save under another name and restart Cubase" and "if persist send Cubase.log file". Now I have been playing live lately and must admit the releases have been coming quickly so I will investigate more. I quickly ran Phrazor and LS was fine. Just an FYI post--short on details. Thanks Ohm.

Thanks - I removed some of the runtime checks as I suspected they were responsible for the clicks - please try the latest RC7 build in that Cubase Studio of yours if possible. And please try hard to crash it even if it seems to run fine. Hit it hard with midi controllers, lots of tracks, detunes and the works. Reproducable crashes are really worth a lot to me at this point.
http://www.livelab.dk - slice up your life

User avatar
Architeuthis
KVRAF
2960 posts since 28 Jan, 2006 from Phoenix, AZ

Post Sun Mar 16, 2008 2:52 pm

Thank you Ohm, clicks fixed! Now I can re-render my latest project.

ohm
KVRAF
1513 posts since 2 Jul, 2004

Post Mon Mar 17, 2008 2:28 am

Architeuthis wrote:Thank you Ohm, clicks fixed! Now I can re-render my latest project.

Thanks for confirming... now off to add an easter egg to LiveSlice :?:
http://www.livelab.dk - slice up your life

DarkStar
KVRAF
8542 posts since 2 Sep, 2003 from Surrey, UK

Post Mon Mar 17, 2008 3:06 am

[b147 rc7]
Yep, these three BRs are fixed:

BR 117 - Slice info not saved to file (after dragging the [Sensitivity] slider or clicking it)
BR 116 - Changing slices using Sensitivity does not update Arrangements
BR 113 - Repositioning to middle in Loops section (when a loop slot is selected)
DarkStar
Interesting, if true ...

Optomadic
KVRAF
6125 posts since 18 Oct, 2007

Post Mon Mar 17, 2008 8:38 am

ohm wrote:now off to add an easter egg to LiveSlice :?:
:hihi:
Image
stay juicy!

Trip-
KVRer
18 posts since 15 Oct, 2003

Post Wed Mar 19, 2008 10:14 pm

Another major bug for me with the last beta,
I saved a project with liveslice, reopened the project - and liveslice was completely in a mess.
volume settings were messed up although i never touched those.
stretch, reverse, midi 1, midi 2, every setting was messed up in some way.

Watch out for that one.

And still, the file browser is showing directories sorted by modified date, not by ABC name.

cheers
Interesting job...

DarkStar
KVRAF
8542 posts since 2 Sep, 2003 from Surrey, UK

Post Thu Mar 20, 2008 4:49 am

@ Trip-
Can you let us know some more info:
- which host are you using?
- can you try the same in another host?
- which OS are you using?
DarkStar
Interesting, if true ...

Trip-
KVRer
18 posts since 15 Oct, 2003

Post Fri Mar 21, 2008 11:10 pm

Host is Logic 5.51 I mentioned earlier.

I don't have any other host, so I can't try it unfortunately.

I'm using windows XP.
Interesting job...

ohm
KVRAF
1513 posts since 2 Jul, 2004

Post Wed Mar 26, 2008 5:21 am

Trip- wrote:Another major bug for me with the last beta,
I saved a project with liveslice, reopened the project - and liveslice was completely in a mess.
volume settings were messed up although i never touched those.
stretch, reverse, midi 1, midi 2, every setting was messed up in some way.

Watch out for that one.

And still, the file browser is showing directories sorted by modified date, not by ABC name.

cheers


Have you checked your midi controller configuration? It sounds like you may have some midi controllers set up to randomize the parameters and that got triggered when you reloaded the project. Please check the midi controllers at the settings page.

Does this bug happen each time you save and reload in logic? Does it happen when LiveSlice is the only plugin loaded?

(btw: you can reset all parameters by right clicking the "reset" button)

Thanks for testing
http://www.livelab.dk - slice up your life

Optomadic
KVRAF
6125 posts since 18 Oct, 2007

Post Wed Mar 26, 2008 7:24 am

This might sound strange but is there a way to setup a controller to switch loops automatically?
Image
stay juicy!

Trip-
KVRer
18 posts since 15 Oct, 2003

Post Thu Mar 27, 2008 9:46 pm

ohm,

I don't have any midi controllers setup.

I've tried to save a song again with liveslice after loading a loop and doing some random pitch change, and after reopening, liveslice doesn't show a loop in the arranger even, the events are empty - except ONE event in the middle.
Of course all the pitch information was lost.

There's a problem reopening a song with the plugin. This is not the case with 1.46 though.
Interesting job...

Trip-
KVRer
18 posts since 15 Oct, 2003

Post Fri Mar 28, 2008 3:08 am

hmm my mistake :)
prob was that I had both 1.46 and 1.47 in the vst directory, this somehow made logic to reopen the project with the 1.46 instead of the 1.47...

I took the 1.46 out and now it reopens perfectly.

Now here's a screenshot of the file browser sort issue:

Image

this was both on 1.46 and 1.47.

cheers,
sorry for the confusion in the begining.
Interesting job...

User avatar
musikmachine
KVRAF
8627 posts since 2 Oct, 2006 from Leeds, UK

Post Sat Mar 29, 2008 3:06 am

Optomadic wrote:This might sound strange but is there a way to setup a controller to switch loops automatically?


You mean like using a knob or button to select them instead of the keys?
Latest release and Socials: https://linktr.ee/ph.i.ltr3

Optomadic
KVRAF
6125 posts since 18 Oct, 2007

Post Sat Mar 29, 2008 3:52 am

What I meant to say was can selecting a new loop from the browser be automated somehow.
Image
stay juicy!

Return to “Livelab.dk”