EchoMelt2 not loading?

Official support for: psychicmodulation.com
KVRer
1 posts since 4 May, 2021

Post Tue May 04, 2021 1:45 am

Hey,

So I purchased Echo Melt 2 last night and am still not able to load it up in FL studio. I'm running the install directly from the .zip folder from the purchase, am installing in my usual VST folder, FL studio is recognising the addition of the VST, I'm able to add it to an effects list... but when I actually try and load Echomelt onto an effects channel I'm getting an error message that say 'FL studio was unable to load the plug-in for unknown reasons' or something like that.

I've had a look through the forum and can see there were issues with a DAW not recognising Echomelt that seemed to resolved by updating C++ - so I've done that just in case, but it didn't help. I've tried installing it into a different folder and loading from there, I've tried uninstalling and re-installing the VST but it seems no matter what I do I'm still getting the same error message when trying to actually load it up.

I've sent a message to the developers to ask for help but haven't heard back yet so thought I'd ask for help here too as I'm really keen to try this product out!

Many thanks

Return to “Psychic Modulation”