How to fix latency of VST plugin?

Official support for: mutools.com
replicant X
KVRist
173 posts since 30 Jun, 2009 from moon

Post Mon May 09, 2016 12:47 am

Hi.
I'm new to Mulab.
I want to know how to fix latency of VST plugins.
I searched MuLab 7 Docs but I can't find any information.
Please help me.
I lost totally 5 software that use online activation and the developers disappeared.

mutools
KVRAF
9580 posts since 24 Jun, 2008 from Europe

Re: How to fix latency of VST plugin?

Post Mon May 09, 2016 1:14 am

MuLab does not yet support APDC. The only way of compensating for plugin delays is to insert the relevant delays manually. The principle is: If VST plug X has a delay of N samples the you need to delay all other signals with N samples before mixing it with VST plug X. The module that is ideal for this is the Pure Delay module as you can set it to a sample precise delay.

replicant X
KVRist
173 posts since 30 Jun, 2009 from moon

Re: How to fix latency of VST plugin?

Post Mon May 09, 2016 4:51 am

Thank you for the reply.

It's a very odd thing.
Because "Plugin window > Options > Show Info > Initial Delay" have the latency parameter.
So mulabe can recognise the latency, then only add a certain delay to other buses...

And I noticed Pure Delay does not have "Process On/Off" button.
So I can't off it from the Rack view, I have to "Delete" and re-Insert it.
I'm sorry but It's boring...
I lost totally 5 software that use online activation and the developers disappeared.

mutools
KVRAF
9580 posts since 24 Jun, 2008 from Europe

Re: How to fix latency of VST plugin?

Post Mon May 09, 2016 5:52 am

replicant X wrote:It's a very odd thing.
Because "Plugin window > Options > Show Info > Initial Delay" have the latency parameter.
So mulabe can recognise the latency, then only add a certain delay to other buses...
It may seem simple, but it's less simple to implement than it seems. Anyway it's on the wishlist to add APDC.
And I noticed Pure Delay does not have "Process On/Off" button.
So I can't off it from the Rack view, I have to "Delete" and re-Insert it.
Indeed that module can use an on/off button too. Taken note.

User avatar
pljones
KVRAF
6323 posts since 8 Feb, 2003 from London, UK

Re: How to fix latency of VST plugin?

Post Mon May 09, 2016 9:20 am

replicant X wrote:Because "Plugin window > Options > Show Info > Initial Delay" have the latency parameter.
So mulabe can recognise the latency, then only add a certain delay to other buses...
Think outside the rack idiom and in the modular idiom and you'll see why it's less obvious - there can be multiple paths into and out of every module and of course some of the inputs to a module may also directly feed into some of the outputs of that module - directly or indirectly via other modules. And every one of those may have an amount of delay that needs to be taken into account.

replicant X
KVRist
173 posts since 30 Jun, 2009 from moon

Re: How to fix latency of VST plugin?

Post Mon May 09, 2016 10:25 am

How about a simple solution.
Only 1 levels can be applied, and when it have multipaths, then longer latency are applied and alert to user.
Then user manually text in and apply.

PDC can be applied to each racks of "Mixing Desk" only.
Ignore the busses that inside of the modulars, and sends.

Because another Belgian DAW company do like that, and only few people complain this solution.
I lost totally 5 software that use online activation and the developers disappeared.

User avatar
pljones
KVRAF
6323 posts since 8 Feb, 2003 from London, UK

Re: How to fix latency of VST plugin?

Post Mon May 09, 2016 1:29 pm

How does this sound?

You're aiming to align outputs that hit the same audio out. You can find a Rack that has an audio out as its output. Then each rack that feeds that rack as its output (not sends) would have its overall delay measured and adjusted so they aligned. Then you find any other Racks with the same audio out and, if found, similarly ensure they're all compensated just before the output. (Then repeat for any other audio outs.) (Maybe have an option to align regardless of "same out" or not.)

You'd not need to look into any module (other than a Mixing Desk Rack) and this would only affect MuLab, not MuX.

replicant X
KVRist
173 posts since 30 Jun, 2009 from moon

Re: How to fix latency of VST plugin?

Post Mon May 09, 2016 5:43 pm

pljones wrote:How does this sound?

You're aiming to align outputs that hit the same audio out. You can find a Rack that has an audio out as its output. Then each rack that feeds that rack as its output (not sends) would have its overall delay measured and adjusted so they aligned. Then you find any other Racks with the same audio out and, if found, similarly ensure they're all compensated just before the output. (Then repeat for any other audio outs.) (Maybe have an option to align regardless of "same out" or not.)

You'd not need to look into any module (other than a Mixing Desk Rack) and this would only affect MuLab, not MuX.
Yes.
It's what I want.
I lost totally 5 software that use online activation and the developers disappeared.

User avatar
Scrubbing Monkeys
KVRian
597 posts since 21 Apr, 2017 from Bahia, Brazil

Re: How to fix latency of VST plugin?

Post Tue Jan 30, 2018 10:55 am

replicant X wrote:
pljones wrote:How does this sound?

You're aiming to align outputs that hit the same audio out. You can find a Rack that has an audio out as its output. Then each rack that feeds that rack as its output (not sends) would have its overall delay measured and adjusted so they aligned. Then you find any other Racks with the same audio out and, if found, similarly ensure they're all compensated just before the output. (Then repeat for any other audio outs.) (Maybe have an option to align regardless of "same out" or not.)

You'd not need to look into any module (other than a Mixing Desk Rack) and this would only affect MuLab, not MuX.
Yes.
It's what I want.
Can someone provide a typical scenario for this. I think I understand it, but still a little unsure.

thanks

Highvoltage
KVRian
533 posts since 8 Dec, 2004

Re: How to fix latency of VST plugin?

Post Wed Apr 25, 2018 11:11 am

Edit VST Initial Delay setting is not saved with presets...

Return to “MUTOOLS”