Some basic submenus don't work in Linux

Official support for: mutools.com
ViktorNova
KVRer
4 posts since 12 Sep, 2013 from USA - Portland, Oregon

Post Mon Mar 12, 2018 1:58 am

MuLab 7 for the most part works great in Linux, however there are some basic submenus that don't work at all:

Right click on track panel > Choose Target Module
Right click on track panel > Choose MIDI Channel
Right click on track panel > Add automation sub-track
Right click on track panel > Choose automation type

When these options are clicked, nothing happens except for the menu disappearing. The secondary menu does not pop up like it's supposed to.

I know MuLab is not officially supported on Linux, but it works so well and I'm hoping this issue might make enough sense to where it would be easy to fix!? Not having these options severely limits MuLab's usefulness on this platform.

I am using Ubuntu 16.04 with Wine 3.0 (latest version) 64bit

Thank you!
-Viktor

User avatar
Rameses
KVRist
130 posts since 9 Mar, 2018 from Frankfurt am Main, Germany

Re: Some basic submenus don't work in Linux

Post Mon Mar 12, 2018 2:02 am

What a surprise... :D
For DISCOGRAPHY, see К Ɱ Ԏ Ꮇ Ꮩ Ꭶ Ꭵ Ꮳ

User avatar
ElizabethAS
KVRer
28 posts since 17 Sep, 2016

Re: Some basic submenus don't work in Linux

Post Tue Mar 13, 2018 12:58 pm

I also use Linux, using ML on Wine. Here's the solution:

- Go to winecfg
- Go to graphics
- Unselect everything on the top section
- Select "emulate virtual desktop" (DON'T FORGET: put in the resolution you want (it should be smaller than your screen resolution))

I don't know why it works, but it does. But there's an issue. If you click on a window of, let's say a VST, it won't stay on top if you click on the DAW itself. Haven't found a fix for this yet
Also known as: Pink Mayo.

ViktorNova
KVRer
4 posts since 12 Sep, 2013 from USA - Portland, Oregon

Re: Some basic submenus don't work in Linux

Post Tue Mar 13, 2018 4:49 pm

Wow thank you so much ElizabethAS, this totally fixed my problem! I didn't even think to try that.

BTW, for me the only option that was necessary for to un-check
"Allow the window manager to control the windows"
it was not necessary to emulate a virtual desktop (which I'm happy about!). Unfortunately I'm still experiencing the same issue as you with this causing VSTs, etc to go behind the main window when they loose focus, although this does not happen with the above option checked.

This is a great workaround, thanks again

Return to “MUTOOLS”