MuLab 8.0.49 Beta

Official support for: mutools.com
mutools
KVRAF
9741 posts since 24 Jun, 2008 from Europe

Post Mon Mar 11, 2019 2:35 pm

PS: Well, ok, i understand that rounded corners for note events in the piano roll may not be relevant. So the next M8.0.47 simply always uses squared corners again for note events in the piano roll, like in M7.

mutools
KVRAF
9741 posts since 24 Jun, 2008 from Europe

Re: MuLab 8.0.47 Beta

Post Mon Mar 11, 2019 3:13 pm

M8.0.47 is available in http://www.mutools.com/mulab/m8/

What's changed:
  • Piano roll editor: Notes are drawn as squared rectangles again, like in M7.
  • Sub-menus now automatically open when hovering them. You can define the hold time via the new "Auto Open Sub-Menu Delay Time" preference. Default is 250 ms.
How to update:
Windows: Replace the current MuLab.exe and MuLab.ID by the new versions.
MacOS: Replace the current MuLab.app by the new version.

User avatar
sl23
KVRAF
1504 posts since 28 Mar, 2008 from U.K.

Re: MuLab 8.0.47 Beta

Post Mon Mar 11, 2019 4:14 pm

Thank you for fixing the Sub Menu's.

Was this planned or due to the comments?

EDIT: Works fantastically and is a major improvement! Thank you!!!
Live for an ideal and leave no place in the mind for anything else.

- MuLab and MuX Patches
- SyMenu -

User avatar
Suono & Computer
KVRist
65 posts since 14 Nov, 2016 from Italy

Re: MuLab 8.0.47 Beta

Post Tue Mar 12, 2019 12:27 am

I think that to write the notes on the piano roll, you could eliminate the pencil. I try to explain myself better: with the mouse arrow click with the left button and write the note (even listening to it). Always with the left button and the mouse arrow, the same note can be stretched and / or shortened. Passing over the written note and clicking instead with the right button, here you can delete the note. This avoids and / or eliminates the continuous transition between the pencil function and the arrow function. The whole makes handwriting faster and easier. For dynamic events (those under the roll plan) I would add the line function, which allows you to draw a straight line that matches all the events made with the same dynamic. What do you think?

mutools
KVRAF
9741 posts since 24 Jun, 2008 from Europe

Re: MuLab 8.0.47 Beta

Post Tue Mar 12, 2019 2:15 am

With the arrow cursor you can doubleclick or [Ctrl]+click to draw notes so no need to switch to the pencil. See http://www.mutools.com/mulab/m8/docs/mu ... ditor.html

User avatar
Michael L
KVRAF
2543 posts since 25 Jan, 2014 from the End of the World as we Knowit

Re: MuLab 8.0.47 Beta

Post Tue Mar 12, 2019 2:53 am

I am on OSX 10.11.6. When I open a new MuLab beta version for the first time, the logo bounces, I click, confirm open, then the logo bounces again, I click open and Mulab opens. But when I open that same version for the second time, I get a message "you are opening this app for the first time..." and the bouncing logo, etc.
Also, when I open Edit Preferences in 8.0.47, select a preference, then Edit and change the value and OK, it does not change and MuLab becomes unresponsive until I click on another app. Then it reverts back to the Edit window, I click OK, it changes, then Done and all is well.
I can replicate both of these behaviors. This seems to be an OSX issue; does this occur with anyone else on Mac ?
(Note: other than this, it works great!)

carllackey
KVRist
232 posts since 7 May, 2009

Re: MuLab 8.0.47 Beta

Post Tue Mar 12, 2019 5:58 am

ok gentlemen, switched to my pc. downloaded from the site freddo had in his response. the first link worked, but the update link was 1 404 error. i downloaded it and extracted all but it still says a subfolder is missing. i own s1 pro, reason 10, waveform 10, and mixcraft pro 8 and have never had a problem downloading/updating these. also i am no computer expert. so i don't know where to move the files or how to do them, like i said before,this seems slightly difficult to me.

mutools
KVRAF
9741 posts since 24 Jun, 2008 from Europe

Re: MuLab 8.0.47 Beta

Post Tue Mar 12, 2019 6:00 am

Which link gives a 404 ?

carllackey
KVRist
232 posts since 7 May, 2009

Re: MuLab 8.0.47 Beta

Post Tue Mar 12, 2019 7:15 am


mutools
KVRAF
9741 posts since 24 Jun, 2008 from Europe

Re: MuLab 8.0.47 Beta

Post Tue Mar 12, 2019 7:31 am

And where do you see that link? On which webpage?

User avatar
dakkra
KVRian
875 posts since 4 Oct, 2012 from Utah

Re: MuLab 8.0.47 Beta

Post Tue Mar 12, 2019 9:09 am

carllackey wrote:
Tue Mar 12, 2019 7:15 am
this one http://www.mutools.com/mulab/m8/mulab-8 ... 64-exe.zip
That's not a proper endpoint. That "..." in the middle of the url doesn't work :dog:

User avatar
pljones
KVRAF
6410 posts since 8 Feb, 2003 from London, UK

Re: MuLab 8.0.47 Beta

Post Tue Mar 12, 2019 1:40 pm

Looks like you cut-n-paste the link, rather than clicking it - plus you shouldn't go to any link except either the latest from "mutools" or the one in the first post in this topic. Links elsewhere _*WILL*_ get stale -- because this product gets updated and the out of date files get removed. The instructions are simple and in the first post: (1) get the main ZIP, (2) unpack it, (3) get the update ZIP and replace the App (or EXE + ID on Windows) from that.

mutools
KVRAF
9741 posts since 24 Jun, 2008 from Europe

Re: MuLab 8.0.47 Beta

Post Tue Mar 12, 2019 5:58 pm

Tip of the day: Something that was not yet mentioned in the docs:
[Shift]+click a collapse/expand button at the top-left of a rack collapses/expands all racks at the same time.

http://www.mutools.com/mulab/m8/docs/mux/rack.html

User avatar
pekbro
KVRAF
2400 posts since 29 Sep, 2010 from Maui

Re: MuLab 8.0.47 Beta

Post Thu Mar 14, 2019 11:07 pm

Anyone able to get the event input module to work? I cant get it to see any ports
although they are listed in the midi setup. Win 8...

User avatar
pljones
KVRAF
6410 posts since 8 Feb, 2003 from London, UK

Re: MuLab 8.0.47 Beta

Post Thu Mar 14, 2019 11:25 pm

pekbro wrote:
Thu Mar 14, 2019 11:07 pm
Anyone able to get the event input module to work? I cant get it to see any ports
although they are listed in the midi setup. Win 8...
I get "None" listed. Connecting an Event Monitor shows no events, regardless of focus. However, disconnecting the Event Monitor from the Event Input and having it focussed shows events, so it's not clear what the Event Input module is doing at project level.

Return to “MUTOOLS”