[BUG] Meta-parameter & Rack

Official support for: mutools.com
dreammachine_nl
KVRer
13 posts since 23 Jun, 2004

Post Fri Nov 01, 2019 9:19 am

I recently midi-retrofitted an old Yamaha 01X which has motorised faders. These faders can now be set via midi CC. It would be cool if the faders could be synchronised with the gain slider of a Rack. Since the gain slider of a Rack does not output any event/modulation signal, I thought I found a workaround via the Meta-parameters. This workaround actually works in conjunction with a Mixer Strip module :), but not with a Rack.

While doing some tests for this workaround, I think I found a bug, but it could also be a feature that is not (yet) implemented; if so, I will change the title of this topic to [FR]...

Hopefully this video makes the bug/FR clear enough:
https://rushfiles.one/client/publiclink ... t54OQHplbo

Thanks for looking into this,
TDM

dreammachine_nl
KVRer
13 posts since 23 Jun, 2004

Re: [BUG] Meta-parameter & Rack

Post Fri Nov 15, 2019 7:49 am

By the way, the tests were initially done with MuLab 7.7.4 (demo), but in the latest version 8.3.3 (beta-demo) the bug/FR remains.

By way of thread bump :wink:

mutools
KVRAF
10274 posts since 24 Jun, 2008 from Europe

Re: [BUG] Meta-parameter & Rack

Post Sat Nov 16, 2019 1:52 am

I see the issue. Not an easy one. Will need some time to think this thru.
Meanwhile you can bypass the issue by doing this:
After you have dragged the rack slider on the meta-parameter, double-click that meta-parm and change the assignment for that rack slider from Audio Mixer Strip Gain to Rack Gain. Then you should be able to do what you want.

dreammachine_nl
KVRer
13 posts since 23 Jun, 2004

Re: [BUG] Meta-parameter & Rack

Post Sat Nov 16, 2019 11:21 am

The Rack Gain solution works nicely, thanks for the reply. This solution also works for the Panning and Width knob of a Rack. You really made an amazing piece of software!

A quick fix to this problem might be to automatically assign the 'Drag parameter' to 'Rack Gain/Panning/Width' instead of 'Rack Mixer Strip Gain/Panning/Width'. Or just remove the target module 'Rack Mixer Strip Gain/Panning/Width'? It seems redundant.

To elaborate on (or maybe help you with) the main issue: attach the 'Rack Gain' to a meta-parameter. Mouseclick and move the Rack slider -> the MP also moves (=your suggested solution).
Now, Drag drop the 'Rack Mixer Strip Gain' parameter onto a Track and automate this with a curve. The Rack Gain slider will move, but not the MP; so there is a difference between moving a slider/knob by means of the internal modulation events and the mouse 'onClick' event.
Changing the 'Target Module' of the Track to 'Rack Gain' doesn't make a difference. The automation curve will move the Rack Gain slider, but not the MP. Again, moving the Rack Gain slider with a mouseclick event will move the MP.

Digging even a little deeper: it is possible to assign the Rack Mute Button to a meta-parameter via 'Rack Mute' or 'Rack Mixer Strip Mute'. In this case, not even a mouseclick event on the Mute button will activate the meta-parameter. (If this gets solved, we could even detect a mute/unmute event and turn on some lights on the 01X -or whatever mackie-like controller- :-) , only problem is that we're probably running out of meta-parameters at some point...).

Anyway, no serious priorities, I think, given the workarounds you've mentioned.
Thanks again,
TDM

[EDIT] Wait, there might be a serious bug actually: I just discovered that it is also not possible to track-automate the meta-parameters of the 'Project Mux Modular Modular Area'? Is this intended behaviour? And Modular Modular, I noticed.[/EDIT]

mutools
KVRAF
10274 posts since 24 Jun, 2008 from Europe

Re: [BUG] Meta-parameter & Rack

Post Wed Nov 20, 2019 2:24 pm

About the initial issue you posted, that has been fixed in M8.3.4, see viewtopic.php?p=7580224#p7580224
Wait, there might be a serious bug actually: I just discovered that it is also not possible to track-automate the meta-parameters of the 'Project Mux Modular Modular Area'? Is this intended behaviour? And Modular Modular, I noticed.
Solution: Add an Event Input module to the Project MUX, then you'll be able to automate its meta-parms.

dreammachine_nl
KVRer
13 posts since 23 Jun, 2004

Re: [BUG] Meta-parameter & Rack

Post Mon Nov 25, 2019 10:56 am

Thanks for fixing the one and posting the solution to the other!

Regards,
TDM

Return to “MUTOOLS”