MuLab & MUX Plugin 8.6.9

Official support for: mutools.com
mutools
KVRAF
10557 posts since 24 Jun, 2008 from Europe

Post Tue Apr 07, 2020 12:02 pm

What samplerate & blocksize are you using?
You can quickly check that via a right-click on the cpu meter -> Audio Engine Stats.

dreammachine_nl
KVRist
30 posts since 23 Jun, 2004

Re: MuLab 8.6.0 beta

Post Tue Apr 07, 2020 12:19 pm

Sample rate: 48000
Block size: 512

mutools
KVRAF
10557 posts since 24 Jun, 2008 from Europe

Re: MuLab 8.6.0 beta

Post Tue Apr 07, 2020 12:20 pm

Confirmed bug! (new bug in M8.6.0)
The fix is in the pipeline.
Thx for reporting this!

mutools
KVRAF
10557 posts since 24 Jun, 2008 from Europe

Re: MuLab 8.6.1 beta

Post Tue Apr 07, 2020 12:37 pm

MuLab 8.6.1 is available in http://www.mutools.com/mulab/beta/

What's changed:
  • When a composer track sends to a module, but the module is not processed because eg its parent rack is switched off, this could lead to general MIDI silence. Fixed.
  • Step sequencer: When showing knobs for CC values, the knob was too big. Fixed.
  • The Editor Navigation preference has extra options so to indicate you prefer a vertical action.
  • Depending on the audio engine settings, previewing MuClips could cause serious problems. Fixed.
How to update MuLab:
Windows: Replace the current MuLab.exe and MuLab.ID by the new versions.
MacOS: Replace the current MuLab.app by the new version.

dreammachine_nl
KVRist
30 posts since 23 Jun, 2004

Re: MuLab 8.6.1 beta

Post Tue Apr 07, 2020 12:59 pm

mutools wrote:
Tue Apr 07, 2020 12:37 pm
  • Depending on the audio engine settings, previewing MuClips could cause serious problems. Fixed.
That's fast :clap:

Dominsane
KVRer
3 posts since 16 Apr, 2007

Re: MuLab 8.6.1 beta

Post Tue Apr 07, 2020 3:10 pm

Thanks a lot for the two new scrolling options: we could have had a debate forever about it, but finally you made everyone satisfied about it :tu: :tu: :tu:

dreammachine_nl
KVRist
30 posts since 23 Jun, 2004

Re: MuLab 8.6.1 beta

Post Thu Apr 09, 2020 2:24 am

Mulab 8.6.1 beta (32 bit): there is a small bug when the midi channel of a track is changed via right click 'Choose Midi Channel'. The midi channel is not instantly updated; I noticed this when I was using a hardware synth and verified it by monitoring the midi stream with the Event Monitor module. To actually realise the midi channel change, you first have to click on the track in question (highlight/focus it).

mutools
KVRAF
10557 posts since 24 Jun, 2008 from Europe

Re: MuLab 8.6.1 beta

Post Thu Apr 09, 2020 2:44 am

I can't repeat this. Please give a step by step, preferably starting from a new project. Thx.

dreammachine_nl
KVRist
30 posts since 23 Jun, 2004

Re: MuLab 8.6.1 beta

Post Thu Apr 09, 2020 3:21 am

Ok, for example:
  • insert a new track ('Add Track');
  • insert an Event Monitor in Project Modular Area;
  • drag drop Event Monitor to the newly created Track;
  • set focus to the Track, play some notes on your hardware midi keyboard/controller and monitor event via Event Monitor;
  • default the track is set to midi channel 1, so all notes shown in the Event Monitor are on channel 1. So far, so good;
  • right click the Track -> 'Choose Midi Channel' -> set channel to for example channel 5;
  • play some notes on your hardware midi keyboard: the Event Monitor still shows midi on channel 1. Indeed, I now also noticed that via the Virtual Keyboard it updates instantly and the Event Monitor shows channel 5. However, via hardware midi it still stays on channel 1, even after clicking on the Virtual Keyboard, so you'll have to..;
  • left click on the Track;
  • play some notes on your hardware midi keyboard: now the Event Monitor shows midi on channel 5, like it should.
So the midi channel change does register (without any additional actions) on the Virtual Keyboard, but not with external midi hardware: then you need to left click the Track first.

mutools
KVRAF
10557 posts since 24 Jun, 2008 from Europe

Re: MuLab 8.6.1 beta

Post Thu Apr 09, 2020 3:46 am

Can repeat it, thx! Will fix that.

dreammachine_nl
KVRist
30 posts since 23 Jun, 2004

Re: MuLab 8.6.1 beta

Post Thu Apr 09, 2020 5:16 am

Thanks! Also, if you set the Track to 'Per Part' midi channel, there are some inconsistencies (also with the Virtual Keyboard), I guess.

Follow these steps for example:
  • create two Parts on one Track (midi channel: Per Part) and set those parts to different midi channels;
  • focus on one of the parts and go to the Edit area; now click on the keyboard inside the Edit area (or draw some notes and press play);
  • the Track will send notes on the assigned midi channel of that Part (which works correctly)
Now (still inside the Edit area of that same part):
  • play some notes via the external midi Keyboard or via the Virtual Keyboard;
  • I guess the Track should still send notes on the assigned midi channel of that part we are working on, right? But it doesn't necessarily. If it does by coincidence, just..
  • go to the Edit area of the other Part to see what I mean
Now, start working inside the Composer Area: we see those two parts. I guess it would also make sense when you highlight/focus/left click on one of the parts, the track midi channel would correspond to the midi channel of the focused Part when you play notes via the external hardware keyboard or the Virtual Keyboard. Am I right? It doesn't, but the Track is on the midi channel of the Part that was set last, or something.

A problem occurs when none of the Parts are selected/focused (or multiple at the same time). On what midi channel should the notes of the external hardware keyboard or Virtual Keyboard be sent? I don't actually know what would work best in that case.

I hope what I'm saying makes sense.

mutools
KVRAF
10557 posts since 24 Jun, 2008 from Europe

Re: MuLab 8.6.1 beta

Post Sat Apr 11, 2020 1:25 am

Yes it sure makes sense. In the next update some of these aspects will be finetuned.

keel
KVRian
824 posts since 27 Oct, 2004 from Inside the kick drum

Re: MuLab 8.6.1 beta

Post Sat Apr 11, 2020 2:03 am

Superb Jo, that you added the third option for the scrolling! Thanks for that! But now the problem is, if I choose this new option, holding CTRL and scroll, it change height, aka vertical zoom. Holding the ALT and scroll, it scrolls sideways, which is fine. Holding SHIFT and scroll, doesn't seems to do anything? How I am now going to zoom in and out, aka horizontal zoom? Only way to do it is just to use those super tiny + and - buttons.

Can you add holding shift and scroll would do the horizontal zoom? Because now the only way to do it, are those tiny buttons, and it is quite frustrating. Thanks!

mutools
KVRAF
10557 posts since 24 Jun, 2008 from Europe

Re: MuLab 8.6.1 beta

Post Sat Apr 11, 2020 2:14 am

keel wrote:
Sat Apr 11, 2020 2:03 am
How I am now going to zoom in and out, aka horizontal zoom?
The [Ctrl] modifier switches between zoom <> scroll
The [Alt] modifier switches between horizontal <> vertical
If your preference is "Mouse Wheel Scrolls (Pref. Vertically)" then you can zoom horizontally by holding both [Ctrl] and [Alt]

keel
KVRian
824 posts since 27 Oct, 2004 from Inside the kick drum

Re: MuLab 8.6.1 beta

Post Sat Apr 11, 2020 2:18 am

mutools wrote:
Sat Apr 11, 2020 2:14 am
keel wrote:
Sat Apr 11, 2020 2:03 am
How I am now going to zoom in and out, aka horizontal zoom?
The [Ctrl] modifier switches between zoom <> scroll
The [Alt] modifier switches between horizontal <> vertical
If your preference is "Mouse Wheel Scrolls (Pref. Vertically)" then you can zoom horizontally by holding both [Ctrl] and [Alt]
Oh, my bad :oops: I needed to hold both, ctrl and alt. However, I would prefer it to be just in one button, you know. And while holding shift doesn't seems do anything, why you can't add horizontal zoom to it? :oops:

Return to “MUTOOLS”